summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-02-15 12:09:02 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-02-15 12:09:02 +0000
commit0ab1040e6058b934148885be88fed2dfb25d37c7 (patch)
tree891c8402305489a10f08f297ab4ab9a97035a010
parentVersion bump msnlib to 3.8. (diff)
downloadgentoo-2-0ab1040e6058b934148885be88fed2dfb25d37c7.tar.gz
gentoo-2-0ab1040e6058b934148885be88fed2dfb25d37c7.tar.bz2
gentoo-2-0ab1040e6058b934148885be88fed2dfb25d37c7.zip
Version bump to latest.
(Portage version: 2.2.0_alpha86/cvs/Linux x86_64)
-rw-r--r--media-gfx/graphite2/ChangeLog11
-rw-r--r--media-gfx/graphite2/files/graphite2-1.1.0-includes-libs-perl.patch13
-rw-r--r--media-gfx/graphite2/files/graphite2-fix_wrong_linker_opts.patch7
-rw-r--r--media-gfx/graphite2/graphite2-1.1.0.ebuild95
4 files changed, 117 insertions, 9 deletions
diff --git a/media-gfx/graphite2/ChangeLog b/media-gfx/graphite2/ChangeLog
index 574dc94b45dc..ce4bd550557e 100644
--- a/media-gfx/graphite2/ChangeLog
+++ b/media-gfx/graphite2/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-gfx/graphite2
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphite2/ChangeLog,v 1.19 2011/12/18 20:42:45 halcy0n Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphite2/ChangeLog,v 1.20 2012/02/15 12:09:02 scarabeus Exp $
+
+*graphite2-1.1.0 (15 Feb 2012)
+
+ 15 Feb 2012; Tomáš Chvátal <scarabeus@gentoo.org> +graphite2-1.1.0.ebuild,
+ files/graphite2-fix_wrong_linker_opts.patch,
+ +files/graphite2-1.1.0-includes-libs-perl.patch:
+ Version bump to latest.
18 Dec 2011; Mark Loeser <halcy0n@gentoo.org> graphite2-1.0.3-r1.ebuild:
Stable for ppc; bug #387187
diff --git a/media-gfx/graphite2/files/graphite2-1.1.0-includes-libs-perl.patch b/media-gfx/graphite2/files/graphite2-1.1.0-includes-libs-perl.patch
new file mode 100644
index 000000000000..3c32b11481d8
--- /dev/null
+++ b/media-gfx/graphite2/files/graphite2-1.1.0-includes-libs-perl.patch
@@ -0,0 +1,13 @@
+--- graphite2-0.9.3.orig/contrib/perl/Build.PL
++++ graphite2-0.9.3/contrib/perl/Build.PL
+@@ -8,8 +8,8 @@ my $builder = Module::Build->new(
+ dist_author => 'Simon Cozens <simon@cpan.org>',
+ dist_version_from => 'lib/Text/Graphite2.pm',
+ extra_compiler_flags => $^O ne 'MSWin32' ? '-Wall -Wno-unused-variable' : '',
+- extra_linker_flags => $^O eq 'MSWin32' ? '../../build/src/graphite2.lib' : '-lgraphite2',
+- include_dirs => ['.'],
++ extra_linker_flags => extra_linker_flags => $^O eq 'MSWin32' ? '../../build/src/graphite2.lib' : '-L @BUILD_DIR@ -lgraphite2',
++ include_dirs => ['.', '../../include'],
+ requires => {
+ 'Test::More' => 0,
+ },
diff --git a/media-gfx/graphite2/files/graphite2-fix_wrong_linker_opts.patch b/media-gfx/graphite2/files/graphite2-fix_wrong_linker_opts.patch
index 77d1206e7bd3..edacd73629f3 100644
--- a/media-gfx/graphite2/files/graphite2-fix_wrong_linker_opts.patch
+++ b/media-gfx/graphite2/files/graphite2-fix_wrong_linker_opts.patch
@@ -9,10 +9,3 @@ diff -urN graphite2-1.0.1.old/src/CMakeLists.txt graphite2-1.0.1/src/CMakeLists.
if (${CMAKE_CXX_COMPILER} MATCHES ".*mingw.*")
target_link_libraries(graphite2 "-lkernel32 -lmsvcr90 -lmingw32 -lgcc -luser32")
else (${CMAKE_CXX_COMPILER} MATCHES ".*mingw.*")
-@@ -121,4 +120,4 @@
-
-
- install(TARGETS graphite2 EXPORT graphite2 LIBRARY DESTINATION lib${LIB_SUFFIX} ARCHIVE DESTINATION lib${LIB_SUFFIX} PUBLIC_HEADER DESTINATION include/graphite2 RUNTIME DESTINATION bin)
--install(EXPORT graphite2 DESTINATION share/graphite2 NAMESPACE gr2_)
-\ Chybí znak konce řádku na konci souboru
-+install(EXPORT graphite2 DESTINATION share/graphite2 NAMESPACE gr2_)
diff --git a/media-gfx/graphite2/graphite2-1.1.0.ebuild b/media-gfx/graphite2/graphite2-1.1.0.ebuild
new file mode 100644
index 000000000000..f39c117fb0eb
--- /dev/null
+++ b/media-gfx/graphite2/graphite2-1.1.0.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphite2/graphite2-1.1.0.ebuild,v 1.1 2012/02/15 12:09:02 scarabeus Exp $
+
+EAPI=4
+
+inherit base cmake-utils perl-module
+
+DESCRIPTION="Library providing rendering capabilities for complex non-Roman writing systems"
+HOMEPAGE="http://graphite.sil.org/"
+SRC_URI="mirror://sourceforge/silgraphite/${PN}/${P}.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="perl test"
+
+RDEPEND="
+ perl? ( dev-lang/perl )
+"
+DEPEND="${RDEPEND}
+ perl? ( virtual/perl-Module-Build )
+ test? (
+ dev-libs/glib:2
+ media-libs/fontconfig
+ media-libs/silgraphite
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.1.0-includes-libs-perl.patch"
+ "${FILESDIR}/${PN}-fix_wrong_linker_opts.patch"
+ "${FILESDIR}/${PN}-1.0.2-no_harfbuzz_tests.patch"
+ "${FILESDIR}/${PN}-1.0.3-no-test-binaries.patch"
+)
+
+pkg_setup() {
+ use perl && perl-module_pkg_setup
+}
+
+src_prepare() {
+ base_src_prepare
+
+ # fix perl linking
+ if use perl; then
+ _check_build_dir init
+ sed -i \
+ -e "s:@BUILD_DIR@:\"${CMAKE_BUILD_DIR}/src\":" \
+ contrib/perl/Build.PL || die
+ fi
+
+ # make tests optional
+ if ! use test; then
+ sed -i \
+ -e '/tests/d' \
+ CMakeLists.txt || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ "-DVM_MACHINE_TYPE=direct"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ if use perl; then
+ cd contrib/perl
+ perl-module_src_prep
+ perl-module_src_compile
+ fi
+}
+
+src_test() {
+ cmake-utils_src_test
+ if use perl; then
+ cd contrib/perl
+ perl-module_src_test
+ fi
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use perl; then
+ cd contrib/perl
+ perl-module_src_install
+ fixlocalpod
+ fi
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
+
+}