summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2001-08-31 16:06:43 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2001-08-31 16:06:43 +0000
commit0c78e16af2f11a7377746ed6f8595c7809bd33dc (patch)
tree7bb0be78b808a925d81bf6743a0613b75d36f599
parentmajor fixes to very weird docs (diff)
downloadgentoo-2-0c78e16af2f11a7377746ed6f8595c7809bd33dc.tar.gz
gentoo-2-0c78e16af2f11a7377746ed6f8595c7809bd33dc.tar.bz2
gentoo-2-0c78e16af2f11a7377746ed6f8595c7809bd33dc.zip
New version of fetchmail.
-rw-r--r--net-mail/fetchmail/fetchmail-5.9.0.ebuild42
-rw-r--r--net-mail/fetchmail/files/digest-fetchmail-5.9.01
2 files changed, 43 insertions, 0 deletions
diff --git a/net-mail/fetchmail/fetchmail-5.9.0.ebuild b/net-mail/fetchmail/fetchmail-5.9.0.ebuild
new file mode 100644
index 000000000000..318ecab36102
--- /dev/null
+++ b/net-mail/fetchmail/fetchmail-5.9.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Parag Mehta <pm@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-5.9.0.ebuild,v 1.1 2001/08/31 16:06:20 g2boojum Exp $
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="fetchmail"
+SRC_URI="http://www.tuxedo.org/~esr/fetchmail/"${P}.tar.gz
+HOMEPAGE="http://www.tuxedo.org/~esr/fetchmail/"
+
+DEPEND="virtual/glibc
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+ if [ "`use ssl`" ] ; then
+ export CFLAGS="$CFLAGS -I/usr/include/openssl"
+ myconf="--with-ssl"
+ fi
+ if [ -z "`use nls`" ] ; then
+ myconf="$myconf --disable-nls"
+ fi
+ try ./configure --prefix=/usr --host=${CHOST} --enable-inet6 \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --enable-RPA --enable-NTLN \
+ --enable-SDPS $myconf
+ try make
+}
+
+
+src_install() {
+ try make DESTDIR=${D} install
+ dodoc FAQ FEATURES ABOUT-NLS NEWS NOTES README README.NTLM README.SSL \
+ TODO COPYING MANIFEST
+ docinto html
+ dodoc *.html
+ docinto contrib
+ dodoc contrib/*
+}
diff --git a/net-mail/fetchmail/files/digest-fetchmail-5.9.0 b/net-mail/fetchmail/files/digest-fetchmail-5.9.0
new file mode 100644
index 000000000000..3b1616b0a911
--- /dev/null
+++ b/net-mail/fetchmail/files/digest-fetchmail-5.9.0
@@ -0,0 +1 @@
+MD5 0bfe6faa6c668d82d5bf67ea3478df68 fetchmail-5.9.0.tar.gz