summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2010-10-31 23:41:55 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2010-10-31 23:41:55 +0000
commit0f92a507a1e7bcf5938b403072b65bed46051aae (patch)
tree8f64d07535d59d1610576fe0de0cdbd71c058b0a
parentUpdate EAPI. Fix dependencies. Set SUPPORT_PYTHON_ABIS. Use PyPI mirrors. (diff)
downloadgentoo-2-0f92a507a1e7bcf5938b403072b65bed46051aae.tar.gz
gentoo-2-0f92a507a1e7bcf5938b403072b65bed46051aae.tar.bz2
gentoo-2-0f92a507a1e7bcf5938b403072b65bed46051aae.zip
Fix LDFLAGS and CXXFLAGS, remove icon extension in desktop file
(Portage version: 2.1.9.23/cvs/Linux x86_64)
-rw-r--r--sci-electronics/gspiceui/ChangeLog6
-rw-r--r--sci-electronics/gspiceui/files/gspiceui-0.9.99-flags.patch27
-rw-r--r--sci-electronics/gspiceui/gspiceui-0.9.99.ebuild13
3 files changed, 37 insertions, 9 deletions
diff --git a/sci-electronics/gspiceui/ChangeLog b/sci-electronics/gspiceui/ChangeLog
index 8d934d242811..77c8b72487f9 100644
--- a/sci-electronics/gspiceui/ChangeLog
+++ b/sci-electronics/gspiceui/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-electronics/gspiceui
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gspiceui/ChangeLog,v 1.2 2010/10/19 09:40:15 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gspiceui/ChangeLog,v 1.3 2010/10/31 23:41:55 dilfridge Exp $
+
+ 31 Oct 2010; Andreas K. Huettel <dilfridge@gentoo.org>
+ gspiceui-0.9.99.ebuild, +files/gspiceui-0.9.99-flags.patch:
+ Fix LDFLAGS and CXXFLAGS, remove icon extension in desktop file
19 Oct 2010; Markos Chandras <hwoarang@gentoo.org> gspiceui-0.9.99.ebuild:
Stable on amd64 wrt bug #341545
diff --git a/sci-electronics/gspiceui/files/gspiceui-0.9.99-flags.patch b/sci-electronics/gspiceui/files/gspiceui-0.9.99-flags.patch
new file mode 100644
index 000000000000..5129929dc159
--- /dev/null
+++ b/sci-electronics/gspiceui/files/gspiceui-0.9.99-flags.patch
@@ -0,0 +1,27 @@
+diff -urN gspiceui-v0.9.99.orig/src/Makefile gspiceui-v0.9.99/src/Makefile
+--- gspiceui-v0.9.99.orig/src/Makefile 2010-04-16 10:43:59.000000000 +0200
++++ gspiceui-v0.9.99/src/Makefile 2010-11-01 00:25:32.000000000 +0100
+@@ -59,13 +59,7 @@
+ INSTALLDIR = /usr/local/bin
+
+ # Compiler options
+-ifeq ($(GSPICEUI_DBG),0)
+- # Options for release (not using -Wall since it's GCC specific)
+- CXXFLAGS := -O -pipe $(shell $(WXCFG) --cxxflags)
+-else
+- # Options for development
+- CXXFLAGS := -Wall -g -pipe $(shell $(WXCFG) --cxxflags)
+-endif
++CXXFLAGS += $(shell $(WXCFG) --cxxflags)
+
+ # Includes
+ INCLUDES = -I/usr/include -I/usr/X11R6/include -I.
+@@ -108,7 +102,7 @@
+ # -o specify the output file name
+
+ $(BINDIR)/$(PROG) : $(OBJS)
+- $(CC) -pipe -o $(BINDIR)/$(PROG) obj/*.o $(LIBS)
++ $(CC) -pipe -o $(BINDIR)/$(PROG) obj/*.o $(LDFLAGS) $(LIBS)
+ ifeq ($(ROOT)/GSpiceUI.app,$(wildcard $(ROOT)/GSpiceUI.app))
+ cp $(BINDIR)/$(PROG) $(ROOT)/GSpiceUI.app/Contents/MacOS/gspiceui
+ endif
diff --git a/sci-electronics/gspiceui/gspiceui-0.9.99.ebuild b/sci-electronics/gspiceui/gspiceui-0.9.99.ebuild
index dbf493779a91..6f33e03fc4fc 100644
--- a/sci-electronics/gspiceui/gspiceui-0.9.99.ebuild
+++ b/sci-electronics/gspiceui/gspiceui-0.9.99.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gspiceui/gspiceui-0.9.99.ebuild,v 1.2 2010/10/19 09:40:15 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gspiceui/gspiceui-0.9.99.ebuild,v 1.3 2010/10/31 23:41:55 dilfridge Exp $
EAPI="2"
WX_GTK_VER="2.8"
-inherit wxwidgets
+inherit eutils wxwidgets
MY_P="${PN}-v${PV}"
@@ -28,11 +28,8 @@ RDEPEND="${DEPEND}
S="${WORKDIR}/${MY_P}"
src_prepare() {
- # Removing pre-configured CXXFLAGS from Makefile. The Makefile then only appends
- # the flags required for wxwidgets to the Gentoo preset.
- sed -i \
- -e "s:CXXFLAGS = -O -pipe:CXXFLAGS += :" \
- src/Makefile || die "Patching src/Makefile failed"
+ # Use Gentoo LDFLAGS and CXXFLAGS
+ epatch "${FILESDIR}/${P}-flags.patch"
# Adjusting the doc path at src/main/HelpTasks.cpp
sed -i \
@@ -57,7 +54,7 @@ src_install() {
doins -r lib/* || die
fi
- make_desktop_entry gspiceui "GNU Spice GUI" gspiceui.xpm "Electronics"
+ make_desktop_entry gspiceui "GNU Spice GUI" gspiceui "Electronics"
}
pkg_postinst() {