summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2013-06-25 17:28:53 +0000
committerDoug Goldstein <cardoe@gentoo.org>2013-06-25 17:28:53 +0000
commit10b39aff6cda93b883699a7cd5a6eca4e40ecab8 (patch)
tree8b46e2fbc01a687bac64e18d09c18bfa2bbb02cf
parentdepend on virtual/texi2dvi with USE=doc as thats what we need here and texliv... (diff)
downloadgentoo-2-10b39aff6cda93b883699a7cd5a6eca4e40ecab8.tar.gz
gentoo-2-10b39aff6cda93b883699a7cd5a6eca4e40ecab8.tar.bz2
gentoo-2-10b39aff6cda93b883699a7cd5a6eca4e40ecab8.zip
The way this package installs we won't be able to support multiple
Python versions so switch to python-single-r1. Additionally the scripts are installed outside of where python_fix_shebang normally runs so we must explicitly fix it up. (Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key D7DFA8D318FA9AEF!)
-rw-r--r--app-emulation/virt-manager/ChangeLog9
-rw-r--r--app-emulation/virt-manager/virt-manager-0.10.0.ebuild12
-rw-r--r--app-emulation/virt-manager/virt-manager-9999.ebuild12
3 files changed, 28 insertions, 5 deletions
diff --git a/app-emulation/virt-manager/ChangeLog b/app-emulation/virt-manager/ChangeLog
index b67fe7518e51..a23c9f5414f4 100644
--- a/app-emulation/virt-manager/ChangeLog
+++ b/app-emulation/virt-manager/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/virt-manager
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/ChangeLog,v 1.83 2013/06/25 14:16:38 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/ChangeLog,v 1.84 2013/06/25 17:28:53 cardoe Exp $
+
+ 25 Jun 2013; Doug Goldstein <cardoe@gentoo.org> virt-manager-0.10.0.ebuild,
+ virt-manager-9999.ebuild:
+ The way this package installs we won't be able to support multiple Python
+ versions so switch to python-single-r1. Additionally the scripts are installed
+ outside of where python_fix_shebang normally runs so we must explicitly fix it
+ up.
25 Jun 2013; Doug Goldstein <cardoe@gentoo.org> virt-manager-0.10.0.ebuild,
virt-manager-9999.ebuild:
diff --git a/app-emulation/virt-manager/virt-manager-0.10.0.ebuild b/app-emulation/virt-manager/virt-manager-0.10.0.ebuild
index e5c9a46e8508..54a53c7f66e4 100644
--- a/app-emulation/virt-manager/virt-manager-0.10.0.ebuild
+++ b/app-emulation/virt-manager/virt-manager-0.10.0.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/virt-manager-0.10.0.ebuild,v 1.3 2013/06/25 14:16:38 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/virt-manager-0.10.0.ebuild,v 1.4 2013/06/25 17:28:53 cardoe Exp $
EAPI=5
#BACKPORTS=
PYTHON_COMPAT=( python{2_6,2_7} )
-#PYTHON_REQ_USE=""
+DISTUTILS_SINGLE_IMPL=1
inherit eutils gnome2 distutils-r1
@@ -63,3 +63,11 @@ distutils-r1_python_compile() {
--qemu-user=qemu \
--default-graphics=${defgraphics}
}
+
+python_install_all() {
+ python_fix_shebang "${ED}/usr/share/virt-manager/virt-clone"
+ python_fix_shebang "${ED}/usr/share/virt-manager/virt-convert"
+ python_fix_shebang "${ED}/usr/share/virt-manager/virt-image"
+ python_fix_shebang "${ED}/usr/share/virt-manager/virt-install"
+ python_fix_shebang "${ED}/usr/share/virt-manager/virt-manager"
+}
diff --git a/app-emulation/virt-manager/virt-manager-9999.ebuild b/app-emulation/virt-manager/virt-manager-9999.ebuild
index 9f552c960f72..5cd682e545db 100644
--- a/app-emulation/virt-manager/virt-manager-9999.ebuild
+++ b/app-emulation/virt-manager/virt-manager-9999.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/virt-manager-9999.ebuild,v 1.16 2013/06/25 14:16:38 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/virt-manager-9999.ebuild,v 1.17 2013/06/25 17:28:53 cardoe Exp $
EAPI=5
#BACKPORTS=
PYTHON_COMPAT=( python{2_6,2_7} )
-#PYTHON_REQ_USE=""
+DISTUTILS_SINGLE_IMPL=1
inherit eutils gnome2 distutils-r1
@@ -63,3 +63,11 @@ distutils-r1_python_compile() {
--qemu-user=qemu \
--default-graphics=${defgraphics}
}
+
+python_install_all() {
+ python_fix_shebang "${ED}/usr/share/virt-manager/virt-clone"
+ python_fix_shebang "${ED}/usr/share/virt-manager/virt-convert"
+ python_fix_shebang "${ED}/usr/share/virt-manager/virt-image"
+ python_fix_shebang "${ED}/usr/share/virt-manager/virt-install"
+ python_fix_shebang "${ED}/usr/share/virt-manager/virt-manager"
+}