summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-08-11 20:27:54 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-08-11 20:27:54 +0000
commit11fb042a3b49d7c498c189947151dda5ee76cdd0 (patch)
tree889d62e2c125fc8bd44ff14eb33dc3b9ddad15f5
parentCall has_multilib_profile from pkg_setup instead of global scope. (diff)
downloadgentoo-2-11fb042a3b49d7c498c189947151dda5ee76cdd0.tar.gz
gentoo-2-11fb042a3b49d7c498c189947151dda5ee76cdd0.tar.bz2
gentoo-2-11fb042a3b49d7c498c189947151dda5ee76cdd0.zip
Call has_multilib_profile from pkg_setup instead of global scope.
(Portage version: 2.0.51.22)
-rw-r--r--app-office/mozilla-sunbird-bin/ChangeLog6
-rw-r--r--app-office/mozilla-sunbird-bin/mozilla-sunbird-bin-0.2.20050724.ebuild12
-rw-r--r--app-office/mozilla-sunbird-bin/mozilla-sunbird-bin-0.2.ebuild12
-rw-r--r--mail-client/mozilla-thunderbird-bin/ChangeLog6
-rw-r--r--mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-1.0.6-r3.ebuild12
-rw-r--r--net-www/netscape-flash/ChangeLog7
-rw-r--r--net-www/netscape-flash/netscape-flash-6.0.79.ebuild12
-rw-r--r--net-www/netscape-flash/netscape-flash-6.0.81.ebuild12
-rw-r--r--net-www/netscape-flash/netscape-flash-7.0.25.ebuild12
9 files changed, 58 insertions, 33 deletions
diff --git a/app-office/mozilla-sunbird-bin/ChangeLog b/app-office/mozilla-sunbird-bin/ChangeLog
index f4e169483b33..9f47a432a41f 100644
--- a/app-office/mozilla-sunbird-bin/ChangeLog
+++ b/app-office/mozilla-sunbird-bin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/mozilla-sunbird-bin
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/mozilla-sunbird-bin/ChangeLog,v 1.9 2005/07/27 16:22:40 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/mozilla-sunbird-bin/ChangeLog,v 1.10 2005/08/11 20:27:54 flameeyes Exp $
+
+ 11 Aug 2005; Diego Pettenò <flameeyes@gentoo.org>
+ mozilla-sunbird-bin-0.2.ebuild, mozilla-sunbird-bin-0.2.20050724.ebuild:
+ Call has_multilib_profile from pkg_setup instead of global scope.
*mozilla-sunbird-bin-0.2.20050724 (27 Jul 2005)
diff --git a/app-office/mozilla-sunbird-bin/mozilla-sunbird-bin-0.2.20050724.ebuild b/app-office/mozilla-sunbird-bin/mozilla-sunbird-bin-0.2.20050724.ebuild
index bfe972b8c92f..8ed52e5a5c48 100644
--- a/app-office/mozilla-sunbird-bin/mozilla-sunbird-bin-0.2.20050724.ebuild
+++ b/app-office/mozilla-sunbird-bin/mozilla-sunbird-bin-0.2.20050724.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/mozilla-sunbird-bin/mozilla-sunbird-bin-0.2.20050724.ebuild,v 1.1 2005/07/27 16:22:40 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/mozilla-sunbird-bin/mozilla-sunbird-bin-0.2.20050724.ebuild,v 1.2 2005/08/11 20:27:54 flameeyes Exp $
inherit mozilla-launcher multilib
@@ -28,10 +28,12 @@ RDEPEND="virtual/x11
S=${WORKDIR}/sunbird
-# This is a binary x86 package => ABI=x86
-# Please keep this in future versions
-# Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
-has_multilib_profile && ABI="x86"
+pkg_config() {
+ # This is a binary x86 package => ABI=x86
+ # Please keep this in future versions
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
+ has_multilib_profile && ABI="x86"
+}
src_install() {
declare MOZILLA_FIVE_HOME=/opt/sunbird
diff --git a/app-office/mozilla-sunbird-bin/mozilla-sunbird-bin-0.2.ebuild b/app-office/mozilla-sunbird-bin/mozilla-sunbird-bin-0.2.ebuild
index 39edeee384d5..d1442fc9190f 100644
--- a/app-office/mozilla-sunbird-bin/mozilla-sunbird-bin-0.2.ebuild
+++ b/app-office/mozilla-sunbird-bin/mozilla-sunbird-bin-0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/mozilla-sunbird-bin/mozilla-sunbird-bin-0.2.ebuild,v 1.2 2005/07/25 03:49:18 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/mozilla-sunbird-bin/mozilla-sunbird-bin-0.2.ebuild,v 1.3 2005/08/11 20:27:54 flameeyes Exp $
inherit mozilla-launcher multilib
@@ -28,10 +28,12 @@ RDEPEND="virtual/x11
S=${WORKDIR}/sunbird
-# This is a binary x86 package => ABI=x86
-# Please keep this in future versions
-# Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
-has_multilib_profile && ABI="x86"
+pkg_config() {
+ # This is a binary x86 package => ABI=x86
+ # Please keep this in future versions
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
+ has_multilib_profile && ABI="x86"
+}
src_install() {
declare MOZILLA_FIVE_HOME=/opt/sunbird
diff --git a/mail-client/mozilla-thunderbird-bin/ChangeLog b/mail-client/mozilla-thunderbird-bin/ChangeLog
index a56eaa5f8457..11e0f023b6ca 100644
--- a/mail-client/mozilla-thunderbird-bin/ChangeLog
+++ b/mail-client/mozilla-thunderbird-bin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for mail-client/mozilla-thunderbird-bin
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird-bin/ChangeLog,v 1.31 2005/08/02 15:07:48 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird-bin/ChangeLog,v 1.32 2005/08/11 20:27:25 flameeyes Exp $
+
+ 11 Aug 2005; Diego Pettenò <flameeyes@gentoo.org>
+ mozilla-thunderbird-bin-1.0.6-r3.ebuild:
+ Call has_multilib_profile from pkg_setup instead of global scope.
*mozilla-thunderbird-bin-1.0.6-r3 (02 Aug 2005)
diff --git a/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-1.0.6-r3.ebuild b/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-1.0.6-r3.ebuild
index d5587491a5ad..9688d234239a 100644
--- a/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-1.0.6-r3.ebuild
+++ b/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-1.0.6-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-1.0.6-r3.ebuild,v 1.1 2005/08/02 15:07:48 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-1.0.6-r3.ebuild,v 1.2 2005/08/11 20:27:25 flameeyes Exp $
inherit eutils mozilla-launcher multilib
@@ -28,10 +28,12 @@ RDEPEND="virtual/x11
S=${WORKDIR}/thunderbird
-# This is a binary x86 package => ABI=x86
-# Please keep this in future versions
-# Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
-has_multilib_profile && ABI="x86"
+pkg_setup() {
+ # This is a binary x86 package => ABI=x86
+ # Please keep this in future versions
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
+ has_multilib_profile && ABI="x86"
+}
src_install() {
declare MOZILLA_FIVE_HOME=/opt/thunderbird
diff --git a/net-www/netscape-flash/ChangeLog b/net-www/netscape-flash/ChangeLog
index 9eaabe7b0b6e..3a6c5ffe0037 100644
--- a/net-www/netscape-flash/ChangeLog
+++ b/net-www/netscape-flash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/netscape-flash
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/netscape-flash/ChangeLog,v 1.29 2005/05/03 18:49:01 herbs Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/netscape-flash/ChangeLog,v 1.30 2005/08/11 20:25:42 flameeyes Exp $
+
+ 11 Aug 2005; Diego Pettenò <flameeyes@gentoo.org>
+ netscape-flash-6.0.79.ebuild, netscape-flash-6.0.81.ebuild,
+ netscape-flash-7.0.25.ebuild:
+ Call has_multilib_profile from pkg_setup instead of global scope.
03 May 2005; Herbie Hopkins <herbs@gentoo.org>
netscape-flash-7.0.25.ebuild:
diff --git a/net-www/netscape-flash/netscape-flash-6.0.79.ebuild b/net-www/netscape-flash/netscape-flash-6.0.79.ebuild
index 4d9fa77f8cfb..fabddfc79501 100644
--- a/net-www/netscape-flash/netscape-flash-6.0.79.ebuild
+++ b/net-www/netscape-flash/netscape-flash-6.0.79.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/netscape-flash/netscape-flash-6.0.79.ebuild,v 1.5 2005/03/26 23:25:03 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/netscape-flash/netscape-flash-6.0.79.ebuild,v 1.6 2005/08/11 20:25:42 flameeyes Exp $
inherit nsplugins
@@ -25,10 +25,12 @@ DEPEND="!net-www/gplflash
RESTRICT="nostrip"
-# This is a binary x86 package => ABI=x86
-# Please keep this in future versions
-# Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
-has_multilib_profile && ABI="x86"
+pkg_setup() {
+ # This is a binary x86 package => ABI=x86
+ # Please keep this in future versions
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
+ has_multilib_profile && ABI="x86"
+}
src_install() {
exeinto /opt/netscape/plugins
diff --git a/net-www/netscape-flash/netscape-flash-6.0.81.ebuild b/net-www/netscape-flash/netscape-flash-6.0.81.ebuild
index decd04789856..fc72aa2ab36a 100644
--- a/net-www/netscape-flash/netscape-flash-6.0.81.ebuild
+++ b/net-www/netscape-flash/netscape-flash-6.0.81.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/netscape-flash/netscape-flash-6.0.81.ebuild,v 1.5 2005/03/26 23:25:03 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/netscape-flash/netscape-flash-6.0.81.ebuild,v 1.6 2005/08/11 20:25:42 flameeyes Exp $
inherit nsplugins
@@ -28,10 +28,12 @@ DEPEND="!net-www/gplflash
RESTRICT="nostrip"
-# This is a binary x86 package => ABI=x86
-# Please keep this in future versions
-# Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
-has_multilib_profile && ABI="x86"
+pkg_setup() {
+ # This is a binary x86 package => ABI=x86
+ # Please keep this in future versions
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
+ has_multilib_profile && ABI="x86"
+}
src_install() {
exeinto /opt/netscape/plugins
diff --git a/net-www/netscape-flash/netscape-flash-7.0.25.ebuild b/net-www/netscape-flash/netscape-flash-7.0.25.ebuild
index 655ab0c8ae4c..21821f8869ae 100644
--- a/net-www/netscape-flash/netscape-flash-7.0.25.ebuild
+++ b/net-www/netscape-flash/netscape-flash-7.0.25.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/netscape-flash/netscape-flash-7.0.25.ebuild,v 1.8 2005/05/03 18:49:01 herbs Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/netscape-flash/netscape-flash-7.0.25.ebuild,v 1.9 2005/08/11 20:25:42 flameeyes Exp $
inherit nsplugins
@@ -28,10 +28,12 @@ DEPEND="!net-www/gplflash
RESTRICT="nostrip"
-# This is a binary x86 package => ABI=x86
-# Please keep this in future versions
-# Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
-has_multilib_profile && ABI="x86"
+pkg_setup() {
+ # This is a binary x86 package => ABI=x86
+ # Please keep this in future versions
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
+ has_multilib_profile && ABI="x86"
+}
src_install() {
exeinto /opt/netscape/plugins