summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-11-22 11:38:44 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-11-22 11:38:44 +0000
commit12eb695fe128215f65eeceecd5770dbdf3ecc7e1 (patch)
tree76046d655727398743b219d5c6e10766f15ca2b0
parentStable on alpha, bug #292022 (diff)
downloadgentoo-2-12eb695fe128215f65eeceecd5770dbdf3ecc7e1.tar.gz
gentoo-2-12eb695fe128215f65eeceecd5770dbdf3ecc7e1.tar.bz2
gentoo-2-12eb695fe128215f65eeceecd5770dbdf3ecc7e1.zip
Add semantic-desktop useflag. Per bug #257070.
(Portage version: 2.2_rc51/cvs/Linux x86_64)
-rw-r--r--kde-base/plasma-workspace/ChangeLog6
-rw-r--r--kde-base/plasma-workspace/plasma-workspace-4.3.3.ebuild7
2 files changed, 10 insertions, 3 deletions
diff --git a/kde-base/plasma-workspace/ChangeLog b/kde-base/plasma-workspace/ChangeLog
index d896d362246a..339a8c92c1a3 100644
--- a/kde-base/plasma-workspace/ChangeLog
+++ b/kde-base/plasma-workspace/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/plasma-workspace
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/plasma-workspace/ChangeLog,v 1.40 2009/11/09 10:32:16 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/plasma-workspace/ChangeLog,v 1.41 2009/11/22 11:38:44 scarabeus Exp $
+
+ 22 Nov 2009; Tomáš Chvátal <scarabeus@gentoo.org>
+ plasma-workspace-4.3.3.ebuild:
+ Add semantic-desktop useflag. Per bug #257070.
09 Nov 2009; Jonathan Callen <abcd@gentoo.org>
-files/plasma-workspace-fake-panel-transparency.patch:
diff --git a/kde-base/plasma-workspace/plasma-workspace-4.3.3.ebuild b/kde-base/plasma-workspace/plasma-workspace-4.3.3.ebuild
index 801d759c2277..ee1753c81f12 100644
--- a/kde-base/plasma-workspace/plasma-workspace-4.3.3.ebuild
+++ b/kde-base/plasma-workspace/plasma-workspace-4.3.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/plasma-workspace/plasma-workspace-4.3.3.ebuild,v 1.1 2009/11/02 22:08:59 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/plasma-workspace/plasma-workspace-4.3.3.ebuild,v 1.2 2009/11/22 11:38:44 scarabeus Exp $
EAPI="2"
@@ -10,7 +10,7 @@ inherit python kde4-meta
DESCRIPTION="Plasma: KDE desktop framework"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
-IUSE="debug +handbook google-gadgets python rss xinerama"
+IUSE="debug +handbook google-gadgets python rss +semantic-desktop xinerama"
COMMONDEPEND="
$(add_kdebase_dep kephal)
@@ -30,6 +30,7 @@ COMMONDEPEND="
$(add_kdebase_dep pykde4)
)
rss? ( $(add_kdebase_dep kdepimlibs) )
+ semantic-desktop? ( $(add_kdebase_dep kdelibs 'semantic-desktop?') )
xinerama? ( x11-libs/libXinerama )
"
DEPEND="${COMMONDEPEND}
@@ -68,6 +69,8 @@ src_configure() {
$(cmake-utils_use_with python PyQt4)
$(cmake-utils_use_with python PyKDE4)
$(cmake-utils_use_with rss KdepimLibs)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)
-DWITH_Xmms=OFF"
kde4-meta_src_configure