summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-05-29 18:52:21 +0000
committerJustin Lecher <jlec@gentoo.org>2012-05-29 18:52:21 +0000
commit1f0d42ed9104ccd13304e3276ee13a9ae428da57 (patch)
tree555d908aac8cc14a14f38be08550ea5231fb9123
parentRemove evolution-data-server support as it is broken, add a litte performance... (diff)
downloadgentoo-2-1f0d42ed9104ccd13304e3276ee13a9ae428da57.tar.gz
gentoo-2-1f0d42ed9104ccd13304e3276ee13a9ae428da57.tar.bz2
gentoo-2-1f0d42ed9104ccd13304e3276ee13a9ae428da57.zip
Version Bump
(Portage version: 2.2.0_alpha108/cvs/Linux x86_64)
-rw-r--r--dev-libs/libatomic_ops/ChangeLog8
-rw-r--r--dev-libs/libatomic_ops/files/libatomic_ops-7.2_alpha6-x32.patch46
-rw-r--r--dev-libs/libatomic_ops/libatomic_ops-7.2_alpha6.ebuild35
3 files changed, 88 insertions, 1 deletions
diff --git a/dev-libs/libatomic_ops/ChangeLog b/dev-libs/libatomic_ops/ChangeLog
index 4c34768ec58c..a823bfa61fb6 100644
--- a/dev-libs/libatomic_ops/ChangeLog
+++ b/dev-libs/libatomic_ops/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libatomic_ops
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libatomic_ops/ChangeLog,v 1.28 2012/02/09 22:40:58 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libatomic_ops/ChangeLog,v 1.29 2012/05/29 18:52:21 jlec Exp $
+
+*libatomic_ops-7.2_alpha6 (29 May 2012)
+
+ 29 May 2012; Justin Lecher <jlec@gentoo.org>
+ +libatomic_ops-7.2_alpha6.ebuild, +files/libatomic_ops-7.2_alpha6-x32.patch:
+ Version Bump
09 Feb 2012; Matt Turner <mattst88@gentoo.org>
libatomic_ops-7.2_alpha4.ebuild:
diff --git a/dev-libs/libatomic_ops/files/libatomic_ops-7.2_alpha6-x32.patch b/dev-libs/libatomic_ops/files/libatomic_ops-7.2_alpha6-x32.patch
new file mode 100644
index 000000000000..838e4a8d27f1
--- /dev/null
+++ b/dev-libs/libatomic_ops/files/libatomic_ops-7.2_alpha6-x32.patch
@@ -0,0 +1,46 @@
+Adopted from
+http://git.yoctoproject.org/cgit/cgit.cgi/poky/commit/?id=e3a384578f677c05d812d99c2c92aa13670bd06a
+
+Upstream-Status: Pending
+
+Remove the `q' suffix on x86-64 atomic instructions.
+
+We don't need the `q' suffix on x86_64 atomic instructions for AO_t,
+which is defined as "unsigned long". "unsigned long" is 32bit for x32
+and 64bit for x86-64. The register operand in x86-64 atomic instructions
+is sufficient to properly determine the register size.
+
+Received this patch from H.J. Lu <hjl.tools@gmail.com>
+Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com> 2011/12/02
+
+diff --git a/libatomic_ops/src/atomic_ops/sysdeps/gcc/x86_64.h b/libatomic_ops/src/atomic_ops/sysdeps/gcc/x86_64.h
+index 0f68c1e..3bcde88 100644
+--- a/libatomic_ops/src/atomic_ops/sysdeps/gcc/x86_64.h
++++ b/libatomic_ops/src/atomic_ops/sysdeps/gcc/x86_64.h
+@@ -47,7 +47,7 @@ AO_fetch_and_add_full (volatile AO_t *p, AO_t incr)
+ {
+ AO_t result;
+
+- __asm__ __volatile__ ("lock; xaddq %0, %1" :
++ __asm__ __volatile__ ("lock; xadd %0, %1" :
+ "=r" (result), "=m" (*p) : "0" (incr), "m" (*p)
+ : "memory");
+ return result;
+@@ -93,7 +93,7 @@ AO_int_fetch_and_add_full (volatile unsigned int *p, unsigned int incr)
+ AO_INLINE void
+ AO_or_full (volatile AO_t *p, AO_t incr)
+ {
+- __asm__ __volatile__ ("lock; orq %1, %0" :
++ __asm__ __volatile__ ("lock; or %1, %0" :
+ "=m" (*p) : "r" (incr), "m" (*p) : "memory");
+ }
+ #define AO_HAVE_or_full
+@@ -123,7 +123,7 @@ AO_compare_and_swap_full(volatile AO_t *addr, AO_t old, AO_t new_val)
+ return (int)__sync_bool_compare_and_swap(addr, old, new_val);
+ # else
+ char result;
+- __asm__ __volatile__("lock; cmpxchgq %3, %0; setz %1"
++ __asm__ __volatile__("lock; cmpxchg %3, %0; setz %1"
+ : "=m" (*addr), "=a" (result)
+ : "m" (*addr), "r" (new_val), "a" (old) : "memory");
+ return (int) result;
diff --git a/dev-libs/libatomic_ops/libatomic_ops-7.2_alpha6.ebuild b/dev-libs/libatomic_ops/libatomic_ops-7.2_alpha6.ebuild
new file mode 100644
index 000000000000..958f27b90e69
--- /dev/null
+++ b/dev-libs/libatomic_ops/libatomic_ops-7.2_alpha6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libatomic_ops/libatomic_ops-7.2_alpha6.ebuild,v 1.1 2012/05/29 18:52:21 jlec Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Implementation for atomic memory update operations"
+HOMEPAGE="http://www.hpl.hp.com/research/linux/atomic_ops/"
+SRC_URI="http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/gc-${PV/_}.tar.gz"
+
+LICENSE="GPL-2 MIT as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+S=${WORKDIR}/gc-${PV/_}/libatomic_ops
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-x32.patch
+ sed -i \
+ -e "/^pkgdatadir/s:/.*:/doc/${PF}:" \
+ doc/Makefile.in || die
+ find -type f -exec touch -r . {} +
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+ find "${ED}" '(' -name COPYING -o -name LICENSING.txt ')' -delete
+}