summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2013-01-21 12:33:10 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2013-01-21 12:33:10 +0000
commit1f18ccc06f3c2853acdcd6310831421ba2787138 (patch)
tree31b338470e68a65288ab0a2103bd7611f3bb1c5c
parentDrop stable ebuilds (see bugs #391789, #453242). (diff)
downloadgentoo-2-1f18ccc06f3c2853acdcd6310831421ba2787138.tar.gz
gentoo-2-1f18ccc06f3c2853acdcd6310831421ba2787138.tar.bz2
gentoo-2-1f18ccc06f3c2853acdcd6310831421ba2787138.zip
Fix compilation with glibc-2.17, bug #451768
(Portage version: 2.2.0_alpha158/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
-rw-r--r--sys-fs/shake/ChangeLog8
-rw-r--r--sys-fs/shake/files/shake-0.999-fix_stat_include.patch22
-rw-r--r--sys-fs/shake/shake-0.99.ebuild18
-rw-r--r--sys-fs/shake/shake-0.999.ebuild10
4 files changed, 35 insertions, 23 deletions
diff --git a/sys-fs/shake/ChangeLog b/sys-fs/shake/ChangeLog
index 539d7e3ef6f1..2fcd8f6c2444 100644
--- a/sys-fs/shake/ChangeLog
+++ b/sys-fs/shake/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/shake
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/shake/ChangeLog,v 1.7 2011/08/05 09:58:47 voyageur Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/shake/ChangeLog,v 1.8 2013/01/21 12:33:10 voyageur Exp $
+
+ 21 Jan 2013; Bernard Cafarelli <voyageur@gentoo.org> -shake-0.99.ebuild,
+ shake-0.999.ebuild, +files/shake-0.999-fix_stat_include.patch:
+ Fix compilation with glibc-2.17, bug #451768
*shake-0.999 (05 Aug 2011)
diff --git a/sys-fs/shake/files/shake-0.999-fix_stat_include.patch b/sys-fs/shake/files/shake-0.999-fix_stat_include.patch
new file mode 100644
index 000000000000..b55776397288
--- /dev/null
+++ b/sys-fs/shake/files/shake-0.999-fix_stat_include.patch
@@ -0,0 +1,22 @@
+diff -Naur shake-fs-0.999.orig/judge.c shake-fs-0.999/judge.c
+--- shake-fs-0.999.orig/judge.c 2013-01-21 13:21:17.171974754 +0100
++++ shake-fs-0.999/judge.c 2013-01-21 13:21:31.346958593 +0100
+@@ -26,7 +26,6 @@
+ #include <fcntl.h> // open()
+ #include <sys/types.h> // open(), umask()
+ #include <dirent.h> // scandir()
+-#include <sys/stat.h> // stat(), umask()
+ #include <unistd.h> // stat()
+ #include <stdio.h> // printf(), tmpfile()
+ #include <error.h> // error()
+diff -Naur shake-fs-0.999.orig/judge.h shake-fs-0.999/judge.h
+--- shake-fs-0.999.orig/judge.h 2013-01-21 13:21:17.171974754 +0100
++++ shake-fs-0.999/judge.h 2013-01-21 13:21:47.630940034 +0100
+@@ -22,6 +22,7 @@
+ #include <stdbool.h>
+ #include <fcntl.h>
+ #include <time.h>
++#include <sys/stat.h>
+ typedef unsigned int uint;
+ typedef long long int llint;
+
diff --git a/sys-fs/shake/shake-0.99.ebuild b/sys-fs/shake/shake-0.99.ebuild
deleted file mode 100644
index 01e28a35717f..000000000000
--- a/sys-fs/shake/shake-0.99.ebuild
+++ /dev/null
@@ -1,18 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/shake/shake-0.99.ebuild,v 1.1 2009/09/11 15:18:56 voyageur Exp $
-
-inherit cmake-utils
-
-DESCRIPTION="defragmenter that runs in userspace while the system is used"
-HOMEPAGE="http://vleu.net/shake/"
-SRC_URI="http://download.savannah.nongnu.org/releases/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-RDEPEND="sys-apps/attr"
-DEPEND="${RDEPEND}
- sys-apps/help2man"
diff --git a/sys-fs/shake/shake-0.999.ebuild b/sys-fs/shake/shake-0.999.ebuild
index b25f32e7be07..6d3cbdc9a205 100644
--- a/sys-fs/shake/shake-0.999.ebuild
+++ b/sys-fs/shake/shake-0.999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/shake/shake-0.999.ebuild,v 1.1 2011/08/05 09:58:47 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/shake/shake-0.999.ebuild,v 1.2 2013/01/21 12:33:10 voyageur Exp $
-inherit cmake-utils
+inherit cmake-utils eutils
DESCRIPTION="defragmenter that runs in userspace while the system is used"
HOMEPAGE="http://vleu.net/shake/"
@@ -18,3 +18,7 @@ DEPEND="${RDEPEND}
sys-apps/help2man"
S=${WORKDIR}/${PN}-fs-${PV}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-fix_stat_include.patch
+}