summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2012-11-06 15:07:48 +0000
committerMichael Palimaka <kensington@gentoo.org>2012-11-06 15:07:48 +0000
commit22669b50806693f6c470a9d5d3c2ba75e7dd0fec (patch)
tree859a52994fc836ad703f5820823dcc3475f67d4e
parentDrop not needed inherits. (diff)
downloadgentoo-2-22669b50806693f6c470a9d5d3c2ba75e7dd0fec.tar.gz
gentoo-2-22669b50806693f6c470a9d5d3c2ba75e7dd0fec.tar.bz2
gentoo-2-22669b50806693f6c470a9d5d3c2ba75e7dd0fec.zip
Fix parallel install wrt bug #255777. Fix automagic dependency on media-libs/svgalib. Migrate to EAPI 4.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 675D0D2C)
-rw-r--r--app-emulation/spectemu/ChangeLog12
-rw-r--r--app-emulation/spectemu/files/spectemu-0.99.3-automagic.patch31
-rw-r--r--app-emulation/spectemu/files/spectemu-0.99.3-build.patch34
-rw-r--r--app-emulation/spectemu/spectemu-0.99.3-r1.ebuild45
4 files changed, 120 insertions, 2 deletions
diff --git a/app-emulation/spectemu/ChangeLog b/app-emulation/spectemu/ChangeLog
index 2a0ea97df199..a78709846de1 100644
--- a/app-emulation/spectemu/ChangeLog
+++ b/app-emulation/spectemu/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-emulation/spectemu
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/spectemu/ChangeLog,v 1.26 2009/03/03 20:37:38 flameeyes Exp $
+# Copyright 2002-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spectemu/ChangeLog,v 1.27 2012/11/06 15:07:48 kensington Exp $
+
+*spectemu-0.99.3-r1 (06 Nov 2012)
+
+ 06 Nov 2012; Michael Palimaka <kensington@gentoo.org>
+ +files/spectemu-0.99.3-automagic.patch, +files/spectemu-0.99.3-build.patch,
+ +spectemu-0.99.3-r1.ebuild:
+ Fix parallel install wrt bug #255777. Fix automagic dependency on media-
+ libs/svgalib. Migrate to EAPI 4.
03 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
spectemu-0.99.3.ebuild:
diff --git a/app-emulation/spectemu/files/spectemu-0.99.3-automagic.patch b/app-emulation/spectemu/files/spectemu-0.99.3-automagic.patch
new file mode 100644
index 000000000000..6e813d6373e5
--- /dev/null
+++ b/app-emulation/spectemu/files/spectemu-0.99.3-automagic.patch
@@ -0,0 +1,31 @@
+--- configure.in
++++ configure.in
+@@ -121,13 +121,22 @@
+ dnl -----------------------------------------------------------
+ dnl Check for SVGALIB
+ dnl -----------------------------------------------------------
+-AC_CHECK_LIB(vga, vga_setmode, no_vga="", no_vga=yes)
+-if test "$no_vga" != yes; then
+- progs="$progs vgaspect"
+- vgalib=-lvga
+
+- LIBS="$vgalib $olibs"
+- AC_CHECK_FUNC(vga_runinbackground_version, AC_DEFINE(RUN_IN_BACKGROUND))
++svgalibs=""
++withsvga=no
++AC_ARG_WITH(svga,
++[ --with-svga Compile with svga library],
++[if test "$withval" = no; then withsvga=no; fi])
++
++if test "$withsvga" = yes; then
++ AC_CHECK_LIB(vga, vga_setmode, no_vga="", no_vga=yes)
++ if test "$no_vga" != yes; then
++ progs="$progs vgaspect"
++ vgalib=-lvga
++
++ LIBS="$vgalib $olibs"
++ AC_CHECK_FUNC(vga_runinbackground_version, AC_DEFINE(RUN_IN_BACKGROUND))
++ fi
+ fi
+
+ LIBS="$olibs"
diff --git a/app-emulation/spectemu/files/spectemu-0.99.3-build.patch b/app-emulation/spectemu/files/spectemu-0.99.3-build.patch
new file mode 100644
index 000000000000..1c354a5fa933
--- /dev/null
+++ b/app-emulation/spectemu/files/spectemu-0.99.3-build.patch
@@ -0,0 +1,34 @@
+--- Makefile.in
++++ Makefile.in
+@@ -44,17 +44,19 @@
+ ./mkinstalldirs $(i_bindir) $(i_mandir)
+
+ install_prog: $(progs)
++ mkdir -p $(i_bindir)
+ if test -f xspect; then \
+- $(INSTALL_PROGRAM) -s -m 755 xspect $(i_bindir); fi
++ $(INSTALL_PROGRAM) -m 755 xspect $(i_bindir); fi
+ if test -f vgaspect; then \
+- $(INSTALL_PROGRAM) -s -m 4755 vgaspect $(i_bindir); fi
++ $(INSTALL_PROGRAM) -m 4755 vgaspect $(i_bindir); fi
+
+ install_man:
++ mkdir -p $(i_mandir)
+ $(INSTALL_DATA) ./xspect.1 $(i_mandir)
+ $(INSTALL_DATA) ./tapeout.1 $(i_mandir)
+ (cd $(i_mandir); rm -f vgaspect.1; ln -s xspect.1 vgaspect.1)
+
+-install: installdirs install_prog install_man
++install: install_prog install_man
+
+ z80_c_objs=z80.o z80optab.o z80_step.o spperif.o spect.o rom48.o \
+ z80_op1.o z80_op2.o z80_op3.o z80_op4.o z80_op5.o z80_op6.o
+@@ -88,7 +90,7 @@
+ ./sp_to_s < i386emul.sp > i386emul.s
+
+ i386emul.o: i386emul.s
+- $(CC) -c $(CFLAGS) i386emul.s
++ $(CC) -c $(ASFLAGS) -Xassembler --noexecstack i386emul.s
+
+ sp_to_s: sp_to_s.o
+ $(CC) -o sp_to_s $(LDFLAGS) sp_to_s.o
diff --git a/app-emulation/spectemu/spectemu-0.99.3-r1.ebuild b/app-emulation/spectemu/spectemu-0.99.3-r1.ebuild
new file mode 100644
index 000000000000..aa8dde0766c0
--- /dev/null
+++ b/app-emulation/spectemu/spectemu-0.99.3-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spectemu/spectemu-0.99.3-r1.ebuild,v 1.1 2012/11/06 15:07:48 kensington Exp $
+
+EAPI=4
+
+inherit autotools eutils
+
+DESCRIPTION="48k ZX Spectrum Emulator"
+HOMEPAGE="http://kempelen.iit.bme.hu/~mszeredi/spectemu/spectemu.html"
+SRC_URI="http://www.inf.bme.hu/~mszeredi/spectemu/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="readline svga +X"
+
+REQUIRED_USE="|| ( svga X )"
+
+DEPEND="X? ( >=x11-proto/xf86vidmodeproto-2.2.2
+ >=x11-proto/xextproto-7.0.2
+ >=x11-proto/xproto-7.0.4
+ >=x11-libs/libX11-1.0.0
+ >=x11-libs/libXext-1.0.0
+ >=x11-libs/libXxf86vm-1.0.0 )
+ readline? ( sys-libs/readline )"
+RDEPEND="${DEPEND}
+ svga? ( media-libs/svgalib )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-automagic.patch
+ epatch "${FILESDIR}"/${P}-build.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with readline) \
+ $(use_with svga) \
+ $(use_with X x)
+}
+
+src_install() {
+ emake install_root="${D}" install
+}