summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-10-22 08:46:45 +0000
committerJustin Lecher <jlec@gentoo.org>2014-10-22 08:46:45 +0000
commit2ced4a6eb77fb5f7550ecfa0a4a51e5797f1ab0e (patch)
treed4a7385a75acc1583d91c59320b1c21ec6aa2dc8
parentslib dependency is not needed (#526404 by Ooblick) (diff)
downloadgentoo-2-2ced4a6eb77fb5f7550ecfa0a4a51e5797f1ab0e.tar.gz
gentoo-2-2ced4a6eb77fb5f7550ecfa0a4a51e5797f1ab0e.tar.bz2
gentoo-2-2ced4a6eb77fb5f7550ecfa0a4a51e5797f1ab0e.zip
sci-visualization/epix: Fix bashcomp installation, #526322
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
-rw-r--r--sci-visualization/epix/ChangeLog10
-rw-r--r--sci-visualization/epix/epix-1.2.10.ebuild5
-rw-r--r--sci-visualization/epix/epix-1.2.11-r1.ebuild67
-rw-r--r--sci-visualization/epix/epix-1.2.11.ebuild5
-rw-r--r--sci-visualization/epix/metadata.xml4
5 files changed, 83 insertions, 8 deletions
diff --git a/sci-visualization/epix/ChangeLog b/sci-visualization/epix/ChangeLog
index be4244043149..15854e86c8ed 100644
--- a/sci-visualization/epix/ChangeLog
+++ b/sci-visualization/epix/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-visualization/epix
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/epix/ChangeLog,v 1.50 2013/07/16 16:42:15 bicatali Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/epix/ChangeLog,v 1.51 2014/10/22 08:46:45 jlec Exp $
+
+*epix-1.2.11-r1 (22 Oct 2014)
+
+ 22 Oct 2014; Justin Lecher <jlec@gentoo.org> epix-1.2.10.ebuild,
+ epix-1.2.11.ebuild, +epix-1.2.11-r1.ebuild, metadata.xml:
+ Fix bashcomp installation, #526322
*epix-1.2.11 (16 Jul 2013)
diff --git a/sci-visualization/epix/epix-1.2.10.ebuild b/sci-visualization/epix/epix-1.2.10.ebuild
index 8c1ebad2c358..8be37ae94e3b 100644
--- a/sci-visualization/epix/epix-1.2.10.ebuild
+++ b/sci-visualization/epix/epix-1.2.10.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/epix/epix-1.2.10.ebuild,v 1.8 2012/12/04 15:38:19 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/epix/epix-1.2.10.ebuild,v 1.9 2014/10/22 08:46:45 jlec Exp $
EAPI=4
@@ -46,6 +46,7 @@ src_install() {
elisp-site-file-install "${FILESDIR}/${SITEFILE}"
fi
newbashcomp bash_completions epix
+ bashcomp_alias epix flix elaps laps
if use doc; then
insinto /usr/share/doc/${PF}
doins doc/*gz
diff --git a/sci-visualization/epix/epix-1.2.11-r1.ebuild b/sci-visualization/epix/epix-1.2.11-r1.ebuild
new file mode 100644
index 000000000000..5cf386f1c3fe
--- /dev/null
+++ b/sci-visualization/epix/epix-1.2.11-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/epix/epix-1.2.11-r1.ebuild,v 1.1 2014/10/22 08:46:45 jlec Exp $
+
+EAPI=5
+
+inherit elisp-common bash-completion-r1 autotools eutils
+
+DESCRIPTION="2- and 3-D plotter for creating images (to be used in LaTeX)"
+HOMEPAGE="http://mathcs.holycross.edu/~ahwang/current/ePiX.html"
+SRC_URI="http://mathcs.holycross.edu/~ahwang/epix/${P}_withpdf.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc emacs examples"
+
+DEPEND="
+ virtual/latex-base
+ dev-texlive/texlive-pstricks
+ dev-texlive/texlive-pictures
+ dev-texlive/texlive-latexextra
+ dev-tex/xcolor
+ emacs? ( virtual/emacs )"
+RDEPEND="${DEPEND}"
+SITEFILE=50${PN}-gentoo.el
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.2.10-autotools.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --disable-epix-el
+}
+
+src_install() {
+ default
+ if use emacs; then
+ # do compilation here as the make install target will
+ # create the .el file
+ elisp-compile *.el || die "elisp-compile failed!"
+ elisp-install ${PN} *.elc *.el || die "elisp-install failed!"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+ newbashcomp bash_completions epix
+ bashcomp_alias epix flix elaps laps
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins doc/*gz
+ fi
+ if use examples; then
+ cd samples
+ insinto /usr/share/doc/${PF}/examples
+ doins *.xp *.flx *c *h README
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/sci-visualization/epix/epix-1.2.11.ebuild b/sci-visualization/epix/epix-1.2.11.ebuild
index c8206c12484d..6b9ef40d168a 100644
--- a/sci-visualization/epix/epix-1.2.11.ebuild
+++ b/sci-visualization/epix/epix-1.2.11.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/epix/epix-1.2.11.ebuild,v 1.1 2013/07/16 16:42:15 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/epix/epix-1.2.11.ebuild,v 1.2 2014/10/22 08:46:45 jlec Exp $
EAPI=5
@@ -46,6 +46,7 @@ src_install() {
elisp-site-file-install "${FILESDIR}/${SITEFILE}"
fi
newbashcomp bash_completions epix
+ bashcomp_alias epix flix elaps laps
if use doc; then
insinto /usr/share/doc/${PF}
doins doc/*gz
diff --git a/sci-visualization/epix/metadata.xml b/sci-visualization/epix/metadata.xml
index 99968f74811f..1e8d734a8d9f 100644
--- a/sci-visualization/epix/metadata.xml
+++ b/sci-visualization/epix/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
-<longdescription lang="en">
+ <herd>sci</herd>
+ <longdescription lang="en">
ePiX creates mathematically accurate figures, plots, and
movies using easy-to-learn syntax. The output is expressly suitable
for use with LaTeX; figures may be written in a LaTeX picture