summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Anderson <tanderson@gentoo.org>2009-09-27 12:34:17 +0000
committerThomas Anderson <tanderson@gentoo.org>2009-09-27 12:34:17 +0000
commit329f605a1885215d712e6ab46c648deca05ad77a (patch)
treef8ea56213afcc65bedb035f32fcd762a79af780e
parentMarking kplato-1.6.3_p20090204 ppc64 for bug 276008 (diff)
downloadgentoo-2-329f605a1885215d712e6ab46c648deca05ad77a.tar.gz
gentoo-2-329f605a1885215d712e6ab46c648deca05ad77a.tar.bz2
gentoo-2-329f605a1885215d712e6ab46c648deca05ad77a.zip
Add gcc-4.3 patch for tests. Thanks to Dustin Polke for the report and initial patch.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
-rw-r--r--dev-cpp/libthrowable/ChangeLog11
-rw-r--r--dev-cpp/libthrowable/files/libthrowable-1.1.0-gcc43.diff10
2 files changed, 18 insertions, 3 deletions
diff --git a/dev-cpp/libthrowable/ChangeLog b/dev-cpp/libthrowable/ChangeLog
index dc6c00a6aa8d..daa951013c5b 100644
--- a/dev-cpp/libthrowable/ChangeLog
+++ b/dev-cpp/libthrowable/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/libthrowable
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libthrowable/ChangeLog,v 1.19 2008/12/09 19:45:29 ranger Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libthrowable/ChangeLog,v 1.20 2009/09/27 12:34:17 tanderson Exp $
+
+ 27 Sep 2009; Thomas Anderson <tanderson@gentoo.org>
+ files/libthrowable-1.1.0-gcc43.diff:
+ Add gcc-4.3 patch for tests. Thanks to Dustin Polke for the report and
+ initial patch.
09 Dec 2008; Brent Baude <ranger@gentoo.org> libthrowable-1.1.0.ebuild:
Marking libthrowable-1.1.0 ppc64 for bug 247464
@@ -18,7 +23,7 @@
Update gcc-4.3 patch per bug 236362. Thanks to Michael Gisbers
<michael@gisbers.de>.
- 26 Jul 2008; Thomas Anderson <gentoofan23@gentoo.org> metadata.xml:
+ 26 Jul 2008; Thomas Anderson <tanderson@gentoo.org> metadata.xml:
Change Maintainer.
10 Jul 2008; Jeroen Roovers <jer@gentoo.org> libthrowable-1.1.0.ebuild:
diff --git a/dev-cpp/libthrowable/files/libthrowable-1.1.0-gcc43.diff b/dev-cpp/libthrowable/files/libthrowable-1.1.0-gcc43.diff
index aaac09d67a3f..7e4b98f10a38 100644
--- a/dev-cpp/libthrowable/files/libthrowable-1.1.0-gcc43.diff
+++ b/dev-cpp/libthrowable/files/libthrowable-1.1.0-gcc43.diff
@@ -30,3 +30,13 @@ diff -NrU5 libthrowable-1.1.0.orig/libthrowable/internal/posix_threads.h libthro
namespace libthrowable {
namespace internal {
namespace posix {
+--- libthrowable-1.1.0.orig/tests/t_libthrowable.cc.old 2009-06-30 16:19:43.000000000 +0200
++++ libthrowable-1.1.0/tests/t_libthrowable.cc 2009-06-30 16:21:01.000000000 +0200
+@@ -23,6 +23,7 @@
+ #include "libthrowable.h"
+ #include "libthrowable/internal/internal.h"
+ #include "libthrowable/streams.h"
++#include <cstdlib>
+ #include <iostream>
+ #include <sstream>
+ #ifdef HAVE_PTHREAD