summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-10-20 06:03:25 +0000
committerHans de Graaff <graaff@gentoo.org>2013-10-20 06:03:25 +0000
commit34d60d18b617ad1a7a2162a4c540447a9860d91f (patch)
tree030019a37fa305d2e5fb16a87d2a3cd3a822dd1c
parentCleanup. (diff)
downloadgentoo-2-34d60d18b617ad1a7a2162a4c540447a9860d91f.tar.gz
gentoo-2-34d60d18b617ad1a7a2162a4c540447a9860d91f.tar.bz2
gentoo-2-34d60d18b617ad1a7a2162a4c540447a9860d91f.zip
Version bump.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
-rw-r--r--dev-ruby/selenium-webdriver/ChangeLog8
-rw-r--r--dev-ruby/selenium-webdriver/selenium-webdriver-2.37.0.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-ruby/selenium-webdriver/ChangeLog b/dev-ruby/selenium-webdriver/ChangeLog
index 5a75fa57ee7f..1cff4e55596a 100644
--- a/dev-ruby/selenium-webdriver/ChangeLog
+++ b/dev-ruby/selenium-webdriver/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/selenium-webdriver
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/selenium-webdriver/ChangeLog,v 1.50 2013/10/20 05:52:20 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/selenium-webdriver/ChangeLog,v 1.51 2013/10/20 06:03:25 graaff Exp $
+
+*selenium-webdriver-2.37.0 (20 Oct 2013)
+
+ 20 Oct 2013; Hans de Graaff <graaff@gentoo.org>
+ +selenium-webdriver-2.37.0.ebuild:
+ Version bump.
20 Oct 2013; Hans de Graaff <graaff@gentoo.org>
-selenium-webdriver-2.31.0.ebuild, -selenium-webdriver-2.32.1.ebuild,
diff --git a/dev-ruby/selenium-webdriver/selenium-webdriver-2.37.0.ebuild b/dev-ruby/selenium-webdriver/selenium-webdriver-2.37.0.ebuild
new file mode 100644
index 000000000000..c393a3a1e6d6
--- /dev/null
+++ b/dev-ruby/selenium-webdriver/selenium-webdriver-2.37.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/selenium-webdriver/selenium-webdriver-2.37.0.ebuild,v 1.1 2013/10/20 06:03:25 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19"
+
+# NOTE: this package contains precompiled code. It appears that all
+# source code can be found at http://code.google.com/p/selenium/ but the
+# repository is not organized in a way so that we can easily rebuild the
+# suited shared object. We'll just try our luck with the precompiled
+# objects for now.
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES README.md"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_QA_ALLOWED_LIBS="x_ignore_nofocus.so"
+QA_PREBUILT="*/x_ignore_nofocus.so"
+
+inherit ruby-fakegem
+
+DESCRIPTION="This gem provides Ruby bindings for WebDriver."
+HOMEPAGE="http://gemcutter.org/gems/selenium-webdriver"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/childprocess-0.2.5
+ >=dev-ruby/multi_json-1.0.4
+ dev-ruby/rubyzip:1"
+
+all_ruby_prepare() {
+ # Make websocket a development dependency since it is only needed
+ # for the safari driver which we don't support on Gentoo.
+ sed -i -e '/websocket/,/version_requirements/ s/runtime/development/' ../metadata || die
+}