summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando J. Pereda <ferdy@gentoo.org>2007-12-23 21:27:07 +0000
committerFernando J. Pereda <ferdy@gentoo.org>2007-12-23 21:27:07 +0000
commit352c6686f7916a8256239fe0ebc48a54c7bf581e (patch)
tree6704785a501a11765268e12ce861d8ed10d50835
parentversion bump (diff)
downloadgentoo-2-352c6686f7916a8256239fe0ebc48a54c7bf581e.tar.gz
gentoo-2-352c6686f7916a8256239fe0ebc48a54c7bf581e.tar.bz2
gentoo-2-352c6686f7916a8256239fe0ebc48a54c7bf581e.zip
Version bump
(Portage version: 2.1.3.19)
-rw-r--r--dev-util/bouml/ChangeLog7
-rw-r--r--dev-util/bouml/bouml-3.4.ebuild34
-rw-r--r--dev-util/bouml/files/digest-bouml-3.43
3 files changed, 43 insertions, 1 deletions
diff --git a/dev-util/bouml/ChangeLog b/dev-util/bouml/ChangeLog
index 330a926d3ded..e00fd7f734ac 100644
--- a/dev-util/bouml/ChangeLog
+++ b/dev-util/bouml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/bouml
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bouml/ChangeLog,v 1.33 2007/11/28 20:26:25 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bouml/ChangeLog,v 1.34 2007/12/23 21:27:06 ferdy Exp $
+
+*bouml-3.4 (23 Dec 2007)
+
+ 23 Dec 2007; Fernando J. Pereda <ferdy@gentoo.org> +bouml-3.4.ebuild:
+ Version bump
*bouml-3.3.4 (28 Nov 2007)
diff --git a/dev-util/bouml/bouml-3.4.ebuild b/dev-util/bouml/bouml-3.4.ebuild
new file mode 100644
index 000000000000..a5415e575acf
--- /dev/null
+++ b/dev-util/bouml/bouml-3.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bouml/bouml-3.4.ebuild,v 1.1 2007/12/23 21:27:06 ferdy Exp $
+
+inherit multilib qt3
+
+MY_P="${PN}_${PV}"
+
+DESCRIPTION="Free UML 2 tool with code generation"
+HOMEPAGE="http://bouml.free.fr/"
+SRC_URI="http://bouml.free.fr/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="$(qt_min_version 3)"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ find src/ genplugouts/ -type f -name "*.pro" | while read file; do
+ local subdir="${file%/*}"
+ eqmake3 "${file}" -o "${subdir}"/Makefile
+ emake -C "${subdir}" || die "emake failed in ${subdir}"
+ done
+}
+
+src_install() {
+ emake BOUML_LIB="/usr/$(get_libdir)/bouml" DESTDIR="${D}" install \
+ || die "emake install failed"
+}
diff --git a/dev-util/bouml/files/digest-bouml-3.4 b/dev-util/bouml/files/digest-bouml-3.4
new file mode 100644
index 000000000000..adaa118d6ae2
--- /dev/null
+++ b/dev-util/bouml/files/digest-bouml-3.4
@@ -0,0 +1,3 @@
+MD5 bd2dee55082fc5bda3bc02e8b8336c9c bouml_3.4.tar.gz 4156888
+RMD160 15b6c7d10a53fe6d6a4dc0c11ed994fd7a92c98d bouml_3.4.tar.gz 4156888
+SHA256 2234444d38860f40e3feac0fa80d3ceb8fe0f21a3b386f2326de5b5730247280 bouml_3.4.tar.gz 4156888