summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-01-27 11:00:34 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-01-27 11:00:34 +0000
commit372c171a260fd086c3b400a4b6b9b9c17f6dc395 (patch)
tree9d907072f59fbfb35e5addaf7339613f15d84890
parentStable on amd64 wrt bug #352051 (diff)
downloadgentoo-2-372c171a260fd086c3b400a4b6b9b9c17f6dc395.tar.gz
gentoo-2-372c171a260fd086c3b400a4b6b9b9c17f6dc395.tar.bz2
gentoo-2-372c171a260fd086c3b400a4b6b9b9c17f6dc395.zip
Respect ldflags. Bug #350466. amd64 stable wrt bug #347537
(Portage version: 2.1.9.35/cvs/Linux x86_64)
-rw-r--r--net-im/bitlbee/ChangeLog8
-rw-r--r--net-im/bitlbee/bitlbee-3.0.1.ebuild5
-rw-r--r--net-im/bitlbee/files/bitlbee-3.0.1-ldflags.patch11
3 files changed, 21 insertions, 3 deletions
diff --git a/net-im/bitlbee/ChangeLog b/net-im/bitlbee/ChangeLog
index d66d770dd82e..4ae1c64c6c43 100644
--- a/net-im/bitlbee/ChangeLog
+++ b/net-im/bitlbee/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/bitlbee
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/bitlbee/ChangeLog,v 1.136 2011/01/23 14:55:15 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/bitlbee/ChangeLog,v 1.137 2011/01/27 11:00:33 hwoarang Exp $
+
+ 27 Jan 2011; Markos Chandras <hwoarang@gentoo.org> bitlbee-3.0.1.ebuild,
+ +files/bitlbee-3.0.1-ldflags.patch:
+ QA commit: Respect ldflags: Bug #350466. Thanks to Nick White
+ <gentoo@njw.me.uk>
+ AMD64: Stable on amd64 wrt bug #347537
23 Jan 2011; Raúl Porcel <armin76@gentoo.org> bitlbee-1.2.3.ebuild,
bitlbee-1.2.3-r1.ebuild, bitlbee-1.2.8.ebuild, bitlbee-3.0.ebuild,
diff --git a/net-im/bitlbee/bitlbee-3.0.1.ebuild b/net-im/bitlbee/bitlbee-3.0.1.ebuild
index 1d1cba9d85d1..d43f1bf2348c 100644
--- a/net-im/bitlbee/bitlbee-3.0.1.ebuild
+++ b/net-im/bitlbee/bitlbee-3.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/bitlbee/bitlbee-3.0.1.ebuild,v 1.5 2011/01/23 14:55:15 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/bitlbee/bitlbee-3.0.1.ebuild,v 1.6 2011/01/27 11:00:33 hwoarang Exp $
EAPI="3"
inherit eutils toolchain-funcs confutils multilib
@@ -11,7 +11,7 @@ SRC_URI="http://get.bitlbee.org/src/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ppc ~x86 ~x86-fbsd"
+KEYWORDS="amd64 ppc ~x86 ~x86-fbsd"
IUSE="debug gnutls ipv6 +jabber libevent msn nss +oscar otr +plugins purple ssl test twitter +yahoo xinetd" # ldap - Bug 195758
COMMON_DEPEND="purple? ( net-im/pidgin )
@@ -87,6 +87,7 @@ src_prepare() {
configure || die "sed failed in configure"
epatch "${FILESDIR}"/${PN}-3.0-configure.patch
+ epatch "${FILESDIR}"/${PN}-3.0.1-ldflags.patch
}
src_configure() {
diff --git a/net-im/bitlbee/files/bitlbee-3.0.1-ldflags.patch b/net-im/bitlbee/files/bitlbee-3.0.1-ldflags.patch
new file mode 100644
index 000000000000..a294801cd7ee
--- /dev/null
+++ b/net-im/bitlbee/files/bitlbee-3.0.1-ldflags.patch
@@ -0,0 +1,11 @@
+--- Makefile 2011-01-18 01:16:42.346666267 +0000
++++ Makefile 2011-01-18 01:17:35.246666305 +0000
+@@ -120,7 +120,7 @@ $(subdirs):
+
+ $(OTR_PI): %.so: $(SRCDIR)%.c
+ @echo '*' Building plugin $@
+- @$(CC) $(CFLAGS) $(OTRFLAGS) -fPIC -shared $< -o $@
++ @$(CC) $(CFLAGS) $(OTRFLAGS) -fPIC -shared $(LDFLAGS) $< -o $@
+
+ $(objects): %.o: $(SRCDIR)%.c
+ @echo '*' Compiling $<