summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2011-01-08 18:45:06 +0000
committerMichael Weber <xmw@gentoo.org>2011-01-08 18:45:06 +0000
commit42774940f2fe371bbef8b36a3e8443d571e4d824 (patch)
tree3b17b9f47f7ab13b29085396d595a359ffa00b6d
parentStable for HPPA (bug #350877). (diff)
downloadgentoo-2-42774940f2fe371bbef8b36a3e8443d571e4d824.tar.gz
gentoo-2-42774940f2fe371bbef8b36a3e8443d571e4d824.tar.bz2
gentoo-2-42774940f2fe371bbef8b36a3e8443d571e4d824.zip
Version bump, python3 stuff
(Portage version: 2.1.9.25/cvs/Linux x86_64)
-rw-r--r--app-text/xmldiff/ChangeLog11
-rw-r--r--app-text/xmldiff/metadata.xml3
-rw-r--r--app-text/xmldiff/xmldiff-0.6.10.ebuild25
-rw-r--r--app-text/xmldiff/xmldiff-0.6.9-r1.ebuild25
4 files changed, 62 insertions, 2 deletions
diff --git a/app-text/xmldiff/ChangeLog b/app-text/xmldiff/ChangeLog
index 3c6ed69c1086..9b539b5bbae5 100644
--- a/app-text/xmldiff/ChangeLog
+++ b/app-text/xmldiff/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-text/xmldiff
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xmldiff/ChangeLog,v 1.15 2011/01/08 16:54:07 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/xmldiff/ChangeLog,v 1.16 2011/01/08 18:45:06 xmw Exp $
+
+*xmldiff-0.6.10 (08 Jan 2011)
+*xmldiff-0.6.9-r1 (08 Jan 2011)
+
+ 08 Jan 2011; Michael Weber <xmw@gentoo.org> +xmldiff-0.6.9-r1.ebuild,
+ +xmldiff-0.6.10.ebuild, metadata.xml:
+ Taking maintainership, resolving python issues (thanks to David Abbott on bug
+ 312129) and bumping to 0.6.10 (thanks to Stefan de Konink <stefan@konink.de>
+ on bug 349499).
08 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
xmldiff-0.6.9.ebuild:
diff --git a/app-text/xmldiff/metadata.xml b/app-text/xmldiff/metadata.xml
index ac44028f647b..8bea2d5d1ad0 100644
--- a/app-text/xmldiff/metadata.xml
+++ b/app-text/xmldiff/metadata.xml
@@ -3,7 +3,8 @@
<pkgmetadata>
<herd>no-herd</herd>
<maintainer>
- <email>maintainer-needed@gentoo.org</email>
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
</maintainer>
<longdescription>A python tool that figures out the differences between two
similar XML files, in the same way the diff utility does.
diff --git a/app-text/xmldiff/xmldiff-0.6.10.ebuild b/app-text/xmldiff/xmldiff-0.6.10.ebuild
new file mode 100644
index 000000000000..a2e2657b0ad8
--- /dev/null
+++ b/app-text/xmldiff/xmldiff-0.6.10.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/xmldiff/xmldiff-0.6.10.ebuild,v 1.1 2011/01/08 18:45:06 xmw Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="*"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils python
+
+DESCRIPTION="A tool that figures out the differences between two similar XML files"
+HOMEPAGE="http://www.logilab.org/projects/xmldiff/"
+SRC_URI="ftp://ftp.logilab.fr/pub/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-python/pyxml"
+RDEPEND="${DEPEND}"
+
+DOCS="ChangeLog README README.xmlrev TODO"
diff --git a/app-text/xmldiff/xmldiff-0.6.9-r1.ebuild b/app-text/xmldiff/xmldiff-0.6.9-r1.ebuild
new file mode 100644
index 000000000000..536eb261c613
--- /dev/null
+++ b/app-text/xmldiff/xmldiff-0.6.9-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/xmldiff/xmldiff-0.6.9-r1.ebuild,v 1.1 2011/01/08 18:45:06 xmw Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="*"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils python
+
+DESCRIPTION="A tool that figures out the differences between two similar XML files"
+HOMEPAGE="http://www.logilab.org/projects/xmldiff/"
+SRC_URI="ftp://ftp.logilab.fr/pub/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-python/pyxml"
+RDEPEND="${DEPEND}"
+
+DOCS="ChangeLog README README.xmlrev TODO"