summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarald van Dijk <truedfx@gentoo.org>2008-08-21 19:43:19 +0000
committerHarald van Dijk <truedfx@gentoo.org>2008-08-21 19:43:19 +0000
commit43f27ad65cf9bc0b0049cd6bbf98093bbe45c636 (patch)
treef5eef8c5e2c7cb97f85d780aadfa38f94d407eb1
parentVersion bump (diff)
downloadgentoo-2-43f27ad65cf9bc0b0049cd6bbf98093bbe45c636.tar.gz
gentoo-2-43f27ad65cf9bc0b0049cd6bbf98093bbe45c636.tar.bz2
gentoo-2-43f27ad65cf9bc0b0049cd6bbf98093bbe45c636.zip
Fix Emacs support (bug #234920, by Ulrich Müller)
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo-r1 x86_64)
-rw-r--r--dev-libs/librep/ChangeLog7
-rw-r--r--dev-libs/librep/files/50librep-gentoo.el6
-rw-r--r--dev-libs/librep/files/librep-0.17_p20070101-disable-elisp.patch20
-rw-r--r--dev-libs/librep/librep-0.17_p20070101.ebuild26
4 files changed, 55 insertions, 4 deletions
diff --git a/dev-libs/librep/ChangeLog b/dev-libs/librep/ChangeLog
index 1c3b60fa9b3e..584cea3be2cd 100644
--- a/dev-libs/librep/ChangeLog
+++ b/dev-libs/librep/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/librep
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/librep/ChangeLog,v 1.49 2008/01/14 20:04:29 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/librep/ChangeLog,v 1.50 2008/08/21 19:43:18 truedfx Exp $
+
+ 21 Aug 2008; Harald van Dijk <truedfx@gentoo.org>
+ +files/librep-0.17_p20070101-disable-elisp.patch,
+ +files/50librep-gentoo.el, librep-0.17_p20070101.ebuild:
+ Fix Emacs support (bug #234920, by Ulrich Müller)
14 Jan 2008; Tobias Scherbaum <dertobi123@gentoo.org>
librep-0.17_p20070101.ebuild:
diff --git a/dev-libs/librep/files/50librep-gentoo.el b/dev-libs/librep/files/50librep-gentoo.el
new file mode 100644
index 000000000000..59025bbb9d0e
--- /dev/null
+++ b/dev-libs/librep/files/50librep-gentoo.el
@@ -0,0 +1,6 @@
+
+;;; librep site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'rep-debugger "rep-debugger"
+ "Run the rep debugger on program FILE in buffer *gud-FILE*." t)
diff --git a/dev-libs/librep/files/librep-0.17_p20070101-disable-elisp.patch b/dev-libs/librep/files/librep-0.17_p20070101-disable-elisp.patch
new file mode 100644
index 000000000000..b41e19d15afd
--- /dev/null
+++ b/dev-libs/librep/files/librep-0.17_p20070101-disable-elisp.patch
@@ -0,0 +1,20 @@
+--- librep-0.17-orig/Makefile.in 2003-09-04 07:57:43.000000000 +0200
++++ librep-0.17/Makefile.in 2008-08-16 13:16:41.000000000 +0200
+@@ -53,7 +53,6 @@
+ $(INSTALL_SCRIPT) libtool $(DESTDIR)$(repcommonexecdir)
+ $(INSTALL_DATA) rules.mk $(DESTDIR)$(repcommonexecdir)
+ $(INSTALL_SCRIPT) install-aliases $(DESTDIR)$(repcommonexecdir)
+- $(INSTALL_DATA) rep-debugger.el $(DESTDIR)$(emacssitelispdir)
+
+ @echo "---------------------------------------------------------"
+ @echo "Trying to install rep.m4 in $(DESTDIR)$(aclocaldir);"
+@@ -64,8 +63,7 @@
+ installdirs : mkinstalldirs
+ $(SHELL) $< $(DESTDIR)$(repdir)/$(version) \
+ $(DESTDIR)$(bindir) $(DESTDIR)$(aclocaldir) \
+- $(DESTDIR)$(repcommonexecdir) $(DESTDIR)$(repexecdir) \
+- $(DESTDIR)$(emacssitelispdir)
++ $(DESTDIR)$(repcommonexecdir) $(DESTDIR)$(repexecdir)
+
+ uninstall :
+ -for dir in $(INSTALL_SUBDIRS); do \
diff --git a/dev-libs/librep/librep-0.17_p20070101.ebuild b/dev-libs/librep/librep-0.17_p20070101.ebuild
index cb9cb271913d..f548c79f9c70 100644
--- a/dev-libs/librep/librep-0.17_p20070101.ebuild
+++ b/dev-libs/librep/librep-0.17_p20070101.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/librep/librep-0.17_p20070101.ebuild,v 1.4 2008/01/14 20:04:29 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/librep/librep-0.17_p20070101.ebuild,v 1.5 2008/08/21 19:43:18 truedfx Exp $
MY_P=${P%_*}
WANT_AUTOCONF="latest"
WANT_AUTOMAKE="latest"
-inherit autotools eutils toolchain-funcs multilib
+inherit autotools eutils toolchain-funcs multilib elisp-common
DESCRIPTION="Shared library implementing a Lisp dialect"
HOMEPAGE="http://librep.sourceforge.net/"
@@ -17,9 +17,10 @@ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha ~amd64 ia64 ppc ~ppc64 sparc x86"
-IUSE="readline"
+IUSE="emacs readline"
RDEPEND=">=sys-libs/gdbm-1.8.0
+ emacs? ( virtual/emacs )
readline? ( sys-libs/readline )"
DEPEND="${RDEPEND}
sys-apps/texinfo"
@@ -32,6 +33,7 @@ src_unpack() {
epatch "${DISTDIR}"/${P}.patch.bz2
epatch "${FILESDIR}"/${P}-libtool.patch
epatch "${FILESDIR}"/rep_file_fdopen.patch
+ epatch "${FILESDIR}"/${P}-disable-elisp.patch
eautoreconf || die "eautoreconf failed"
}
@@ -43,6 +45,10 @@ src_compile() {
$(use_with readline) || die "configure failed"
LC_ALL=C emake || die "make failed"
+
+ if use emacs; then
+ elisp-compile rep-debugger.el || die "elisp-compile failed"
+ fi
}
src_install() {
@@ -50,4 +56,18 @@ src_install() {
dodoc AUTHORS BUGS ChangeLog NEWS README THANKS TODO TREE
docinto doc
dodoc doc/*
+
+ if use emacs; then
+ elisp-install ${PN} rep-debugger.{el,elc} || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" \
+ || die "elisp-site-file-install failed"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
}