summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-12-08 11:54:20 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-12-08 11:54:20 +0000
commit44185f2c5baee778dded664ecabd74e24dd02f2a (patch)
tree11642cc11d01871d024d0f441da7cf536400b3bc
parentDrop KDE 4.8 (diff)
downloadgentoo-2-44185f2c5baee778dded664ecabd74e24dd02f2a.tar.gz
gentoo-2-44185f2c5baee778dded664ecabd74e24dd02f2a.tar.bz2
gentoo-2-44185f2c5baee778dded664ecabd74e24dd02f2a.zip
Version bump to use the Makefile's targets for building and installing.
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key D4301342)
-rw-r--r--sys-apps/hwids/ChangeLog8
-rw-r--r--sys-apps/hwids/hwids-20121208.5.ebuild (renamed from sys-apps/hwids/hwids-20121208.ebuild)28
-rw-r--r--sys-apps/hwids/hwids-99999999.ebuild28
3 files changed, 22 insertions, 42 deletions
diff --git a/sys-apps/hwids/ChangeLog b/sys-apps/hwids/ChangeLog
index ee4838cb0d6c..9b89fb631c85 100644
--- a/sys-apps/hwids/ChangeLog
+++ b/sys-apps/hwids/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/hwids
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/ChangeLog,v 1.51 2012/12/08 11:30:12 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/ChangeLog,v 1.52 2012/12/08 11:54:20 flameeyes Exp $
+
+*hwids-20121208.5 (08 Dec 2012)
+
+ 08 Dec 2012; Diego E. Pettenò <flameeyes@gentoo.org> +hwids-20121208.5.ebuild,
+ -hwids-20121208.ebuild, hwids-99999999.ebuild:
+ Version bump to use the Makefile's targets for building and installing.
*hwids-20121208 (08 Dec 2012)
diff --git a/sys-apps/hwids/hwids-20121208.ebuild b/sys-apps/hwids/hwids-20121208.5.ebuild
index 5314e1cbf0cd..9af5ded8b3f7 100644
--- a/sys-apps/hwids/hwids-20121208.ebuild
+++ b/sys-apps/hwids/hwids-20121208.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-20121208.ebuild,v 1.1 2012/12/08 11:30:12 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-20121208.5.ebuild,v 1.1 2012/12/08 11:54:20 flameeyes Exp $
EAPI=5
inherit udev
@@ -18,26 +18,14 @@ DEPEND="udev? ( dev-lang/perl !=sys-fs/udev-196 )"
RDEPEND="!<sys-apps/pciutils-3.1.9-r2
!<sys-apps/usbutils-005-r1"
-src_compile() {
- for file in {usb,pci}.ids; do
- gzip -c ${file} > ${file}.gz || die
- done
+S=${WORKDIR}/hwids-${P}
- if use udev; then
- emake udev-hwdb
- fi
-}
-
-src_install() {
- insinto /usr/share/misc
- doins {usb,pci}.ids{,.gz} oui.txt iab.txt
-
- dodoc README.md
-
- if use udev; then
- insinto "$(udev_get_udevdir)"/hwdb.d
- doins udev/*.hwdb
- fi
+src_configure() {
+ MAKEOPTS+=" UDEV=$(usex udev)"
+ MAKEOPTS+=" DOCDIR=/usr/share/doc/${PF}"
+ MAKEOPTS+=" MISCDIR=/usr/share/misc"
+ MAKEOPTS+=" HWDBDIR=$(udev_get_udevdir)/hwdb.d"
+ MAKEOPTS+=" DESTDIR=${D}"
}
pkg_postinst() {
diff --git a/sys-apps/hwids/hwids-99999999.ebuild b/sys-apps/hwids/hwids-99999999.ebuild
index 6cf1b6010d4f..5af37e3f1e1c 100644
--- a/sys-apps/hwids/hwids-99999999.ebuild
+++ b/sys-apps/hwids/hwids-99999999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-99999999.ebuild,v 1.11 2012/12/08 11:30:12 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-99999999.ebuild,v 1.12 2012/12/08 11:54:20 flameeyes Exp $
EAPI=5
inherit udev git-2
@@ -23,26 +23,12 @@ src_prepare() {
emake fetch
}
-src_compile() {
- for file in {usb,pci}.ids; do
- gzip -c ${file} > ${file}.gz || die
- done
-
- if use udev; then
- emake udev-hwdb
- fi
-}
-
-src_install() {
- insinto /usr/share/misc
- doins {usb,pci}.ids{,.gz} oui.txt iab.txt
-
- dodoc README.md
-
- if use udev; then
- insinto "$(udev_get_udevdir)"/hwdb.d
- doins udev/*.hwdb
- fi
+src_configure() {
+ MAKEOPTS+=" UDEV=$(usex udev)"
+ MAKEOPTS+=" DOCDIR=/usr/share/doc/${PF}"
+ MAKEOPTS+=" MISCDIR=/usr/share/misc"
+ MAKEOPTS+=" HWDBDIR=$(udev_get_udevdir)/hwdb.d"
+ MAKEOPTS+=" DESTDIR=${D}"
}
pkg_postinst() {