summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-21 16:26:40 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-21 16:26:40 +0000
commit4c8c5c540e46c7a35ce886b4a5826d1c3f0c83a0 (patch)
tree45b7ea5f020a2ad7ebc5672510197337b40af279
parent~amd64 (Manifest recommit) (diff)
downloadgentoo-2-4c8c5c540e46c7a35ce886b4a5826d1c3f0c83a0.tar.gz
gentoo-2-4c8c5c540e46c7a35ce886b4a5826d1c3f0c83a0.tar.bz2
gentoo-2-4c8c5c540e46c7a35ce886b4a5826d1c3f0c83a0.zip
cleanup
-rw-r--r--net-misc/freeswan/freeswan-1.99.ebuild4
-rw-r--r--net-misc/freeswan/freeswan-2.04.ebuild56
-rw-r--r--net-misc/htbinit/htbinit-0.8.4.ebuild13
-rw-r--r--net-misc/openswan/openswan-2.0.0.ebuild4
-rw-r--r--net-misc/openswan/openswan-2.1.0.ebuild4
-rw-r--r--net-misc/openswan/openswan-2.1.1.ebuild24
-rw-r--r--net-misc/ptrtd/ptrtd-0.5.2.ebuild20
-rw-r--r--net-misc/vpnc/vpnc-0.2_pre7.ebuild10
8 files changed, 63 insertions, 72 deletions
diff --git a/net-misc/freeswan/freeswan-1.99.ebuild b/net-misc/freeswan/freeswan-1.99.ebuild
index ded7e48b3b50..aeaef780c6db 100644
--- a/net-misc/freeswan/freeswan-1.99.ebuild
+++ b/net-misc/freeswan/freeswan-1.99.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/freeswan/freeswan-1.99.ebuild,v 1.10 2004/02/21 08:19:40 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/freeswan/freeswan-1.99.ebuild,v 1.11 2004/04/21 16:22:46 vapier Exp $
X509_PATCH=0.9.34
S=${WORKDIR}/${P}
@@ -12,7 +12,7 @@ HOMEPAGE="http://www.freeswan.org"
DEPEND="virtual/glibc
virtual/linux-sources
>=dev-libs/gmp-3.1.1
- sys-apps/iproute"
+ sys-apps/iproute2"
LICENSE="GPL-2"
RDEPEND=""
SLOT="0"
diff --git a/net-misc/freeswan/freeswan-2.04.ebuild b/net-misc/freeswan/freeswan-2.04.ebuild
index 3957263dfaeb..297582a00755 100644
--- a/net-misc/freeswan/freeswan-2.04.ebuild
+++ b/net-misc/freeswan/freeswan-2.04.ebuild
@@ -1,33 +1,33 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/freeswan/freeswan-2.04.ebuild,v 1.3 2004/02/21 08:20:09 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/freeswan/freeswan-2.04.ebuild,v 1.4 2004/04/21 16:22:46 vapier Exp $
inherit eutils
X509_PATCH=1.4.8
-S=${WORKDIR}/${P}
DESCRIPTION="FreeS/WAN IPSec Userspace Utilities with X.509 Patches"
+HOMEPAGE="http://www.freeswan.org"
SRC_URI="ftp://ftp.xs4all.nl/pub/crypto/freeswan/${P}.tar.gz
http://www.strongsec.com/freeswan/x509-${X509_PATCH}-${P}.tar.gz"
-HOMEPAGE="http://www.freeswan.org"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 -sparc"
+IUSE=""
+
DEPEND="virtual/glibc
virtual/linux-sources
>=dev-libs/gmp-3.1.1
net-misc/host
- sys-apps/iproute"
-LICENSE="GPL-2"
+ sys-apps/iproute2"
RDEPEND=""
-SLOT="0"
-KEYWORDS="~x86 -sparc"
pkg_setup() {
- [ -d /usr/src/linux/net/ipsec ] || {
+ [ -d ${ROOT}/usr/src/linux/net/ipsec ] || {
echo You need to have the crypto-enabled version of Gentoo Sources
echo with a symlink to it in /usr/src/linux in order to have IPSec
echo kernel compatibility.
-
- exit 1
+ die
}
}
@@ -45,38 +45,34 @@ src_unpack() {
}
src_compile() {
-
- make \
- DESTDIR=${D} \
- USERCOMPILE="${CFLAGS}" \
- FINALCONFDIR=/etc/ipsec \
- INC_RCDEFAULT=/etc/init.d \
- INC_USRLOCAL=/usr \
- INC_MANDIR=share/man \
+ make \
+ DESTDIR=${D} \
+ USERCOMPILE="${CFLAGS}" \
+ FINALCONFDIR=/etc/ipsec \
+ INC_RCDEFAULT=/etc/init.d \
+ INC_USRLOCAL=/usr \
+ INC_MANDIR=share/man \
confcheck programs || die
}
-src_install () {
-
+src_install() {
# try make prefix=${D}/usr install
-
- make \
- DESTDIR=${D} \
- USERCOMPILE="${CFLAGS}" \
- FINALCONFDIR=/etc/ipsec \
- INC_RCDEFAULT=/etc/init.d \
- INC_USRLOCAL=/usr \
- INC_MANDIR=share/man \
+ make \
+ DESTDIR=${D} \
+ USERCOMPILE="${CFLAGS}" \
+ FINALCONFDIR=/etc/ipsec \
+ INC_RCDEFAULT=/etc/init.d \
+ INC_USRLOCAL=/usr \
+ INC_MANDIR=share/man \
install || die
newdoc ${WORKDIR}/x509-${X509_PATCH}-${P}/README README.x509
newdoc ${WORKDIR}/x509-${X509_PATCH}-${P}/CHANGES CHANGES.x509
newdoc ${WORKDIR}/x509-${X509_PATCH}-${P}/ipsec.secrets.template ipsec.secrets.x509
- dodoc INSTALL COPYING CREDITS BUGS CHANGES README doc/*
+ dodoc INSTALL CREDITS BUGS CHANGES README doc/*
dosym /etc/ipsec/ipsec.d /etc/ipsec.d
dosym /etc/ipsec/ipsec.conf /etc/ipsec.conf
exeinto /etc/init.d/
doexe ${FILESDIR}/ipsec
}
-
diff --git a/net-misc/htbinit/htbinit-0.8.4.ebuild b/net-misc/htbinit/htbinit-0.8.4.ebuild
index f94e49e51217..1bc35d56b3c9 100644
--- a/net-misc/htbinit/htbinit-0.8.4.ebuild
+++ b/net-misc/htbinit/htbinit-0.8.4.ebuild
@@ -1,18 +1,19 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/htbinit/htbinit-0.8.4.ebuild,v 1.3 2003/09/05 22:01:48 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/htbinit/htbinit-0.8.4.ebuild,v 1.4 2004/04/21 16:23:35 vapier Exp $
DESCRIPTION="Sets up Hierachical Token Bucket based traffic control (QoS) with iproute2"
HOMEPAGE="http://www.sourceforge.net/projects/htbinit"
-SRC_URI="http://unc.dl.sourceforge.net/sourceforge/htbinit/htb.init-v${PV}"
+SRC_URI="mirror://sourceforge/htbinit/htb.init-v${PV}"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+IUSE=""
-DEPEND="sys-apps/iproute"
-RDEPEND="${DEPEND}"
+DEPEND="sys-apps/iproute2"
-S="${WORKDIR}"
+S=${WORKDIR}
src_unpack() {
cp ${DISTDIR}/htb.init-v${PV} ${S}
diff --git a/net-misc/openswan/openswan-2.0.0.ebuild b/net-misc/openswan/openswan-2.0.0.ebuild
index b0901bb927b5..f9d197fd548f 100644
--- a/net-misc/openswan/openswan-2.0.0.ebuild
+++ b/net-misc/openswan/openswan-2.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openswan/openswan-2.0.0.ebuild,v 1.1 2004/02/22 04:58:34 pfeifer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openswan/openswan-2.0.0.ebuild,v 1.2 2004/04/21 16:25:24 vapier Exp $
MY_P=${P/_p/_kb}
S=${WORKDIR}/${MY_P}
@@ -13,7 +13,7 @@ DEPEND="virtual/glibc
virtual/linux-sources
>=dev-libs/gmp-3.1.1
net-misc/host
- sys-apps/iproute"
+ sys-apps/iproute2"
RDEPEND=""
LICENSE="GPL-2"
SLOT="0"
diff --git a/net-misc/openswan/openswan-2.1.0.ebuild b/net-misc/openswan/openswan-2.1.0.ebuild
index 56232a8810d0..6046a801d4eb 100644
--- a/net-misc/openswan/openswan-2.1.0.ebuild
+++ b/net-misc/openswan/openswan-2.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openswan/openswan-2.1.0.ebuild,v 1.1 2004/03/18 02:11:22 pfeifer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openswan/openswan-2.1.0.ebuild,v 1.2 2004/04/21 16:25:24 vapier Exp $
MY_P=${P/_p/_kb}
S=${WORKDIR}/${MY_P}
@@ -13,7 +13,7 @@ DEPEND="virtual/glibc
virtual/linux-sources
>=dev-libs/gmp-3.1.1
net-misc/host
- sys-apps/iproute"
+ sys-apps/iproute2"
RDEPEND=""
LICENSE="GPL-2"
SLOT="0"
diff --git a/net-misc/openswan/openswan-2.1.1.ebuild b/net-misc/openswan/openswan-2.1.1.ebuild
index 9fc5a3960f57..d1be007dfebc 100644
--- a/net-misc/openswan/openswan-2.1.1.ebuild
+++ b/net-misc/openswan/openswan-2.1.1.ebuild
@@ -1,24 +1,25 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openswan/openswan-2.1.1.ebuild,v 1.2 2004/03/31 13:13:45 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openswan/openswan-2.1.1.ebuild,v 1.3 2004/04/21 16:25:24 vapier Exp $
MY_P=${P/_p/_kb}
S=${WORKDIR}/${MY_P}
DESCRIPTION="Open Source implementation of IPsec for the Linux operating system (was SuperFreeS/WAN)."
-SRC_URI="http://www.openswan.org/code/${MY_P}.tar.gz
- mirror://gentoo/${MY_P}.tar.gz"
HOMEPAGE="http://www.openswan.org/"
+SRC_URI="http://www.openswan.org/code/${MY_P}.tar.gz
+ mirror://gentoo/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~x86 ~amd64"
+IUSE=""
DEPEND="virtual/glibc
virtual/linux-sources
>=dev-libs/gmp-3.1.1
net-misc/host
- sys-apps/iproute"
+ sys-apps/iproute2"
RDEPEND=""
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64 -*"
-
check_version_h() {
if [ ! -f "${ROOT}/usr/src/linux/include/linux/version.h" ]
@@ -94,7 +95,6 @@ src_unpack() {
}
src_compile() {
-
make \
DESTDIR=${D} \
USERCOMPILE="${CFLAGS}" \
@@ -105,8 +105,7 @@ src_compile() {
${MYMAKE} || die
}
-src_install () {
-
+src_install() {
make \
DESTDIR=${D} \
USERCOMPILE="${CFLAGS}" \
@@ -116,10 +115,9 @@ src_install () {
INC_MANDIR=share/man \
install || die
- dodoc INSTALL COPYING CREDITS BUGS CHANGES README doc/*
+ dodoc INSTALL CREDITS BUGS CHANGES README doc/*
dosym /etc/ipsec/ipsec.d /etc/ipsec.d
exeinto /etc/init.d/
doexe ${FILESDIR}/ipsec
-
}
diff --git a/net-misc/ptrtd/ptrtd-0.5.2.ebuild b/net-misc/ptrtd/ptrtd-0.5.2.ebuild
index 97b8baa0c0d0..b737340ed70e 100644
--- a/net-misc/ptrtd/ptrtd-0.5.2.ebuild
+++ b/net-misc/ptrtd/ptrtd-0.5.2.ebuild
@@ -1,19 +1,18 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ptrtd/ptrtd-0.5.2.ebuild,v 1.2 2003/07/13 14:31:36 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ptrtd/ptrtd-0.5.2.ebuild,v 1.3 2004/04/21 16:26:15 vapier Exp $
DESCRIPTION="Portable Transport Relay Translator Daemon for IPv6"
-
-HOMEPAGE="http://v6web.litech.org/ptrtd"
-
+HOMEPAGE="http://v6web.litech.org/ptrtd/"
SRC_URI="http://v6web.litech.org/ptrtd/dist/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
-
KEYWORDS="x86"
+IUSE=""
+
DEPEND=""
-RDEPEND="sys-apps/iproute"
-S=${WORKDIR}/${P}
+RDEPEND="sys-apps/iproute2"
src_unpack() {
unpack ${A}
@@ -23,11 +22,6 @@ src_unpack() {
${T}/Makefile.in > Makefile.in
}
-src_compile() {
- econf || die
- emake || die
-}
-
src_install() {
einstall || die
diff --git a/net-misc/vpnc/vpnc-0.2_pre7.ebuild b/net-misc/vpnc/vpnc-0.2_pre7.ebuild
index cc05799cac1a..ff7b4170a1a0 100644
--- a/net-misc/vpnc/vpnc-0.2_pre7.ebuild
+++ b/net-misc/vpnc/vpnc-0.2_pre7.ebuild
@@ -1,28 +1,30 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vpnc/vpnc-0.2_pre7.ebuild,v 1.1 2004/02/03 16:30:47 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vpnc/vpnc-0.2_pre7.ebuild,v 1.2 2004/04/21 16:26:40 vapier Exp $
MY_P="vpnc-0.2-rm+zomb-pre7"
DESCRIPTION="Free client for Cisco VPN routing software"
HOMEPAGE="http://www.unix-ag.uni-kl.de/~massar/vpnc/"
SRC_URI="http://www.unix-ag.uni-kl.de/~massar/vpnc/${MY_P}.tar.gz"
+
LICENSE="GPL-2 BSD"
SLOT="0"
KEYWORDS="~x86"
IUSE=""
+
DEPEND=">=dev-libs/libgcrypt-1.1.91
- sys-apps/iproute"
+ sys-apps/iproute2"
+
S=${WORKDIR}/${MY_P}
src_compile() {
# Workaround for crappy Makefile
sed -i -e "s:CFLAGS=-W -Wall -O:CFLAGS=${CFLAGS}:" Makefile
-
emake || die
}
src_install() {
- dobin vpnc vpnc-connect vpnc-disconnect
+ dobin vpnc vpnc-connect vpnc-disconnect || die
dodoc ChangeLog README TODO VERSION
insinto /etc
doins vpnc.conf