summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2011-03-18 07:48:12 +0000
committerMart Raudsepp <leio@gentoo.org>2011-03-18 07:48:12 +0000
commit5191ebdd5dfbccebf522f227e9c0f9399f7cd7d9 (patch)
tree964ff50cd8c39aac7aa5a44eba6341ca6530efd5
parentAdded missing DEPENDs to build manpages, #359183 (diff)
downloadgentoo-2-5191ebdd5dfbccebf522f227e9c0f9399f7cd7d9.tar.gz
gentoo-2-5191ebdd5dfbccebf522f227e9c0f9399f7cd7d9.tar.bz2
gentoo-2-5191ebdd5dfbccebf522f227e9c0f9399f7cd7d9.zip
Fix tests for 0.10.32; second report on bug #352944
(Portage version: 2.2.0_alpha10/cvs/Linux x86_64)
-rw-r--r--media-libs/gst-plugins-base/ChangeLog7
-rw-r--r--media-libs/gst-plugins-base/files/gst-plugins-base-0.10.32-fix-tests-encodebin.patch69
-rw-r--r--media-libs/gst-plugins-base/gst-plugins-base-0.10.32.ebuild3
3 files changed, 77 insertions, 2 deletions
diff --git a/media-libs/gst-plugins-base/ChangeLog b/media-libs/gst-plugins-base/ChangeLog
index 08513dc6e30e..be2cc50ec56d 100644
--- a/media-libs/gst-plugins-base/ChangeLog
+++ b/media-libs/gst-plugins-base/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/gst-plugins-base
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-base/ChangeLog,v 1.162 2011/03/13 09:25:28 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-base/ChangeLog,v 1.163 2011/03/18 07:48:11 leio Exp $
+
+ 18 Mar 2011; Mart Raudsepp <leio@gentoo.org>
+ +files/gst-plugins-base-0.10.32-fix-tests-encodebin.patch,
+ gst-plugins-base-0.10.32.ebuild:
+ Fix tests for 0.10.32; second report on bug #352944
13 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org>
gst-plugins-base-0.10.31.ebuild:
diff --git a/media-libs/gst-plugins-base/files/gst-plugins-base-0.10.32-fix-tests-encodebin.patch b/media-libs/gst-plugins-base/files/gst-plugins-base-0.10.32-fix-tests-encodebin.patch
new file mode 100644
index 000000000000..23cf617135c0
--- /dev/null
+++ b/media-libs/gst-plugins-base/files/gst-plugins-base-0.10.32-fix-tests-encodebin.patch
@@ -0,0 +1,69 @@
+commit fc608d4dcd0257549c6018aac9ee5c2dec52bbee
+Author: Tim-Philipp Müller
+Date: Wed Jan 26 15:42:48 2011 +0000
+
+ tests: don't run encodebin test if vorbis or theora plugins aren't available
+
+Minimal Makefile.in patch added manually to avoid eautoreconf
+
+diff --git a/tests/check/Makefile.am b/tests/check/Makefile.am
+index 0cc03a4..f284716 100644
+--- a/tests/check/Makefile.am
++++ b/tests/check/Makefile.am
+@@ -77,6 +77,16 @@ else
+ check_theora =
+ endif
+
++if USE_VORBIS
++if USE_THEORA
++check_encodebin = elements/encodebin
++else
++check_encodebin =
++endif
++else
++check_encodebin =
++endif
++
+ if USE_PLUGIN_SUBPARSE
+ check_subparse = elements/subparse
+ else
+@@ -106,7 +116,7 @@ check_PROGRAMS = \
+ elements/audiotestsrc \
+ elements/decodebin \
+ elements/decodebin2 \
+- elements/encodebin \
++ $(check_encodebin) \
+ elements/ffmpegcolorspace \
+ elements/gdpdepay \
+ elements/gdppay \
+--- a/tests/check/Makefile.in
++++ b/tests/check/Makefile.in
+@@ -43,7 +43,7 @@
+ elements/audioconvert$(EXEEXT) elements/audiorate$(EXEEXT) \
+ elements/audioresample$(EXEEXT) elements/audiotestsrc$(EXEEXT) \
+ elements/decodebin$(EXEEXT) elements/decodebin2$(EXEEXT) \
+- elements/encodebin$(EXEEXT) elements/ffmpegcolorspace$(EXEEXT) \
++ $(am__EXEEXT_11) elements/ffmpegcolorspace$(EXEEXT) \
+ elements/gdpdepay$(EXEEXT) elements/gdppay$(EXEEXT) \
+ elements/multifdsink$(EXEEXT) elements/playbin$(EXEEXT) \
+ elements/playbin2$(EXEEXT) $(am__EXEEXT_8) \
+@@ -114,7 +114,9 @@
+ @USE_VORBIS_TRUE@ pipelines/vorbisdec$(EXEEXT) \
+ @USE_VORBIS_TRUE@ elements/vorbistag$(EXEEXT)
+ @USE_THEORA_TRUE@am__EXEEXT_7 = pipelines/theoraenc$(EXEEXT)
++@USE_THEORA_TRUE@@USE_VORBIS_TRUE@am__EXEEXT_11 = \
++@USE_THEORA_TRUE@@USE_VORBIS_TRUE@ elements/encodebin$(EXEEXT)
+ @USE_PLUGIN_SUBPARSE_TRUE@am__EXEEXT_8 = elements/subparse$(EXEEXT)
+ @HAVE_ORC_TRUE@am__EXEEXT_9 = orc/adder$(EXEEXT) \
+ @HAVE_ORC_TRUE@ orc/audioconvert$(EXEEXT) orc/volume$(EXEEXT) \
+ @HAVE_ORC_TRUE@ orc/videoscale$(EXEEXT) \
+@@ -932,6 +933,9 @@
+
+ @USE_THEORA_FALSE@check_theora =
+ @USE_THEORA_TRUE@check_theora = pipelines/theoraenc
++@USE_THEORA_FALSE@@USE_VORBIS_TRUE@check_encodebin =
++@USE_THEORA_TRUE@@USE_VORBIS_TRUE@check_encodebin = elements/encodebin
++@USE_VORBIS_FALSE@check_encodebin =
+ @USE_PLUGIN_SUBPARSE_FALSE@check_subparse =
+ @USE_PLUGIN_SUBPARSE_TRUE@check_subparse = elements/subparse
+ @HAVE_ORC_FALSE@check_orc =
diff --git a/media-libs/gst-plugins-base/gst-plugins-base-0.10.32.ebuild b/media-libs/gst-plugins-base/gst-plugins-base-0.10.32.ebuild
index 2cdccf075f8b..609f37331f9f 100644
--- a/media-libs/gst-plugins-base/gst-plugins-base-0.10.32.ebuild
+++ b/media-libs/gst-plugins-base/gst-plugins-base-0.10.32.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-base/gst-plugins-base-0.10.32.ebuild,v 1.1 2011/02/24 06:32:41 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-base/gst-plugins-base-0.10.32.ebuild,v 1.2 2011/03/18 07:48:11 leio Exp $
EAPI=1
@@ -34,6 +34,7 @@ DOCS="AUTHORS NEWS README RELEASE"
src_unpack() {
gnome2_src_unpack
epatch "$FILESDIR/${PN}-0.10.31-fix-tag-test-linking.patch"
+ epatch "$FILESDIR/${P}-fix-tests-encodebin.patch"
}
src_compile() {