summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-04-27 15:03:11 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-04-27 15:03:11 +0000
commit52f27465b494c102f08a82e0a315281f149874f4 (patch)
treed55d3eae0119e66088e8a520aabd2b32f6bd159a
parentFixing SHA256 digest, pass four (diff)
downloadgentoo-2-52f27465b494c102f08a82e0a315281f149874f4.tar.gz
gentoo-2-52f27465b494c102f08a82e0a315281f149874f4.tar.bz2
gentoo-2-52f27465b494c102f08a82e0a315281f149874f4.zip
Version bump thanks to Nicholas Doyle <niskel+bugs@gmail.com> in bug 131400, kde services file thanks to Heiko Baums <heiko@baums-on-web.de> in bug 129335
(Portage version: 2.1_pre9-r4)
-rw-r--r--media-sound/lastfmplayer/ChangeLog10
-rw-r--r--media-sound/lastfmplayer/files/digest-lastfmplayer-1.2_pre20991
-rw-r--r--media-sound/lastfmplayer/files/lastfm.protocol11
-rw-r--r--media-sound/lastfmplayer/lastfmplayer-1.2_pre2099.ebuild78
4 files changed, 99 insertions, 1 deletions
diff --git a/media-sound/lastfmplayer/ChangeLog b/media-sound/lastfmplayer/ChangeLog
index 796016a638bf..c6236fd078a9 100644
--- a/media-sound/lastfmplayer/ChangeLog
+++ b/media-sound/lastfmplayer/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-sound/lastfmplayer
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfmplayer/ChangeLog,v 1.2 2006/04/02 23:11:09 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfmplayer/ChangeLog,v 1.3 2006/04/27 15:03:11 genstef Exp $
+
+*lastfmplayer-1.2_pre2099 (27 Apr 2006)
+
+ 27 Apr 2006; Stefan Schweizer <genstef@gentoo.org> +files/lastfm.protocol,
+ -lastfmplayer-1.1.4_p2099.ebuild, +lastfmplayer-1.2_pre2099.ebuild:
+ Version bump thanks to Nicholas Doyle <niskel+bugs@gmail.com> in bug 131400,
+ kde services file thanks to Heiko Baums <heiko@baums-on-web.de> in bug
+ 129335
02 Apr 2006; Stefan Schweizer <genstef@gentoo.org>
lastfmplayer-1.1.4_p2099.ebuild:
diff --git a/media-sound/lastfmplayer/files/digest-lastfmplayer-1.2_pre2099 b/media-sound/lastfmplayer/files/digest-lastfmplayer-1.2_pre2099
new file mode 100644
index 000000000000..8b137891791f
--- /dev/null
+++ b/media-sound/lastfmplayer/files/digest-lastfmplayer-1.2_pre2099
@@ -0,0 +1 @@
+
diff --git a/media-sound/lastfmplayer/files/lastfm.protocol b/media-sound/lastfmplayer/files/lastfm.protocol
new file mode 100644
index 000000000000..3b3d104f4523
--- /dev/null
+++ b/media-sound/lastfmplayer/files/lastfm.protocol
@@ -0,0 +1,11 @@
+[Protocol]
+exec=/usr/bin/lastfm "%u"
+protocol=lastfm
+input=none
+output=none
+helper=true
+listing=false
+reading=false
+writing=false
+makedir=false
+deleting=false
diff --git a/media-sound/lastfmplayer/lastfmplayer-1.2_pre2099.ebuild b/media-sound/lastfmplayer/lastfmplayer-1.2_pre2099.ebuild
new file mode 100644
index 000000000000..a049f1db761d
--- /dev/null
+++ b/media-sound/lastfmplayer/lastfmplayer-1.2_pre2099.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfmplayer/lastfmplayer-1.2_pre2099.ebuild,v 1.1 2006/04/27 15:03:11 genstef Exp $
+
+inherit eutils subversion
+
+DESCRIPTION="The Last.fm player allows you to listen to their internet radio which is tailored to your music profile"
+HOMEPAGE="http://lastfmplayer.sourceforge.net"
+SRC_URI=""
+ESVN_REPO_URI="svn://svn.audioscrobbler.net/player/branches/1.2"
+ESVN_OPTIONS="--revision ${PV#*_pre}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="=x11-libs/qt-4*"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if ! built_with_use qt gif ; then
+ eerror "It appears that qt was compiled with the \"gif\" USE flag disabled."
+ eerror
+ eerror "In order to use the Last.fm player, you need to enable this USE flag"
+ eerror "To do this, run the following in a command window:"
+ eerror "echo \"x11-libs/qt gif\" >> /etc/portage/package.use"
+ eerror "and recompile qt using \"emerge -avN1 qt\""
+
+ die "no gif support in qt"
+ fi
+}
+
+src_compile() {
+ # gcc-4.1 fix
+ sed -i "s/Player:://" src/player.h || die
+ qmake || die "qmake failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ # The root at which the player, data, and cache
+ # are to be installed
+ local destination="/opt/lastfm"
+
+ # Install the player
+ exeinto ${destination}
+ doexe player
+
+ insinto ${destination}
+ doins -r data
+
+ # Make a folder such that album art cache works
+ diropts -m0775 -g audio
+ dodir ${destination}/cache
+ keepdir ${destination}/cache
+
+ make_wrapper lastfm ./player ${destination}
+ newicon data/icon.png lastfm.png
+ make_desktop_entry lastfm "Last.fm Player" lastfm.png
+
+ insinto /usr/share/services
+ doins ${FILESDIR}/lastfm.protocol
+
+ dodoc ChangeLog README
+}
+
+pkg_postinst() {
+ einfo "In order to use the Last.fm player with your mozilla based browser,"
+ einfo "You must follow these steps:"
+ einfo " 1. Go to \"about:config\" using the location bar"
+ einfo " 2. Right-click on the page. Select \"New\" and then \"String\""
+ einfo " 3. Type in the name field: \"network.protocol-handler.app.lastfm\""
+ einfo " 4. Type in the value field: \"/usr/bin/lastfm\""
+ einfo
+ einfo "If you experiance awkward fonts or widgets, you may consider"
+ einfo "running \"qtconfig\" and change the settings"
+}