summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Vershilov <qnikst@gentoo.org>2013-08-25 07:23:15 +0000
committerAlexander Vershilov <qnikst@gentoo.org>2013-08-25 07:23:15 +0000
commit58bd2708062ab0b4214eefe008cb1c90691e5fbd (patch)
treeb6fea9b0344cf875b41b46e8497197a4375f98c8
parentBump (diff)
downloadgentoo-2-58bd2708062ab0b4214eefe008cb1c90691e5fbd.tar.gz
gentoo-2-58bd2708062ab0b4214eefe008cb1c90691e5fbd.tar.bz2
gentoo-2-58bd2708062ab0b4214eefe008cb1c90691e5fbd.zip
dev-haskell/conduit: 1.0.7.3
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0xEAD50D64D8D3571A!)
-rw-r--r--dev-haskell/conduit/ChangeLog9
-rw-r--r--dev-haskell/conduit/conduit-1.0.7.3.ebuild44
-rw-r--r--dev-haskell/conduit/files/conduit-1.0.7-doctest.patch10
-rw-r--r--dev-haskell/conduit/metadata.xml11
4 files changed, 74 insertions, 0 deletions
diff --git a/dev-haskell/conduit/ChangeLog b/dev-haskell/conduit/ChangeLog
new file mode 100644
index 000000000000..661ff0897a86
--- /dev/null
+++ b/dev-haskell/conduit/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-haskell/conduit
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/conduit/ChangeLog,v 1.1 2013/08/25 07:23:15 qnikst Exp $
+
+*conduit-1.0.7.3 (25 Aug 2013)
+
+ 25 Aug 2013; Alexander Vershilov <qnikst@gentoo.org> +conduit-1.0.7.3.ebuild,
+ +files/conduit-1.0.7-doctest.patch, +metadata.xml:
+ dev-haskell/conduit: 1.0.7.3
diff --git a/dev-haskell/conduit/conduit-1.0.7.3.ebuild b/dev-haskell/conduit/conduit-1.0.7.3.ebuild
new file mode 100644
index 000000000000..0911dfdbc09f
--- /dev/null
+++ b/dev-haskell/conduit/conduit-1.0.7.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/conduit/conduit-1.0.7.3.ebuild,v 1.1 2013/08/25 07:23:15 qnikst Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit eutils haskell-cabal
+
+DESCRIPTION="Streaming data processing library."
+HOMEPAGE="http://github.com/snoyberg/conduit"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/lifted-base-0.1:=[profile?]
+ dev-haskell/mmorph:=[profile?]
+ >=dev-haskell/monad-control-0.3.1:=[profile?]
+ <dev-haskell/monad-control-0.4:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/resourcet-0.4.3:=[profile?]
+ <dev-haskell/resourcet-0.5:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-haskell/transformers-0.2.2:=[profile?]
+ <dev-haskell/transformers-0.4:=[profile?]
+ >=dev-haskell/transformers-base-0.4.1:=[profile?]
+ <dev-haskell/transformers-base-0.5:=[profile?]
+ >=dev-haskell/void-0.5.5:=[profile?]
+ >=dev-lang/ghc-7.0.1:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/doctest-0.8
+ >=dev-haskell/hspec-1.3
+ dev-haskell/quickcheck
+ )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.0.7-doctest.patch
+}
diff --git a/dev-haskell/conduit/files/conduit-1.0.7-doctest.patch b/dev-haskell/conduit/files/conduit-1.0.7-doctest.patch
new file mode 100644
index 000000000000..34bbd837e826
--- /dev/null
+++ b/dev-haskell/conduit/files/conduit-1.0.7-doctest.patch
@@ -0,0 +1,10 @@
+diff --git a/test/doctests.hs b/test/doctests.hs
+index 3862bd3..943da13 100644
+--- a/test/doctests.hs
++++ b/test/doctests.hs
+@@ -3,4 +3,4 @@ module Main where
+ import Test.DocTest
+
+ main :: IO ()
+-main = doctest ["Data/Conduit.hs"]
++main = doctest $ ["Data/Conduit.hs", "-hide-all-packages"] ++ (map ("-package "++) ["base","resourcet","lifted-base","transformers-base","monad-control","containers","transformers","mtl","bytestring","text","void","mmorph","directory"])
diff --git a/dev-haskell/conduit/metadata.xml b/dev-haskell/conduit/metadata.xml
new file mode 100644
index 000000000000..ffba81f0dcfe
--- /dev/null
+++ b/dev-haskell/conduit/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Conduits are an approach to the streaming data problem. It is meant as an alternative to enumerators\/iterators, hoping to address the same issues with different trade-offs based on real-world experience with enumerators. For more information, see &lt;http://www.yesodweb.com/blog/2011/12/conduits&gt;.
+ </longdescription>
+</pkgmetadata>