summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-09-01 04:18:08 +0000
committerMike Frysinger <vapier@gentoo.org>2007-09-01 04:18:08 +0000
commit58dfb94d99c7b144bd771f08db6c6b49476025fb (patch)
tree842743def5e398c8914d31256fac9b76041a7c59
parentVersion bump #190858 by Martin von Gagern. (diff)
downloadgentoo-2-58dfb94d99c7b144bd771f08db6c6b49476025fb.tar.gz
gentoo-2-58dfb94d99c7b144bd771f08db6c6b49476025fb.tar.bz2
gentoo-2-58dfb94d99c7b144bd771f08db6c6b49476025fb.zip
Link in libpthread with all binaries for now #190523 by Sergey D.
(Portage version: 2.1.3.7)
-rw-r--r--sys-fs/xfsprogs/ChangeLog6
-rw-r--r--sys-fs/xfsprogs/files/xfsprogs-2.9.3-pthreads.patch69
-rw-r--r--sys-fs/xfsprogs/xfsprogs-2.9.3.ebuild3
3 files changed, 76 insertions, 2 deletions
diff --git a/sys-fs/xfsprogs/ChangeLog b/sys-fs/xfsprogs/ChangeLog
index aaa19079045c..7cdb018320ff 100644
--- a/sys-fs/xfsprogs/ChangeLog
+++ b/sys-fs/xfsprogs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/xfsprogs
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsprogs/ChangeLog,v 1.67 2007/08/29 00:03:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsprogs/ChangeLog,v 1.68 2007/09/01 04:18:08 vapier Exp $
+
+ 01 Sep 2007; Mike Frysinger <vapier@gentoo.org>
+ +files/xfsprogs-2.9.3-pthreads.patch, xfsprogs-2.9.3.ebuild:
+ Link in libpthread with all binaries for now #190523 by Sergey D.
*xfsprogs-2.9.3 (29 Aug 2007)
diff --git a/sys-fs/xfsprogs/files/xfsprogs-2.9.3-pthreads.patch b/sys-fs/xfsprogs/files/xfsprogs-2.9.3-pthreads.patch
new file mode 100644
index 000000000000..75f22c0b73c7
--- /dev/null
+++ b/sys-fs/xfsprogs/files/xfsprogs-2.9.3-pthreads.patch
@@ -0,0 +1,69 @@
+http://bugs.gentoo.org/190523
+http://oss.sgi.com/bugzilla/show_bug.cgi?id=766
+
+--- db/Makefile
++++ db/Makefile
+@@ -16,7 +16,7 @@
+ attrset.h
+ CFILES = $(HFILES:.h=.c)
+ LSRCFILES = xfs_admin.sh xfs_check.sh xfs_ncheck.sh xfs_metadump.sh
+-LLDLIBS = $(LIBXFS) $(LIBXLOG) $(LIBUUID) $(LIBRT)
++LLDLIBS = $(LIBXFS) $(LIBXLOG) $(LIBUUID) $(LIBRT) $(LIBPTHREAD)
+ LTDEPENDENCIES = $(LIBXFS) $(LIBXLOG)
+ LLDFLAGS += -static
+
+--- growfs/Makefile
++++ growfs/Makefile
+@@ -9,7 +9,7 @@
+
+ CFILES = xfs_growfs.c
+
+-LLDLIBS = $(LIBXFS) $(LIBXCMD) $(LIBUUID) $(LIBRT)
++LLDLIBS = $(LIBXFS) $(LIBXCMD) $(LIBUUID) $(LIBRT) $(LIBPTHREAD)
+ LTDEPENDENCIES = $(LIBXFS) $(LIBXCMD)
+ LLDFLAGS = -static
+ LSRCFILES = xfs_info.sh
+--- logprint/Makefile
++++ logprint/Makefile
+@@ -12,7 +12,7 @@
+ log_copy.c log_dump.c log_misc.c \
+ log_print_all.c log_print_trans.c
+
+-LLDLIBS = $(LIBXFS) $(LIBXLOG) $(LIBUUID) $(LIBRT)
++LLDLIBS = $(LIBXFS) $(LIBXLOG) $(LIBUUID) $(LIBRT) $(LIBPTHREAD)
+ LTDEPENDENCIES = $(LIBXFS) $(LIBXLOG)
+ LLDFLAGS = -static
+
+--- mdrestore/Makefile
++++ mdrestore/Makefile
+@@ -8,7 +8,7 @@
+ LTCOMMAND = xfs_mdrestore
+ CFILES = xfs_mdrestore.c
+
+-LLDLIBS = $(LIBXFS) $(LIBRT)
++LLDLIBS = $(LIBXFS) $(LIBRT) $(LIBPTHREAD)
+ LTDEPENDENCIES = $(LIBXFS)
+ LLDFLAGS = -static
+
+--- mkfs/Makefile
++++ mkfs/Makefile
+@@ -11,7 +11,7 @@
+ HFILES = xfs_mkfs.h
+ CFILES = maxtrres.c proto.c xfs_mkfs.c
+
+-LLDLIBS = $(LIBXFS) $(LIBUUID) $(LIBDISK) $(LIBRT)
++LLDLIBS = $(LIBXFS) $(LIBUUID) $(LIBDISK) $(LIBRT) $(LIBPTHREAD)
+ LTDEPENDENCIES = $(LIBXFS) $(LIBDISK)
+ LLDFLAGS = -static
+
+--- quota/Makefile
++++ quota/Makefile
+@@ -14,7 +14,7 @@
+ PCFILES = darwin.c freebsd.c irix.c linux.c
+ LSRCFILES = $(shell echo $(PCFILES) | sed -e "s/$(PKG_PLATFORM).c//g")
+
+-LLDLIBS = $(LIBXCMD)
++LLDLIBS = $(LIBXCMD) $(LIBPTHREAD)
+ LTDEPENDENCIES = $(LIBXCMD)
+ LLDFLAGS = -static
+
diff --git a/sys-fs/xfsprogs/xfsprogs-2.9.3.ebuild b/sys-fs/xfsprogs/xfsprogs-2.9.3.ebuild
index 1c54550f3e23..ff4853071bcf 100644
--- a/sys-fs/xfsprogs/xfsprogs-2.9.3.ebuild
+++ b/sys-fs/xfsprogs/xfsprogs-2.9.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsprogs/xfsprogs-2.9.3.ebuild,v 1.1 2007/08/29 00:03:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsprogs/xfsprogs-2.9.3.ebuild,v 1.2 2007/09/01 04:18:08 vapier Exp $
inherit eutils toolchain-funcs autotools
@@ -23,6 +23,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/${PN}-2.8.18-symlinks.patch #166729
epatch "${FILESDIR}"/${PN}-2.8.21-kern-types.patch #131483
+ epatch "${FILESDIR}"/${PN}-2.9.3-pthreads.patch #190523
sed -i \
-e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
include/builddefs.in \