summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-04-07 01:09:08 +0000
committerMike Frysinger <vapier@gentoo.org>2011-04-07 01:09:08 +0000
commit597dc13388feb1cee967ec2733b88a09e9d3d951 (patch)
tree1578fc00c6103e4af20d0ba2c0bf2708f3aa44ff
parentRe-digest the re-rolled rc2 (#2), drop all patches as they are all upstreamed... (diff)
downloadgentoo-2-597dc13388feb1cee967ec2733b88a09e9d3d951.tar.gz
gentoo-2-597dc13388feb1cee967ec2733b88a09e9d3d951.tar.bz2
gentoo-2-597dc13388feb1cee967ec2733b88a09e9d3d951.zip
Add fallback code for older versions of glibc #361271 by Viktor Robev.
(Portage version: 2.2.0_alpha28/cvs/Linux x86_64)
-rw-r--r--sys-apps/util-linux/ChangeLog6
-rw-r--r--sys-apps/util-linux/files/util-linux-2.19-old-libc.patch41
-rw-r--r--sys-apps/util-linux/util-linux-2.19.ebuild3
3 files changed, 48 insertions, 2 deletions
diff --git a/sys-apps/util-linux/ChangeLog b/sys-apps/util-linux/ChangeLog
index d9f00e5f4845..f2f783077f84 100644
--- a/sys-apps/util-linux/ChangeLog
+++ b/sys-apps/util-linux/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/util-linux
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.333 2011/04/02 14:23:45 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.334 2011/04/07 01:09:08 vapier Exp $
+
+ 07 Apr 2011; Mike Frysinger <vapier@gentoo.org> util-linux-2.19.ebuild,
+ +files/util-linux-2.19-old-libc.patch:
+ Add fallback code for older versions of glibc #361271 by Viktor Robev.
02 Apr 2011; Raúl Porcel <armin76@gentoo.org> util-linux-2.18-r1.ebuild:
ia64/m68k/s390/sh/sparc stable wrt #356941
diff --git a/sys-apps/util-linux/files/util-linux-2.19-old-libc.patch b/sys-apps/util-linux/files/util-linux-2.19-old-libc.patch
new file mode 100644
index 000000000000..2ffff84fc61f
--- /dev/null
+++ b/sys-apps/util-linux/files/util-linux-2.19-old-libc.patch
@@ -0,0 +1,41 @@
+http://bugs.gentoo.org/361271
+
+random upstream patches for building with older versions of glibc
+
+--- a/shlibs/mount/src/context_umount.c
++++ b/shlibs/mount/src/context_umount.c
+@@ -21,6 +21,34 @@
+ #include "strutils.h"
+ #include "mountP.h"
+
++#if defined(MNT_FORCE)
++/* Interesting ... it seems libc knows about MNT_FORCE and presumably
++ about umount2 as well -- need not do anything */
++#else /* MNT_FORCE */
++/* Does the present kernel source know about umount2? */
++# include <linux/unistd.h>
++# ifdef __NR_umount2
++static int umount2(const char *path, int flags);
++_syscall2(int, umount2, const char *, path, int, flags);
++# else /* __NR_umount2 */
++static int
++umount2(const char *path, int flags) {
++ fprintf(stderr, _("umount: compiled without support for -f\n"));
++ errno = ENOSYS;
++ return -1;
++}
++#endif /* __NR_umount2 */
++# if !defined(MNT_FORCE)
++# define MNT_FORCE 1
++#endif
++
++#endif /* MNT_FORCE */
++
++#if !defined(MNT_DETACH)
++#define MNT_DETACH 2
++#endif
++
++
+ static int lookup_umount_fs(struct libmnt_context *cxt)
+ {
+ int rc;
diff --git a/sys-apps/util-linux/util-linux-2.19.ebuild b/sys-apps/util-linux/util-linux-2.19.ebuild
index 630649178847..19cd55bd5d1f 100644
--- a/sys-apps/util-linux/util-linux-2.19.ebuild
+++ b/sys-apps/util-linux/util-linux-2.19.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.19.ebuild,v 1.2 2011/03/12 06:33:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.19.ebuild,v 1.3 2011/04/07 01:09:08 vapier Exp $
EAPI="2"
@@ -45,6 +45,7 @@ src_prepare() {
eautoreconf
fi
use uclibc && sed -i -e s/versionsort/alphasort/g -e s/strverscmp.h/dirent.h/g mount/lomount.c
+ epatch "${FILESDIR}"/${P}-old-libc.patch #361271
elibtoolize
}