summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-01-25 14:17:26 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-01-25 14:17:26 +0000
commit59a55d9663790ac2511039ec4eb992d0ad2b9c75 (patch)
tree43b3f8c3ee6a46eb779e3863d84cf5e9062ee865
parentMask KDE SC 4.3.5 until released. (diff)
downloadgentoo-2-59a55d9663790ac2511039ec4eb992d0ad2b9c75.tar.gz
gentoo-2-59a55d9663790ac2511039ec4eb992d0ad2b9c75.tar.bz2
gentoo-2-59a55d9663790ac2511039ec4eb992d0ad2b9c75.zip
Version bump KDE 4.3.5
(Portage version: 2.2_rc61/cvs/Linux x86_64, RepoMan options: --force)
-rw-r--r--kde-base/akonadi/ChangeLog8
-rw-r--r--kde-base/akonadi/akonadi-4.3.5.ebuild89
2 files changed, 96 insertions, 1 deletions
diff --git a/kde-base/akonadi/ChangeLog b/kde-base/akonadi/ChangeLog
index d0bf483a46c2..253fbff44313 100644
--- a/kde-base/akonadi/ChangeLog
+++ b/kde-base/akonadi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/akonadi
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/akonadi/ChangeLog,v 1.49 2010/01/23 20:10:39 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/akonadi/ChangeLog,v 1.50 2010/01/25 14:17:26 scarabeus Exp $
+
+*akonadi-4.3.5 (25 Jan 2010)
+
+ 25 Jan 2010; Tomáš Chvátal <scarabeus@gentoo.org>
+ +akonadi-4.3.5.ebuild:
+ Version bump
23 Jan 2010; Jonathan Callen <abcd@gentoo.org> akonadi-4.3.4.ebuild:
Keyword ~amd64-linux/~x86-linux
diff --git a/kde-base/akonadi/akonadi-4.3.5.ebuild b/kde-base/akonadi/akonadi-4.3.5.ebuild
new file mode 100644
index 000000000000..accee0587577
--- /dev/null
+++ b/kde-base/akonadi/akonadi-4.3.5.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/akonadi/akonadi-4.3.5.ebuild,v 1.1 2010/01/25 14:17:26 scarabeus Exp $
+
+EAPI="2"
+
+if [[ ${PV} = *9999* ]]; then
+ KMNAME="kdepim"
+ eclass="kde4-meta"
+else
+ KMNAME="kdepim-runtime"
+ eclass="kde4-base"
+fi
+inherit ${eclass}
+
+DESCRIPTION="An extensible cross-desktop storage service for PIM data and meta data"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+# add when libmapi becomes available with an ebuild
+#exchange
+IUSE="debug semantic-desktop"
+
+# add when libmapi becomes available with an ebuild
+#exchange? ( net-libs/libmapi )
+DEPEND="
+ dev-libs/boost
+ dev-libs/libxml2
+ dev-libs/libxslt
+ $(add_kdebase_dep kdelibs 'semantic-desktop?')
+ $(add_kdebase_dep kdepimlibs)
+ x11-misc/shared-mime-info
+"
+RDEPEND="${DEPEND}
+ >=app-office/akonadi-server-1.2.1
+"
+
+# @since 4.3 - blocks kdemaildir - no longer provided (it's in akonadi now)
+add_blocker kdemaildir
+add_blocker kdepim-kresources '<4.2.95'
+
+[[ ${KMNAME} = "kdepim-runtime" ]] && S="${WORKDIR}/${KMNAME}-${PV}"
+
+src_prepare() {
+ local pref="${S}"
+ [[ ${KMNAME} != "kdepim-runtime" ]] && pref="${S}/${PN}"
+ if ! use semantic-desktop; then
+ sed -i -e "s/add_subdirectory( nepomuktag )//"\
+ "${pref}"/resources/CMakeLists.txt\
+ || die "Failed to disable nepomuktag"
+ fi
+
+ ${eclass}_src_prepare
+}
+
+src_configure() {
+ mycmakeargs=(
+ # Set the dbus dirs, otherwise it searches in KDEDIR
+ -DAKONADI_DBUS_INTERFACES_INSTALL_DIR="${EPREFIX}/usr/share/dbus-1/interfaces"
+ -DAKONADI_DBUS_SERVICES_INSTALL_DIR="${EPREFIX}/usr/share/dbus-1/services"
+
+ -DWITH_LibXslt=ON
+ # replace with $(cmake-utils_use_with exchange OpenChange) when libmapi becomes available with an ebuild
+ -DWITH_OpenChange=OFF
+ -DWITH_GNOKII=OFF
+ -DWITH_GLIB2=OFF
+ -DWITH_OpenSync=OFF
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ )
+
+ ${eclass}_src_configure
+}
+
+src_test() {
+ # disable broken tests
+ sed -i -e '/kcalserializertest/ s/^/#DO_NOT_RUN_TEST /' \
+ "${S}"/plugins/tests/CMakeLists.txt || \
+ die "sed to disable kcalserializertest failed."
+ sed -i -e '/kresmigrationtest/ s/^/#DO_NOT_RUN_TEST /' \
+ "${S}"/migration/kres/tests/CMakeLists.txt || \
+ die "sed to disable kresmigrationtest failed."
+
+ ${eclass}_src_test
+}
+
+src_install() {
+ ${eclass}_src_install
+ # colliding files with nepomuk
+ rm -rf "${ED}"/${KDEDIR}/share/apps/nepomuk/ontologies/n{m,c}o.{desktop,trig}
+}