summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2012-09-01 00:11:01 +0000
committerJulian Ospald <hasufell@gentoo.org>2012-09-01 00:11:01 +0000
commit5b0dd758a5318acd95dc58bab284f5a3c4dcd024 (patch)
treed8179a945feaf43573d457b54668d797af36f499
parentfix as-needed (diff)
downloadgentoo-2-5b0dd758a5318acd95dc58bab284f5a3c4dcd024.tar.gz
gentoo-2-5b0dd758a5318acd95dc58bab284f5a3c4dcd024.tar.bz2
gentoo-2-5b0dd758a5318acd95dc58bab284f5a3c4dcd024.zip
fix as-needed
(Portage version: 2.2.0_alpha123/cvs/Linux x86_64)
-rw-r--r--games-board/pokerth/ChangeLog6
-rw-r--r--games-board/pokerth/files/pokerth-0.9.5-underlinking.patch9
-rw-r--r--games-board/pokerth/pokerth-0.9.5.ebuild3
3 files changed, 12 insertions, 6 deletions
diff --git a/games-board/pokerth/ChangeLog b/games-board/pokerth/ChangeLog
index 2e80ddffac5c..a667b35ae812 100644
--- a/games-board/pokerth/ChangeLog
+++ b/games-board/pokerth/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-board/pokerth
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/ChangeLog,v 1.42 2012/08/23 17:06:52 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/ChangeLog,v 1.43 2012/09/01 00:11:01 hasufell Exp $
+
+ 01 Sep 2012; Julian Ospald <hasufell@gentoo.org> pokerth-0.9.5.ebuild,
+ files/pokerth-0.9.5-underlinking.patch:
+ fix as-needed
23 Aug 2012; Michael Sterrett <mr_bones_@gentoo.org> pokerth-0.9.5.ebuild:
fix linking with ld.bfd
diff --git a/games-board/pokerth/files/pokerth-0.9.5-underlinking.patch b/games-board/pokerth/files/pokerth-0.9.5-underlinking.patch
index 3ff9ab2dd685..397fb7d6c1bc 100644
--- a/games-board/pokerth/files/pokerth-0.9.5-underlinking.patch
+++ b/games-board/pokerth/files/pokerth-0.9.5-underlinking.patch
@@ -3,15 +3,18 @@ Date: Thu Aug 16 22:25:12 UTC 2012
Subject: build system
fix compilation for linkers that don't permit underlinking
+reorder linker line to fix issues with as-needed
--- pokerth_server.pro
+++ pokerth_server.pro
-@@ -114,7 +114,7 @@
+@@ -114,8 +114,8 @@
LIBS += -lpokerth_lib \
-lpokerth_db \
-lpokerth_protocol \
- -lcurl \
-+ $$system(pkg-config --libs --static libcurl) \
- -lircclient
+- -lircclient
++ -lircclient \
++ $$system(pkg-config --libs --static libcurl)
win32 {
+ DEFINES += CURL_STATICLIB
diff --git a/games-board/pokerth/pokerth-0.9.5.ebuild b/games-board/pokerth/pokerth-0.9.5.ebuild
index 50d1913bd625..2f2da0888055 100644
--- a/games-board/pokerth/pokerth-0.9.5.ebuild
+++ b/games-board/pokerth/pokerth-0.9.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/pokerth-0.9.5.ebuild,v 1.6 2012/08/23 17:06:52 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/pokerth-0.9.5.ebuild,v 1.7 2012/09/01 00:11:01 hasufell Exp $
EAPI=2
inherit flag-o-matic eutils qt4-r2 games
@@ -65,7 +65,6 @@ src_prepare() {
}
src_configure() {
- append-ldflags $(no-as-needed)
eqmake4
}