summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-03 18:29:44 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-03 18:29:44 +0000
commit5bf6427b4fbfe78b9c72ffd3105198b56dc4b7bd (patch)
tree0aac7e15516408a996a88931f88008a76b232b50
parentAnother version bump to try and finally fix the openssl problems. (diff)
downloadgentoo-2-5bf6427b4fbfe78b9c72ffd3105198b56dc4b7bd.tar.gz
gentoo-2-5bf6427b4fbfe78b9c72ffd3105198b56dc4b7bd.tar.bz2
gentoo-2-5bf6427b4fbfe78b9c72ffd3105198b56dc4b7bd.zip
Update to a recent version, by reverting the change in 0.99.5.0-r1 (fedora patches, selinux useflag, berkdb, dependencies check). Berkeley DB support should be moved out of this ebuild, and disabled here; selinux useflag has to be added back by selinux team; the dependencies check should be outside the scope of this single ebuild.
(Portage version: 2.1.2_pre2-r1)
-rw-r--r--sys-libs/pam/ChangeLog11
-rw-r--r--sys-libs/pam/files/digest-pam-0.99.6.33
-rw-r--r--sys-libs/pam/pam-0.99.6.3.ebuild96
3 files changed, 109 insertions, 1 deletions
diff --git a/sys-libs/pam/ChangeLog b/sys-libs/pam/ChangeLog
index e3e5baef623f..937df37900ea 100644
--- a/sys-libs/pam/ChangeLog
+++ b/sys-libs/pam/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-libs/pam
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/ChangeLog,v 1.117 2006/09/06 00:28:48 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/ChangeLog,v 1.118 2006/10/03 18:29:44 flameeyes Exp $
+
+*pam-0.99.6.3 (03 Oct 2006)
+
+ 03 Oct 2006; Diego Pettenò <flameeyes@gentoo.org> +pam-0.99.6.3.ebuild:
+ Update to a recent version, by reverting the change in 0.99.5.0-r1 (fedora
+ patches, selinux useflag, berkdb, dependencies check). Berkeley DB support
+ should be moved out of this ebuild, and disabled here; selinux useflag has
+ to be added back by selinux team; the dependencies check should be outside
+ the scope of this single ebuild.
06 Sep 2006; Chris PeBenito <pebenito@gentoo.org> pam-0.78-r5.ebuild:
Fix gcc 4.1 compile issue with SELinux patch.
diff --git a/sys-libs/pam/files/digest-pam-0.99.6.3 b/sys-libs/pam/files/digest-pam-0.99.6.3
new file mode 100644
index 000000000000..48bbbcaac6a2
--- /dev/null
+++ b/sys-libs/pam/files/digest-pam-0.99.6.3
@@ -0,0 +1,3 @@
+MD5 4c2830ed55a41e795af6a482009a036c Linux-PAM-0.99.6.3.tar.bz2 863340
+RMD160 9c02478d0b5fe5af72b736a64ede6b09618c98e0 Linux-PAM-0.99.6.3.tar.bz2 863340
+SHA256 8468b0fd062cead62a66a048280d28ed70420eefc55b5c9a3fdb361891f2ccd4 Linux-PAM-0.99.6.3.tar.bz2 863340
diff --git a/sys-libs/pam/pam-0.99.6.3.ebuild b/sys-libs/pam/pam-0.99.6.3.ebuild
new file mode 100644
index 000000000000..776ea16749ae
--- /dev/null
+++ b/sys-libs/pam/pam-0.99.6.3.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/pam-0.99.6.3.ebuild,v 1.1 2006/10/03 18:29:44 flameeyes Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit libtool multilib eutils autotools pam toolchain-funcs
+
+MY_P="Linux-PAM-${PV}"
+
+HOMEPAGE="http://www.kernel.org/pub/linux/libs/pam/"
+DESCRIPTION="Linux-PAM (Pluggable Authentication Modules)"
+
+SRC_URI="http://www.kernel.org/pub/linux/libs/pam/pre/library/${MY_P}.tar.bz2"
+
+LICENSE="PAM"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="nls? ( virtual/libintl )
+ >=sys-libs/cracklib-2.8.3
+ sys-libs/pwdb"
+DEPEND="${RDEPEND}
+ ~app-text/docbook-xml-dtd-4.4
+ nls? ( sys-devel/gettext )"
+
+S="${WORKDIR}/${MY_P}"
+
+RESTRICT="confcache"
+
+PROVIDE="virtual/pam"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ elibtoolize
+}
+
+src_compile() {
+ local myconf
+
+ # don't build documentation as it doesn't seem to really work
+ export SGML2PS=no
+ export SGML2TXT=no
+ export SGML2HTML=no
+ export SGML2LATEX=no
+ export PS2PDF=no
+
+ if use hppa || use elibc_FreeBSD; then
+ myconf="${myconf} --disable-pie"
+ fi
+
+ econf \
+ $(use_enable nls) \
+ --enable-securedir=/$(get_libdir)/security \
+ --enable-isadir=/$(get_libdir)/security \
+ --disable-dependency-tracking \
+ --disable-prelude \
+ --enable-docdir=/usr/share/doc/${PF} \
+ ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ # Need to be suid
+ fperms u+s /sbin/unix_chkpwd
+
+ dodir /$(get_libdir)
+ mv "${D}/usr/$(get_libdir)/libpam.so"* "${D}/$(get_libdir)/"
+ mv "${D}/usr/$(get_libdir)/libpamc.so"* "${D}/$(get_libdir)/"
+ mv "${D}/usr/$(get_libdir)/libpam_misc.so"* "${D}/$(get_libdir)/"
+ gen_usr_ldscript libpam.so libpamc.so libpam_misc.so
+
+ # No, we don't really need .la files for PAM modules.
+ rm -f "${D}/$(get_libdir)/security/"*.la
+
+ dodoc CHANGELOG ChangeLog README AUTHORS Copyright
+
+ for x in "${FILESDIR}/pam.d-0.99/"*; do
+ [[ -f "${x}" ]] && dopamd "${x}"
+ done
+}
+
+pkg_postinst() {
+ ewarn " "
+ ewarn "Pay attention! This ebuild is still highly experimental. Don't use"
+ ewarn "in production environments. We don't guarrantee it's working at all."
+ ewarn "Please also note that RedHat patches are not applied, thus stuff"
+ ewarn "like pam_stack is not present at this time."
+ ewarn " "
+}