summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-10 19:19:33 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-10 19:19:33 +0000
commit5c4bad5514822bfd02eb5789aa6eb723bfc28fde (patch)
tree434013912167ec2f6a8fbeb19ddc62c9b7c331b3
parentUpdate HOMEPAGE. Simplify src_test(). (diff)
downloadgentoo-2-5c4bad5514822bfd02eb5789aa6eb723bfc28fde.tar.gz
gentoo-2-5c4bad5514822bfd02eb5789aa6eb723bfc28fde.tar.bz2
gentoo-2-5c4bad5514822bfd02eb5789aa6eb723bfc28fde.zip
Fix dependencies. Use -fno-strict-aliasing.
(Portage version: HEAD/cvs/Linux x86_64)
-rw-r--r--dev-python/traits/traits-3.4.0.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-python/traits/traits-3.4.0.ebuild b/dev-python/traits/traits-3.4.0.ebuild
index e03229710c58..986939be0ed1 100644
--- a/dev-python/traits/traits-3.4.0.ebuild
+++ b/dev-python/traits/traits-3.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/traits/traits-3.4.0.ebuild,v 1.2 2010/06/10 19:12:51 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/traits/traits-3.4.0.ebuild,v 1.3 2010/06/10 19:19:33 arfrever Exp $
EAPI="3"
PYTHON_DEPEND="2"
@@ -8,7 +8,7 @@ SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="3.*"
DISTUTILS_SRC_TEST="setup.py"
-inherit distutils
+inherit distutils flag-o-matic
MY_PN="Traits"
MY_P="${MY_PN}-${PV}"
@@ -23,7 +23,7 @@ KEYWORDS="~amd64 ~ppc ~x86"
LICENSE="BSD"
RDEPEND=">=dev-python/numpy-1.1
- >=dev-python/enthoughtbase-3.0.3"
+ >=dev-python/enthoughtbase-3.0.5"
DEPEND="dev-python/setuptools
doc? ( dev-python/setupdocs )
test? ( >=dev-python/nose-0.10.3
@@ -41,7 +41,10 @@ src_prepare() {
}
src_compile() {
+ append-flags -fno-strict-aliasing
+
distutils_src_compile
+
if use doc; then
"$(PYTHON -f)" setup.py build_docs --formats=html || die "Generation of documentation failed"
fi