summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-02 14:01:09 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-02 14:01:09 +0000
commit5f3db1b8e19039920a62d644bc685e6e3e4e6b8c (patch)
tree60c909a70540aa665fa72934da8438fd271d3818
parentMarking stable amd64 (diff)
downloadgentoo-2-5f3db1b8e19039920a62d644bc685e6e3e4e6b8c.tar.gz
gentoo-2-5f3db1b8e19039920a62d644bc685e6e3e4e6b8c.tar.bz2
gentoo-2-5f3db1b8e19039920a62d644bc685e6e3e4e6b8c.zip
Version bump to version 1.4.1. No gitweb installed as of yet.
(Portage version: 2.1.1_pre2-r1)
-rw-r--r--dev-util/git/ChangeLog7
-rw-r--r--dev-util/git/files/digest-git-1.4.19
-rw-r--r--dev-util/git/git-1.4.1.ebuild148
3 files changed, 163 insertions, 1 deletions
diff --git a/dev-util/git/ChangeLog b/dev-util/git/ChangeLog
index 5c68af7bae73..7bf197238793 100644
--- a/dev-util/git/ChangeLog
+++ b/dev-util/git/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/git
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.100 2006/06/28 17:37:22 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.101 2006/07/02 14:01:09 flameeyes Exp $
+
+*git-1.4.1 (02 Jul 2006)
+
+ 02 Jul 2006; Diego Pettenò <flameeyes@gentoo.org> +git-1.4.1.ebuild:
+ Version bump to version 1.4.1. No gitweb installed as of yet.
28 Jun 2006; Fabian Groffen <grobian@gentoo.org> git-1.4.0-r1.ebuild:
Marked ~ppc-macos
diff --git a/dev-util/git/files/digest-git-1.4.1 b/dev-util/git/files/digest-git-1.4.1
new file mode 100644
index 000000000000..c3fec4897ca1
--- /dev/null
+++ b/dev-util/git/files/digest-git-1.4.1
@@ -0,0 +1,9 @@
+MD5 e8f5324ed90a7337f3983db1ec95b666 git-1.4.1.tar.bz2 752929
+RMD160 4eb93156ed3c6efec2cd7f1081005491ccf89502 git-1.4.1.tar.bz2 752929
+SHA256 f9adef149a28e1a5b58a585aa68f9bf5d358b519b2c5d854731de8f634bab028 git-1.4.1.tar.bz2 752929
+MD5 5e20d82a55273a622301d59420128471 git-htmldocs-1.4.1.tar.bz2 263145
+RMD160 a4ef9fa7981f7555cd1bb5bf464fc285ccca5391 git-htmldocs-1.4.1.tar.bz2 263145
+SHA256 27877133e66f22e616b37c62aad3fbaa97457d7e9628c48eeec8a10bba6eeaa8 git-htmldocs-1.4.1.tar.bz2 263145
+MD5 ebead05e2dfec6950eb18447f92b5ccd git-manpages-1.4.1.tar.bz2 83968
+RMD160 a0fa8eb80120c1da11638a4700f4685e5bccd41a git-manpages-1.4.1.tar.bz2 83968
+SHA256 a406ac88362ec4c43d5528f09e778b362fbd0e277f887c9043d133d038204ab4 git-manpages-1.4.1.tar.bz2 83968
diff --git a/dev-util/git/git-1.4.1.ebuild b/dev-util/git/git-1.4.1.ebuild
new file mode 100644
index 000000000000..fba42fbcf25a
--- /dev/null
+++ b/dev-util/git/git-1.4.1.ebuild
@@ -0,0 +1,148 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.4.1.ebuild,v 1.1 2006/07/02 14:01:09 flameeyes Exp $
+
+inherit python toolchain-funcs eutils elisp-common
+
+DOC_VER=${PV}
+
+DESCRIPTION="GIT - the stupid content tracker"
+HOMEPAGE="http://kernel.org/pub/software/scm/git/"
+SRC_URI="mirror://kernel/software/scm/git/${P}.tar.bz2
+ mirror://kernel/software/scm/git/${PN}-manpages-${DOC_VER}.tar.bz2
+ doc? ( mirror://kernel/software/scm/git/${PN}-htmldocs-${DOC_VER}.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc-macos ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="curl doc emacs gtk mozsha1 ppcsha1 webdav X"
+
+DEPEND="dev-libs/openssl
+ sys-libs/zlib
+ !app-misc/git
+ curl? ( net-misc/curl )
+ webdav? ( dev-libs/expat )"
+RDEPEND="${DEPEND}
+ dev-lang/perl
+ >=dev-lang/python-2.3
+ app-text/rcs
+ X? ( dev-lang/tk )
+ gtk? ( >=dev-python/pygtk-2.6 )"
+
+# This is needed because for some obscure reasons future calls to make don't
+# pick up these exports if we export them in src_unpack()
+exportmakeopts() {
+ local myopts
+
+ if use mozsha1 ; then
+ myopts="${myopts} MOZILLA_SHA1=YesPlease"
+ elif use ppcsha1 ; then
+ myopts="${myopts} PPC_SHA1=YesPlease"
+ fi
+
+ if use curl ; then
+ use webdav || myopts="${myopts} NO_EXPAT=YesPlease"
+ else
+ myopts="${myopts} NO_CURL=YesPlease"
+ use webdav && ewarn "USE=webdav only matters with USE=curl. Ignoring."
+ fi
+
+ myopts="${myopts} WITH_SEND_EMAIL=YesPlease"
+
+ # Older python versions need own subproccess.py
+ python_version
+ [[ ${PYVER} < 2.4 ]] && myopts="${myopts} WITH_OWN_SUBPROCESS_PY=YesPlease"
+
+ use elibc_uclibc && myopts="${myopts} NO_ICONV=YesPlease"
+
+ export MY_MAKEOPTS=${myopts}
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i \
+ -e "s:^\(CFLAGS = \).*$:\1${CFLAGS} -Wall:" \
+ -e "s:^\(LDFLAGS = \).*$:\1${LDFLAGS}:" \
+ -e "s:^\(CC = \).*$:\1$(tc-getCC):" \
+ -e "s:^\(AR = \).*$:\1$(tc-getAR):" \
+ Makefile || die "sed failed"
+
+ exportmakeopts
+}
+
+src_compile() {
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr || die "make failed"
+ emake -C contrib/git-svn/ git-svn || die "make git-svn failed"
+
+ if use emacs ; then
+ elisp-compile contrib/emacs/{,vc-}git.el || die "emacs modules failed"
+ fi
+}
+
+src_install() {
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr install || die "make install failed"
+
+ use X || rm "${D}"/usr/bin/gitk
+
+ doman "${WORKDIR}"/man?/*
+
+ dodoc README COPYING Documentation/SubmittingPatches
+ if use doc ; then
+ dodoc Documentation/technical/*
+ dodir /usr/share/doc/${PF}/html
+ cp -r "${WORKDIR}"/{*.html,howto} "${D}"/usr/share/doc/${PF}/html
+ fi
+
+ if use emacs ; then
+ insinto "${SITELISP}"
+ doins contrib/emacs/{,vc-}git.el*
+ elisp-site-file-install "${FILESDIR}"/70git-gentoo.el
+ fi
+
+ if use gtk ; then
+ dobin contrib/gitview/gitview
+ use doc && dodoc contrib/gitview/gitview.txt
+ fi
+
+ dobin contrib/git-svn/git-svn
+ dodoc contrib/git-svn/git-svn.txt
+
+ newinitd "${FILESDIR}"/git-daemon.initd git-daemon
+ newconfd "${FILESDIR}"/git-daemon.confd git-daemon
+}
+
+src_test() {
+ cd "${S}"
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr test || die "tests failed"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ einfo
+ einfo "If you want to import arch repositories into git, consider using the"
+ einfo "git-archimport command. You should install dev-util/tla before"
+ einfo
+ einfo "If you want to import cvs repositories into git, consider using the"
+ einfo "git-cvsimport command. You should install >=dev-util/cvsps-2.1 before"
+ einfo
+ einfo "If you want to import svn repositories into git, consider using the"
+ einfo "git-svnimport command. You should install dev-util/subversion before"
+ einfo
+ einfo "If you want to manage subversion repositories using git, consider"
+ einfo "using git-svn. You should install dev-util/subversion before"
+ einfo
+ einfo "If you want to import a quilt series into git, donsider using the"
+ einfo "git-quiltimport command. You should install dev-util/quilt before"
+ einfo
+ einfo "If you want to use the included CVS server you will need to install"
+ einfo "dev-perl/DBI and dev-perl/DBD-SQLite"
+ einfo
+}
+
+pkg_postrm() {
+ # regenerate site-gentoo if we are merged USE=emacs and unmerged
+ # USE=-emacs
+ has_version virtual/emacs && elisp-site-regen
+}