summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRainer Groesslinger <scandium@gentoo.org>2004-07-31 12:37:21 +0000
committerRainer Groesslinger <scandium@gentoo.org>2004-07-31 12:37:21 +0000
commit6362d043fb9e3b61ce7008fbf47089ce61ea19ee (patch)
treedd69d9e8eaab037783042291a493e65ab2d9ee0f
parentAnother revision bump for an updated tab completion patch. This should close ... (diff)
downloadgentoo-2-6362d043fb9e3b61ce7008fbf47089ce61ea19ee.tar.gz
gentoo-2-6362d043fb9e3b61ce7008fbf47089ce61ea19ee.tar.bz2
gentoo-2-6362d043fb9e3b61ce7008fbf47089ce61ea19ee.zip
stable on x86 and ppc
-rw-r--r--dev-lang/pike/ChangeLog5
-rw-r--r--dev-lang/pike/files/digest-pike-7.4.28-r21
-rw-r--r--dev-lang/pike/pike-7.4.28-r2.ebuild98
-rw-r--r--dev-lang/pike/pike-7.6.6.ebuild11
4 files changed, 8 insertions, 107 deletions
diff --git a/dev-lang/pike/ChangeLog b/dev-lang/pike/ChangeLog
index 80c6cd4341a8..370675f4592b 100644
--- a/dev-lang/pike/ChangeLog
+++ b/dev-lang/pike/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/pike
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/pike/ChangeLog,v 1.10 2004/06/24 22:54:03 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/pike/ChangeLog,v 1.11 2004/07/31 12:37:21 scandium Exp $
+
+ 31 Jul 2004; Rainer Groesslinger <scandium@gentoo.org> pike-7.6.6.ebuild:
+ stable on x86 and ppc
*pike-7.6.6 (20 Jun 2004)
diff --git a/dev-lang/pike/files/digest-pike-7.4.28-r2 b/dev-lang/pike/files/digest-pike-7.4.28-r2
deleted file mode 100644
index f5426a8ea50a..000000000000
--- a/dev-lang/pike/files/digest-pike-7.4.28-r2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 98a7944cea94c7255a24f2cba7d15ec1 Pike-v7.4.28.tar.gz 6712605
diff --git a/dev-lang/pike/pike-7.4.28-r2.ebuild b/dev-lang/pike/pike-7.4.28-r2.ebuild
deleted file mode 100644
index c6babd1a2279..000000000000
--- a/dev-lang/pike/pike-7.4.28-r2.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation, Emil Skoldberg, Fredrik Mellstrom (see ChangeLog)
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/pike/pike-7.4.28-r2.ebuild,v 1.5 2004/06/26 14:52:48 scandium Exp $
-
-inherit flag-o-matic fixheadtails
-
-# -fomit-frame-pointer breaks the compilation
-filter-flags -fomit-frame-pointer
-
-IUSE="debug doc gdbm gif java jpeg mysql oci8 odbc opengl pdflib postgres scanner sdl tiff truetype zlib"
-
-S="${WORKDIR}/Pike-v${PV}"
-HOMEPAGE="http://pike.ida.liu.se/"
-DESCRIPTION="Pike programming language and runtime"
-SRC_URI="ftp://pike.ida.liu.se/pub/pike/all/${PV}/Pike-v${PV}.tar.gz"
-
-LICENSE="GPL-2 LGPL-2.1 MPL-1.1"
-SLOT="0"
-KEYWORDS="x86 ppc"
-
-DEPEND="dev-libs/gmp
- zlib? ( sys-libs/zlib )
- pdflib? ( media-libs/pdflib )
- gdbm? ( sys-libs/gdbm )
- java? ( virtual/jdk )
- scanner? ( media-gfx/sane-backends )
- mysql? ( dev-db/mysql )
- postgres? ( dev-db/postgresql )
- gif? ( media-libs/giflib )
- truetype? ( media-libs/freetype )
- jpeg? ( media-libs/jpeg )
- tiff? ( media-libs/tiff )
- opengl? ( virtual/opengl
- virtual/glut )
- sdl? ( media-libs/libsdl )"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- # ht_fix_all kills autoheader stuff, so we use ht_fix_file
- find . -iname "*.sh" -or -iname "*.sh.in" -or -iname "Makefile*" | \
- while read i; do
- ht_fix_file $i
- done
-}
-
-src_compile() {
-
- einfo 'Gtk+ and Gnome support is disabled for now!'
- einfo 'Gtk+-2 did not work with pike and'
- einfo 'Gtk+-1 just caused too many problems'
- sleep 5
-
- local myconf
- use zlib || myconf="${myconf} --without-zlib"
- use mysql || myconf="${myconf} --without-mysql"
- use debug || myconf="${myconf} --without-debug"
- use gdbm || myconf="${myconf} --without-gdbm"
- use pdflib || myconf="${myconf} --without-libpdf"
- use java || myconf="${myconf} --without-java"
- use odbc || myconf="${myconf} --without-odbc"
- use scanner || myconf="${myconf} --without-sane"
- use postgres || myconf="${myconf} --without-postgres"
- use oci8 || myconf="${myconf} --without-oracle"
- use gif || myconf="${myconf} --without-gif"
- use truetype || myconf="${myconf} --without-ttflib --without-freetype"
- use jpeg || myconf="${myconf} --without-jpeglib"
- use tiff || myconf="${myconf} --without-tifflib"
- use opengl || myconf="${myconf} --without-GL --without-GLUT"
-
- # We have to use --disable-make_conf to override make.conf settings
- # Otherwise it may set -fomit-frame-pointer again
- # disable ffmpeg support because it does not compile
- # disable dvb support because it does not compile
- emake CONFIGUREARGS="${myconf} --prefix=/usr --disable-make_conf --without-ffmpeg \
- --without-GTK --without-GTK2 --without-gnome --without-dvb" || die
-
- # only build documentation if 'doc' is in USE
- if use doc; then
- PATH="${S}/bin:${PATH}" make doc || die
- fi
-}
-
-src_install() {
- # the installer should be stopped from removing files, to prevent sandbox issues
- sed -i s/rm\(mod\+\"\.o\"\)\;/\{\}/ ${S}/bin/install.pike || die "Failed to modify install.pike"
-
- make INSTALLARGS="--traditional" buildroot="${D}" install || die
-
- # We remove all .o files to prevent decode errors, bug #32973
- rm -vf `find ${D} -regex '.*\.o' -type f | xargs`
-
- if use doc; then
- einfo "Installing 60MB of docs, this could take some time ..."
- dohtml -r ${S}/refdoc/traditional_manual ${S}/refdoc/modref
- fi
-}
diff --git a/dev-lang/pike/pike-7.6.6.ebuild b/dev-lang/pike/pike-7.6.6.ebuild
index 062236980632..7f6ee05df3b6 100644
--- a/dev-lang/pike/pike-7.6.6.ebuild
+++ b/dev-lang/pike/pike-7.6.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/pike/pike-7.6.6.ebuild,v 1.4 2004/07/12 16:29:57 scandium Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/pike/pike-7.6.6.ebuild,v 1.5 2004/07/31 12:37:21 scandium Exp $
# Contributions by Emil Skoldberg, Fredrik Mellstrom (see ChangeLog)
inherit fixheadtails
@@ -14,7 +14,7 @@ SRC_URI="ftp://pike.ida.liu.se/pub/pike/all/${PV}/Pike-v${PV}.tar.gz"
LICENSE="GPL-2 LGPL-2.1 MPL-1.1"
SLOT="0"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="x86 ppc"
DEPEND="zlib? ( sys-libs/zlib )
pdflib? ( media-libs/pdflib )
@@ -81,12 +81,9 @@ src_install() {
if use doc; then
make INSTALLARGS="--traditional" buildroot="${D}" install || die
- else
- make INSTALLARGS="--traditional" buildroot="${D}" install_nodoc || die
- fi
-
- if use doc; then
einfo "Installing 60MB of docs, this could take some time ..."
dohtml -r ${S}/refdoc/traditional_manual ${S}/refdoc/modref
+ else
+ make INSTALLARGS="--traditional" buildroot="${D}" install_nodoc || die
fi
}