summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-04-04 00:08:56 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-04-04 00:08:56 +0000
commit6547996ffa23b75b5a760df44435d79950013a21 (patch)
tree4d0214aeaa788aef65ba2b728b9fd8d37d49503a
parent- quick fix for non multilib systems (diff)
downloadgentoo-2-6547996ffa23b75b5a760df44435d79950013a21.tar.gz
gentoo-2-6547996ffa23b75b5a760df44435d79950013a21.tar.bz2
gentoo-2-6547996ffa23b75b5a760df44435d79950013a21.zip
add gcc-3.4 fixup (bug #87644)
(Portage version: 2.0.51.19)
-rw-r--r--games-puzzle/construo/ChangeLog8
-rw-r--r--games-puzzle/construo/construo-0.2.2.ebuild15
2 files changed, 18 insertions, 5 deletions
diff --git a/games-puzzle/construo/ChangeLog b/games-puzzle/construo/ChangeLog
index 05dea7039ce4..339c1cd83abd 100644
--- a/games-puzzle/construo/ChangeLog
+++ b/games-puzzle/construo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/construo
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/construo/ChangeLog,v 1.4 2004/06/24 23:03:09 agriffis Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/construo/ChangeLog,v 1.5 2005/04/04 00:08:56 mr_bones_ Exp $
+
+ 04 Apr 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ construo-0.2.2.ebuild:
+ add gcc-3.4 fixup (bug #87644)
27 May 2004; Danny van Dyk <kugelfang@gentoo.org> construo-0.2.2.ebuild:
Marked ~amd64.
diff --git a/games-puzzle/construo/construo-0.2.2.ebuild b/games-puzzle/construo/construo-0.2.2.ebuild
index 54e68366fa92..eda9405bd309 100644
--- a/games-puzzle/construo/construo-0.2.2.ebuild
+++ b/games-puzzle/construo/construo-0.2.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/construo/construo-0.2.2.ebuild,v 1.5 2004/06/24 23:03:09 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/construo/construo-0.2.2.ebuild,v 1.6 2005/04/04 00:08:56 mr_bones_ Exp $
inherit games
@@ -10,13 +10,22 @@ SRC_URI="http://freesoftware.fsf.org/download/construo/construo.pkg/${PV}/${P}.t
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ~amd64"
+KEYWORDS="~amd64 x86"
IUSE=""
DEPEND="virtual/x11
sys-libs/zlib
virtual/glut"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e 's:<math.h>:<cmath>:g' vector.cxx \
+ || die "sed failed"
+
+}
+
src_compile() {
egamesconf --datadir="${GAMES_DATADIR_BASE}" || die
emake || die "emake failed"