summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-10-14 08:34:43 +0000
committerUlrich Müller <ulm@gentoo.org>2007-10-14 08:34:43 +0000
commit699a4b35c3261142c0575cceeba15ce61f8db34d (patch)
tree47c0e58df3cfbe815f3bd6a070508fa543b3f3c9
parentinitial import (diff)
downloadgentoo-2-699a4b35c3261142c0575cceeba15ce61f8db34d.tar.gz
gentoo-2-699a4b35c3261142c0575cceeba15ce61f8db34d.tar.bz2
gentoo-2-699a4b35c3261142c0575cceeba15ce61f8db34d.zip
Change USE flag "nosendmail" to "sendmail".
(Portage version: 2.1.3.12)
-rw-r--r--app-editors/emacs/ChangeLog6
-rw-r--r--app-editors/emacs/emacs-21.4-r12.ebuild22
-rw-r--r--app-editors/emacs/emacs-21.4-r4.ebuild8
-rw-r--r--app-editors/emacs/emacs-21.4-r8.ebuild12
4 files changed, 25 insertions, 23 deletions
diff --git a/app-editors/emacs/ChangeLog b/app-editors/emacs/ChangeLog
index 31cf98c38494..5e99be8f1bae 100644
--- a/app-editors/emacs/ChangeLog
+++ b/app-editors/emacs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/emacs
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.186 2007/10/10 06:22:17 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.187 2007/10/14 08:34:43 ulm Exp $
+
+ 14 Oct 2007; Ulrich Mueller <ulm@gentoo.org> emacs-21.4-r4.ebuild,
+ emacs-21.4-r8.ebuild, emacs-21.4-r12.ebuild:
+ Change USE flag "nosendmail" to "sendmail". Update postinst messages.
10 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
emacs-18.59-r4.ebuild, emacs-21.4-r4.ebuild, emacs-21.4-r8.ebuild,
diff --git a/app-editors/emacs/emacs-21.4-r12.ebuild b/app-editors/emacs/emacs-21.4-r12.ebuild
index 5cda3ebded90..04683cbbe9f9 100644
--- a/app-editors/emacs/emacs-21.4-r12.ebuild
+++ b/app-editors/emacs/emacs-21.4-r12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.4-r12.ebuild,v 1.32 2007/10/10 06:22:17 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.4-r12.ebuild,v 1.33 2007/10/14 08:34:43 ulm Exp $
WANT_AUTOCONF="2.1"
@@ -15,7 +15,7 @@ SRC_URI="mirror://gnu/emacs/${P}a.tar.gz
LICENSE="GPL-2 FDL-1.1 BSD"
SLOT="21"
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="X Xaw3d leim lesstif motif nls nosendmail"
+IUSE="X Xaw3d leim lesstif motif nls sendmail"
RDEPEND="sys-libs/ncurses
X? (
@@ -35,7 +35,7 @@ RDEPEND="sys-libs/ncurses
!lesstif? ( >=x11-libs/openmotif-2.1.30 )
)
)
- !nosendmail? ( virtual/mta )
+ sendmail? ( virtual/mta )
>=app-admin/eselect-emacs-0.7-r1"
DEPEND="${RDEPEND}
@@ -191,18 +191,16 @@ pkg_postinst() {
eselect emacs update --if-unset
fi
- if use nosendmail; then
- elog "You disabled sendmail support for Emacs. If you later install a MTA"
- elog "then you will need to recompile Emacs. See Bug #11104."
+ if ! use sendmail && ! has_version "virtual/mta"; then
+ elog "You disabled sendmail support for Emacs. If you later install"
+ elog "a MTA then you will need to recompile Emacs. See Bug #11104."
fi
if use X; then
elog "You need to install some fonts for Emacs. Under monolithic"
- elog "XFree86/Xorg you typically had such fonts installed by default. With"
- elog "modular Xorg, you will have to perform this step yourself on the machine"
- elog "your X server is running."
- echo
- elog "Installing media-fonts/font-adobe-{75,100}dpi would satisfy basic"
- elog "Emacs requirements under X11."
+ elog "XFree86/Xorg you typically had such fonts installed by default."
+ elog "With modular Xorg, you will have to perform this step yourself."
+ elog "Installing media-fonts/font-adobe-{75,100}dpi on the X server's"
+ elog "machine would satisfy basic Emacs requirements under X11."
fi
}
diff --git a/app-editors/emacs/emacs-21.4-r4.ebuild b/app-editors/emacs/emacs-21.4-r4.ebuild
index 2811554c7cbe..7a3cf296d7ad 100644
--- a/app-editors/emacs/emacs-21.4-r4.ebuild
+++ b/app-editors/emacs/emacs-21.4-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.4-r4.ebuild,v 1.19 2007/10/10 06:22:17 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.4-r4.ebuild,v 1.20 2007/10/14 08:34:43 ulm Exp $
inherit flag-o-matic eutils alternatives toolchain-funcs
@@ -14,7 +14,7 @@ SRC_URI="mirror://gnu/emacs/${P}a.tar.gz
LICENSE="GPL-2 BSD"
SLOT="21"
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="X Xaw3d leim lesstif motif nls nosendmail"
+IUSE="X Xaw3d leim lesstif motif nls sendmail"
RDEPEND="sys-libs/ncurses
X? ( x11-libs/libXext
@@ -37,7 +37,7 @@ RDEPEND="sys-libs/ncurses
)
)
nls? ( sys-devel/gettext )
- !nosendmail? ( virtual/mta )"
+ sendmail? ( virtual/mta )"
DEPEND="${RDEPEND}
>=sys-devel/autoconf-2.58
@@ -164,7 +164,7 @@ update-alternatives() {
pkg_postinst() {
update-alternatives
elisp-site-regen
- if use nosendmail ; then
+ if ! use sendmail ; then
ewarn
ewarn "You disabled sendmail support for Emacs. If you will install any MTA"
ewarn "you need to recompile Emacs after that. See bug #11104."
diff --git a/app-editors/emacs/emacs-21.4-r8.ebuild b/app-editors/emacs/emacs-21.4-r8.ebuild
index 31832e3112f0..dd30ff9f3eb3 100644
--- a/app-editors/emacs/emacs-21.4-r8.ebuild
+++ b/app-editors/emacs/emacs-21.4-r8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.4-r8.ebuild,v 1.7 2007/10/10 06:22:17 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.4-r8.ebuild,v 1.8 2007/10/14 08:34:43 ulm Exp $
inherit flag-o-matic eutils alternatives toolchain-funcs
@@ -14,7 +14,7 @@ SRC_URI="mirror://gnu/emacs/${P}a.tar.gz
LICENSE="GPL-2 BSD"
SLOT="21"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="X Xaw3d leim lesstif motif nls nosendmail"
+IUSE="X Xaw3d leim lesstif motif nls sendmail"
RDEPEND="sys-libs/ncurses
X? ( x11-libs/libXext
@@ -37,7 +37,7 @@ RDEPEND="sys-libs/ncurses
)
)
nls? ( sys-devel/gettext )
- !nosendmail? ( virtual/mta )"
+ sendmail? ( virtual/mta )"
DEPEND="${RDEPEND}
>=sys-devel/autoconf-2.58
@@ -179,12 +179,12 @@ update-alternatives() {
}
pkg_postinst() {
- test -f ${ROOT}/usr/share/emacs/site-lisp/subdirs.el ||
- cp ${ROOT}/usr/share/emacs{/${PV},}/site-lisp/subdirs.el
+ test -f "${ROOT}"/usr/share/emacs/site-lisp/subdirs.el ||
+ cp "${ROOT}"/usr/share/emacs{/${PV},}/site-lisp/subdirs.el
update-alternatives
- if use nosendmail; then
+ if ! use sendmail; then
while read line; do einfo "${line}"; done<<'EOF'
You disabled sendmail support for Emacs. If you later install a MTA