summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-03-29 01:18:31 +0000
committerMike Frysinger <vapier@gentoo.org>2004-03-29 01:18:31 +0000
commit6a4700566bf246d73907888c916864c95cf8babf (patch)
treee697ac50a7436f92f7a03d418aee93bbd920ee74
parentold (diff)
downloadgentoo-2-6a4700566bf246d73907888c916864c95cf8babf.tar.gz
gentoo-2-6a4700566bf246d73907888c916864c95cf8babf.tar.bz2
gentoo-2-6a4700566bf246d73907888c916864c95cf8babf.zip
move from net-ftp #45968
-rw-r--r--net-mail/gotmail/gotmail-0.8.0_beta1.ebuild19
-rw-r--r--net-mail/gotmail/gotmail-0.8.1.ebuild22
-rw-r--r--net-misc/drivel/drivel-0.9.1.ebuild11
-rw-r--r--net-misc/drivel/drivel-0.9.3.ebuild9
-rw-r--r--net-misc/icecast/icecast-2.0.0.ebuild17
-rw-r--r--net-misc/logjam/logjam-4.2.2.ebuild15
-rw-r--r--net-misc/logjam/logjam-4.3.2.ebuild15
7 files changed, 51 insertions, 57 deletions
diff --git a/net-mail/gotmail/gotmail-0.8.0_beta1.ebuild b/net-mail/gotmail/gotmail-0.8.0_beta1.ebuild
index 1a07d98bbcb8..53367364b996 100644
--- a/net-mail/gotmail/gotmail-0.8.0_beta1.ebuild
+++ b/net-mail/gotmail/gotmail-0.8.0_beta1.ebuild
@@ -1,20 +1,23 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/gotmail/gotmail-0.8.0_beta1.ebuild,v 1.2 2004/03/24 23:20:22 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/gotmail/gotmail-0.8.0_beta1.ebuild,v 1.3 2004/03/29 01:13:59 vapier Exp $
PVPREV=0.7.10
S=${WORKDIR}/${PN}-${PVPREV}
DESCRIPTION="Utility to download mail from a HotMail account"
-SRC_URI="http://savannah.nongnu.org/download/${PN}/stable.pkg/${PV}/${PN}_${PVPREV}.tar.gz
- mirror://gentoo/${P}.tar.gz"
HOMEPAGE="http://www.nongnu.org/gotmail/"
+SRC_URI="http://savannah.nongnu.org/download/${PN}/stable.pkg/${PV}/${PN}_${PVPREV}.tar.gz
+ mirror://gentoo/${P}.tar.gz"
-DEPEND="virtual/glibc net-ftp/curl dev-perl/URI dev-perl/libnet"
-
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 ~sparc"
+DEPEND="virtual/glibc
+ net-misc/curl
+ dev-perl/URI
+ dev-perl/libnet"
+
src_unpack() {
unpack ${A}
cp ${WORKDIR}/${PN} ${S}
@@ -23,7 +26,7 @@ src_unpack() {
src_compile() { :; }
src_install () {
- dobin gotmail
- dodoc COPYING ChangeLog README sample.gotmailrc
+ dobin gotmail || die
+ dodoc ChangeLog README sample.gotmailrc
doman gotmail.1
}
diff --git a/net-mail/gotmail/gotmail-0.8.1.ebuild b/net-mail/gotmail/gotmail-0.8.1.ebuild
index 87e126f4280e..01264ddef2a2 100644
--- a/net-mail/gotmail/gotmail-0.8.1.ebuild
+++ b/net-mail/gotmail/gotmail-0.8.1.ebuild
@@ -1,24 +1,26 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/gotmail/gotmail-0.8.1.ebuild,v 1.5 2004/03/24 23:20:22 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/gotmail/gotmail-0.8.1.ebuild,v 1.6 2004/03/29 01:13:59 vapier Exp $
DESCRIPTION="Utility to download mail from a HotMail account"
-SRC_URI="mirror://sourceforge/gotmail/${P}.tar.gz"
-RESTRICT="nomirror"
HOMEPAGE="http://www.nongnu.org/gotmail/"
+SRC_URI="mirror://sourceforge/gotmail/${P}.tar.gz"
-DEPEND="virtual/glibc net-ftp/curl dev-perl/URI dev-perl/libnet"
-
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86 sparc amd64 ~ppc"
+SLOT="0"
+KEYWORDS="x86 ppc sparc amd64"
+
+DEPEND="virtual/glibc
+ net-misc/curl
+ dev-perl/URI
+ dev-perl/libnet"
src_compile () {
echo "nothing to compile"
}
-src_install () {
- dobin gotmail
- dodoc COPYING ChangeLog README sample.gotmailrc
+src_install() {
+ dobin gotmail || die
+ dodoc ChangeLog README sample.gotmailrc
doman gotmail.1
}
diff --git a/net-misc/drivel/drivel-0.9.1.ebuild b/net-misc/drivel/drivel-0.9.1.ebuild
index 7158f667e828..ecbf225010fa 100644
--- a/net-misc/drivel/drivel-0.9.1.ebuild
+++ b/net-misc/drivel/drivel-0.9.1.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/drivel/drivel-0.9.1.ebuild,v 1.4 2003/09/05 22:13:37 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/drivel/drivel-0.9.1.ebuild,v 1.5 2004/03/29 01:16:18 vapier Exp $
inherit gnome2
-IUSE=""
DESCRIPTION="Drivel is a LiveJournal client for the GNOME desktop."
HOMEPAGE="http://sourceforge.net/project/drivel/"
SRC_URI="mirror://sourceforge/drivel/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ~ppc"
@@ -15,9 +15,8 @@ KEYWORDS="x86 ~ppc"
RDEPEND=">=x11-libs/gtk+-2.0.0
>=gnome-base/libgnomeui-2.0.3
>=gnome-base/gconf-1.2.1
- >=net-ftp/curl-7.10"
-
+ >=net-misc/curl-7.10"
DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.12.0"
-DOCS="AUTHORS COPYING ChangeLog INSTALL NEWS README"
+DOCS="AUTHORS ChangeLog INSTALL NEWS README"
diff --git a/net-misc/drivel/drivel-0.9.3.ebuild b/net-misc/drivel/drivel-0.9.3.ebuild
index 3d9fe10c1fa8..14755def8b33 100644
--- a/net-misc/drivel/drivel-0.9.3.ebuild
+++ b/net-misc/drivel/drivel-0.9.3.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/drivel/drivel-0.9.3.ebuild,v 1.1 2004/01/25 20:50:08 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/drivel/drivel-0.9.3.ebuild,v 1.2 2004/03/29 01:16:18 vapier Exp $
inherit gnome2
-IUSE=""
DESCRIPTION="Drivel is a LiveJournal client for the GNOME desktop."
HOMEPAGE="http://sourceforge.net/project/drivel/"
SRC_URI="mirror://sourceforge/drivel/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc"
@@ -15,13 +15,12 @@ KEYWORDS="~x86 ~ppc"
RDEPEND=">=x11-libs/gtk+-2.0.0
>=gnome-base/libgnomeui-2.0.3
>=gnome-base/gconf-1.2.1
- >=net-ftp/curl-7.10"
-
+ >=net-misc/curl-7.10"
DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.12.0
dev-util/intltool"
-DOCS="AUTHORS COPYING ChangeLog INSTALL NEWS README"
+DOCS="AUTHORS ChangeLog INSTALL NEWS README"
src_unpack() {
unpack ${A}
diff --git a/net-misc/icecast/icecast-2.0.0.ebuild b/net-misc/icecast/icecast-2.0.0.ebuild
index fe4b6364bd8d..ad4fbd57c325 100644
--- a/net-misc/icecast/icecast-2.0.0.ebuild
+++ b/net-misc/icecast/icecast-2.0.0.ebuild
@@ -1,8 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/icecast/icecast-2.0.0.ebuild,v 1.4 2004/03/26 21:44:44 eradicator Exp $
-
-IUSE="oggvorbis curl"
+# $Header: /var/cvsroot/gentoo-x86/net-misc/icecast/icecast-2.0.0.ebuild,v 1.5 2004/03/29 01:17:08 vapier Exp $
inherit eutils
@@ -10,24 +8,22 @@ DESCRIPTION="An opensource alternative to shoutcast that supports mp3 and ogg st
HOMEPAGE="http://www.icecast.org/"
SRC_URI="http://www.icecast.org/files/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 ~ppc ~sparc ~alpha ~amd64"
+IUSE="oggvorbis curl"
DEPEND="virtual/glibc
dev-libs/libxml2
dev-libs/libxslt
oggvorbis? ( >=media-libs/libvorbis-1.0
>=media-libs/libogg-1.0 )
- curl? ( net-ftp/curl )"
+ curl? ( net-misc/curl )"
src_compile() {
- local myconf="--with-gnu-ld"
-
+ local myconf=""
use oggvorbis || myconf="${myconf} --without-ogg --without-vorbis"
-
use curl || myconf="${myconf} --disable-yp"
-
econf \
--sysconfdir=/etc/icecast2 \
${myconf} || die "configure failed"
@@ -36,10 +32,7 @@ src_compile() {
}
src_install() {
- export CONFIG_PROTECT="${CONFIG_PROTECT}:/etc/icecast2"
make DESTDIR=${D} install || die "make install failed"
-
dodoc AUTHORS README TODO HACKING NEWS
-
rm -rf ${D}usr/share/doc/icecast
}
diff --git a/net-misc/logjam/logjam-4.2.2.ebuild b/net-misc/logjam/logjam-4.2.2.ebuild
index 927fd80b44d7..be0a3a7e6a78 100644
--- a/net-misc/logjam/logjam-4.2.2.ebuild
+++ b/net-misc/logjam/logjam-4.2.2.ebuild
@@ -1,25 +1,24 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/logjam/logjam-4.2.2.ebuild,v 1.5 2004/03/20 00:49:36 weeve Exp $
-
-IUSE="xmms spell gtkhtml"
+# $Header: /var/cvsroot/gentoo-x86/net-misc/logjam/logjam-4.2.2.ebuild,v 1.6 2004/03/29 01:18:31 vapier Exp $
DESCRIPTION="GTK2-based LiveJournal client"
HOMEPAGE="http://logjam.danga.com/"
SRC_URI="http://logjam.danga.com/download/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 ~ppc sparc"
+IUSE="xmms spell gtkhtml"
DEPEND=">=x11-libs/gtk+-2
>=dev-libs/libxml2-2.0
- net-ftp/curl
+ net-misc/curl
gtkhtml? ( >=gnome-extra/libgtkhtml-3.0 )
spell? ( app-text/gtkspell )
xmms? ( media-sound/xmms )"
-src_compile () {
+src_compile() {
local myconf
use xmms && myconf="${myconf} --enable-xmms"
@@ -29,7 +28,7 @@ src_compile () {
emake || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
- dodoc README TODO ChangeLog COPYING AUTHORS
+ dodoc README TODO ChangeLog AUTHORS
}
diff --git a/net-misc/logjam/logjam-4.3.2.ebuild b/net-misc/logjam/logjam-4.3.2.ebuild
index 9aa4c3a7beb9..816e352979ee 100644
--- a/net-misc/logjam/logjam-4.3.2.ebuild
+++ b/net-misc/logjam/logjam-4.3.2.ebuild
@@ -1,25 +1,24 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/logjam/logjam-4.3.2.ebuild,v 1.3 2004/03/20 00:49:36 weeve Exp $
-
-IUSE="xmms spell gtkhtml"
+# $Header: /var/cvsroot/gentoo-x86/net-misc/logjam/logjam-4.3.2.ebuild,v 1.4 2004/03/29 01:18:31 vapier Exp $
DESCRIPTION="GTK2-based LiveJournal client"
HOMEPAGE="http://logjam.danga.com/"
SRC_URI="http://logjam.danga.com/download/${P}.tar.bz2"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc"
+IUSE="xmms spell gtkhtml"
DEPEND=">=x11-libs/gtk+-2
>=dev-libs/libxml2-2.0
- net-ftp/curl
+ net-misc/curl
gtkhtml? ( >=gnome-extra/libgtkhtml-3.0 )
spell? ( app-text/gtkspell )
xmms? ( media-sound/xmms )"
-src_compile () {
+src_compile() {
local myconf
use xmms && myconf="${myconf} --enable-xmms"
@@ -29,7 +28,7 @@ src_compile () {
emake || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
- dodoc doc/README doc/TODO ChangeLog COPYING AUTHORS
+ dodoc doc/README doc/TODO ChangeLog AUTHORS
}