summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2014-05-14 23:22:00 +0000
committerChristoph Junghans <ottxor@gentoo.org>2014-05-14 23:22:00 +0000
commit6af51c8f7285f42152177bc17d5e3d14dab00975 (patch)
treee81d8fdc6f32732003b73716d5144d13b38b077d
parentbumpity bump, add IUSE examples, cleanup (diff)
downloadgentoo-2-6af51c8f7285f42152177bc17d5e3d14dab00975.tar.gz
gentoo-2-6af51c8f7285f42152177bc17d5e3d14dab00975.tar.bz2
gentoo-2-6af51c8f7285f42152177bc17d5e3d14dab00975.zip
provide logrotate.d entry that works with systemd (bug #508524)
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key C2000586)
-rw-r--r--app-admin/denyhosts/ChangeLog8
-rw-r--r--app-admin/denyhosts/denyhosts-2.6-r10.ebuild94
-rw-r--r--app-admin/denyhosts/files/denyhosts.logrotate-r210
3 files changed, 111 insertions, 1 deletions
diff --git a/app-admin/denyhosts/ChangeLog b/app-admin/denyhosts/ChangeLog
index 963ddec8d36f..40dd2dcc0067 100644
--- a/app-admin/denyhosts/ChangeLog
+++ b/app-admin/denyhosts/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/denyhosts
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/denyhosts/ChangeLog,v 1.78 2014/01/09 01:11:32 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/denyhosts/ChangeLog,v 1.79 2014/05/14 23:22:00 ottxor Exp $
+
+*denyhosts-2.6-r10 (14 May 2014)
+
+ 14 May 2014; Christoph Junghans <ottxor@gentoo.org> +denyhosts-2.6-r10.ebuild,
+ +files/denyhosts.logrotate-r2:
+ provide logrotate.d entry that works with systemd (bug #508524)
09 Jan 2014; Christoph Junghans <ottxor@gentoo.org> -files/denyhosts.init:
clean up unneeded files
diff --git a/app-admin/denyhosts/denyhosts-2.6-r10.ebuild b/app-admin/denyhosts/denyhosts-2.6-r10.ebuild
new file mode 100644
index 000000000000..0cd575cef485
--- /dev/null
+++ b/app-admin/denyhosts/denyhosts-2.6-r10.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/denyhosts/denyhosts-2.6-r10.ebuild,v 1.1 2014/05/14 23:22:00 ottxor Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1 eutils readme.gentoo systemd
+
+MY_PN="DenyHosts"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="DenyHosts is a utility to help sys admins thwart ssh hackers"
+HOMEPAGE="http://www.denyhosts.net"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+PYTHON_MODNAME="${MY_PN}"
+
+S="${WORKDIR}/${MY_P}"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+You can configure DenyHosts to run as a daemon by running:
+# rc-update add denyhosts default
+or:
+# systemctl enable denyhosts.service
+(if you use systemd)
+
+To run DenyHosts as a cronjob instead of a daemon add the following
+to /etc/crontab
+# run DenyHosts every 10 minutes
+*/10 * * * * root /usr/bin/denyhosts.py -c /etc/denyhosts.conf
+
+More information can be found at http://denyhosts.sourceforge.net/faq.html"
+
+src_prepare() {
+ # changes default file installations
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ epatch "${FILESDIR}"/${P}-log-injection-regex.patch
+
+ # Multiple patches from Fedora and Debian
+ epatch "${FILESDIR}"/${P}-daemon-control.patch
+ epatch "${FILESDIR}"/${P}-defconffile.patch
+ epatch "${FILESDIR}"/${P}-foreground_mode.patch
+ epatch "${FILESDIR}"/${P}-hostname.patch
+ epatch "${FILESDIR}"/${P}-plugin_deny.patch
+ epatch "${FILESDIR}"/${P}-single_config_switch.patch
+
+ epatch "${FILESDIR}"/${P}-cve-2013-6890.patch
+
+ sed -i -e 's:DENY_THRESHOLD_VALID = 10:DENY_THRESHOLD_VALID = 5:' \
+ denyhosts.cfg-dist || die "sed failed"
+
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ readme.gentoo_create_doc
+
+ dodoc CHANGELOG.txt README.txt PKG-INFO
+ distutils-r1_src_install
+
+ insinto /etc
+ insopts -m0640
+ newins denyhosts.cfg-dist denyhosts.conf
+
+ dodir /etc/logrotate.d
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${PN}.logrotate-r2 ${PN}
+
+ newinitd "${FILESDIR}"/denyhosts.init-r2 denyhosts
+ systemd_dounit "${FILESDIR}"/${PN}.service
+
+ # build system installs docs that we installed above
+ rm -f "${D}"/usr/share/denyhosts/*.txt
+
+ keepdir /var/lib/denyhosts
+}
+
+pkg_postinst() {
+ if [[ ! -f "${ROOT}etc/hosts.deny" ]]; then
+ touch "${ROOT}etc/hosts.deny"
+ fi
+
+ readme.gentoo_print_elog
+}
diff --git a/app-admin/denyhosts/files/denyhosts.logrotate-r2 b/app-admin/denyhosts/files/denyhosts.logrotate-r2
new file mode 100644
index 000000000000..582e72f7a365
--- /dev/null
+++ b/app-admin/denyhosts/files/denyhosts.logrotate-r2
@@ -0,0 +1,10 @@
+/var/log/denyhosts {
+ missingok
+ notifempty
+ create 0640 root root
+ sharedscripts
+ postrotate
+ test -e /run/openrc/softlevel && /etc/init.d/denyhosts restart 1>/dev/null || true
+ test -e /run/systemd/system && systemctl restart denyhosts >/dev/null || true
+ endscript
+}