summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2008-10-18 07:48:20 +0000
committerAlin Năstac <mrness@gentoo.org>2008-10-18 07:48:20 +0000
commit6b529dd4be890377eb45b5eea7e5438cb0d4dfe2 (patch)
treefbb13296509503dc7352940bcf2b3fc09dc2e2f1
parentPass Makefile parameters through emake command line (#240872). (diff)
downloadgentoo-2-6b529dd4be890377eb45b5eea7e5438cb0d4dfe2.tar.gz
gentoo-2-6b529dd4be890377eb45b5eea7e5438cb0d4dfe2.tar.bz2
gentoo-2-6b529dd4be890377eb45b5eea7e5438cb0d4dfe2.zip
Build hcfpcidiag with user specified CFLAGS/LDFLAGS (#240874).
(Portage version: 2.1.4.4)
-rw-r--r--net-dialup/hcfpcimodem/ChangeLog8
-rw-r--r--net-dialup/hcfpcimodem/files/hcfpcimodem-1.17-gentoo.patch29
-rw-r--r--net-dialup/hcfpcimodem/hcfpcimodem-1.17-r1.ebuild91
3 files changed, 127 insertions, 1 deletions
diff --git a/net-dialup/hcfpcimodem/ChangeLog b/net-dialup/hcfpcimodem/ChangeLog
index 5b209a2fc015..00c340f84f38 100644
--- a/net-dialup/hcfpcimodem/ChangeLog
+++ b/net-dialup/hcfpcimodem/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dialup/hcfpcimodem
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/hcfpcimodem/ChangeLog,v 1.38 2008/09/25 20:55:12 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/hcfpcimodem/ChangeLog,v 1.39 2008/10/18 07:48:20 mrness Exp $
+
+*hcfpcimodem-1.17-r1 (18 Oct 2008)
+
+ 18 Oct 2008; Alin Năstac <mrness@gentoo.org>
+ +files/hcfpcimodem-1.17-gentoo.patch, +hcfpcimodem-1.17-r1.ebuild:
+ Build hcfpcidiag with user specified CFLAGS/LDFLAGS (#240874).
*hcfpcimodem-1.17 (25 Sep 2008)
diff --git a/net-dialup/hcfpcimodem/files/hcfpcimodem-1.17-gentoo.patch b/net-dialup/hcfpcimodem/files/hcfpcimodem-1.17-gentoo.patch
new file mode 100644
index 000000000000..9ac0be4dde56
--- /dev/null
+++ b/net-dialup/hcfpcimodem/files/hcfpcimodem-1.17-gentoo.patch
@@ -0,0 +1,29 @@
+diff -Nru hcfpcimodem-1.17full.orig/diag/makefile hcfpcimodem-1.17full/diag/makefile
+--- hcfpcimodem-1.17full.orig/diag/makefile 2004-12-14 07:50:41.000000000 +0000
++++ hcfpcimodem-1.17full/diag/makefile 2008-10-18 07:41:51.000000000 +0000
+@@ -10,7 +10,7 @@
+ include $(TOP)/config.mak
+ -include $(TOP)/modules/imported/makeflags.mak
+
+-CFLAGS = -I$(TOP)/modules/imported/include -I$(TOP)/modules/include
++CFLAGS += -I$(TOP)/modules/imported/include -I$(TOP)/modules/include
+ CFLAGS += $(IMPORTED_FRAMEWORK_DEFS) $(IMPORTED_GENERAL_DEFS)
+ CFLAGS += -DCNXTTARGET="\"$(CNXTTARGET)\""
+
+@@ -41,13 +41,13 @@
+ $(MKDIR) -p $@
+
+ $(CNXTTARGET)diag: diag.o modemexpert.o
+- $(CC) -o $@ $^
++ $(CC) ${LDFLAGS} -o $@ $^
+
+ $(CNXTTARGET)scr: scr.o
+- $(CC) -o $@ $^
++ $(CC) ${CFLAGS} ${LDFLAGS} -o $@ $^
+
+ $(CNXTTARGET)dmp: dmp.o
+- $(CC) -o $@ $^
++ $(CC) ${CFLAGS} ${LDFLAGS} -o $@ $^
+
+ clean:
+ rm -f *.o $(ALL)
diff --git a/net-dialup/hcfpcimodem/hcfpcimodem-1.17-r1.ebuild b/net-dialup/hcfpcimodem/hcfpcimodem-1.17-r1.ebuild
new file mode 100644
index 000000000000..56c04581d840
--- /dev/null
+++ b/net-dialup/hcfpcimodem/hcfpcimodem-1.17-r1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/hcfpcimodem/hcfpcimodem-1.17-r1.ebuild,v 1.1 2008/10/18 07:48:20 mrness Exp $
+
+inherit eutils linux-info
+
+#The document is the same as in hsfmodem, even if it has a different URL
+MY_DOC="100498D_RM_HxF_Released.pdf"
+
+DESCRIPTION="Linuxant's modem driver for Connexant HCF chipset"
+HOMEPAGE="http://www.linuxant.com/drivers/hcf/index.php"
+SRC_URI="http://www.linuxant.com/drivers/hcf/full/archive/${P}full/${P}full.tar.gz
+ doc? ( http://www.linuxant.com/drivers/hcf/full/archive/${P}full/${MY_DOC} )"
+
+LICENSE="Conexant"
+SLOT="0"
+KEYWORDS="-* ~x86"
+IUSE="doc"
+
+DEPEND="dev-lang/perl
+ app-arch/cpio"
+
+S="${WORKDIR}/${P}full"
+
+QA_EXECSTACK="usr/lib/hcfpcimodem/modules/imported/hcfblam-i386.O usr/lib/hcfpcimodem/modules/imported/hcfengine-i386.O"
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ MOD_N="hcfpci"
+ # Check to see if module is inserted into kernel, otherwise, build fails
+ if [ "`lsmod | sed '/^'$MOD_N'serial/!d'`" ]; then
+ eerror
+ eerror "Module is in use by the kernel!!!"
+ eerror "Attempting to unload..."
+ eerror
+
+ # Unloading module...
+ ${MOD_N}stop
+ if [ "`lsmod | sed '/^'$MOD_N'serial/!d'`" ]; then
+ eerror "Failed to unload modules from kernel!!!"
+ eerror "Please manualy remove the module from the kernel and emerge again."
+ eerror
+ die
+ fi
+ einfo "Successfuly removed module from memory. Resuming emerge."
+ einfo
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_compile() {
+ emake all || die "make failed"
+}
+
+pkg_preinst() {
+ local NVMDIR="${ROOT}/etc/${PN}/nvm"
+ if [ -d "${NVMDIR}" ]; then
+ einfo "Cleaning ${NVMDIR}..."
+ rm -rf "${NVMDIR}"
+ eend
+ fi
+}
+
+src_install () {
+ make PREFIX="${D}/usr/" ROOT="${D}" install || die "make install failed"
+
+ # in some cases, kernelcompiler.sh does not have x permission (#173414)
+ fperms a+rx /usr/lib/hcfpcimodem/modules/kernelcompiler.sh
+
+ use doc && dodoc "${DISTDIR}/${MY_DOC}"
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" = / ]; then
+ elog "To complete the installation and configuration of your HCF modem,"
+ elog "please run hcfpciconfig."
+ fi
+}
+
+pkg_prerm() {
+ if [ "${ROOT}" = / -a -f /etc/init.d/hcfpci ] ; then
+ hcfpciconfig --remove || die "hcfpciconfig --remove failed"
+ fi
+}