summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2001-09-01 06:12:57 +0000
committerDonny Davies <woodchip@gentoo.org>2001-09-01 06:12:57 +0000
commit6c56a8aa4b39eb4d96fdee748d2426f0e7bd819b (patch)
treef23b707f1a528647fea0e61915856b358bad9e87
parentrc6 adjusts (diff)
downloadgentoo-2-6c56a8aa4b39eb4d96fdee748d2426f0e7bd819b.tar.gz
gentoo-2-6c56a8aa4b39eb4d96fdee748d2426f0e7bd819b.tar.bz2
gentoo-2-6c56a8aa4b39eb4d96fdee748d2426f0e7bd819b.zip
This is the last ebuild of xinetd that will install
the djb tools stubs. deprecated in rc6.
-rwxr-xr-xsys-apps/xinetd/files/xinetd-run5
-rw-r--r--sys-apps/xinetd/xinetd-2.3.3.ebuild51
2 files changed, 20 insertions, 36 deletions
diff --git a/sys-apps/xinetd/files/xinetd-run b/sys-apps/xinetd/files/xinetd-run
index 26fcefcbf0f1..912f10fc3aea 100755
--- a/sys-apps/xinetd/files/xinetd-run
+++ b/sys-apps/xinetd/files/xinetd-run
@@ -18,11 +18,8 @@ then
#bogus pidfile, remove
rm /var/run/xinetd.pid
fi
-fi
-if [ ! -e /var/run/xinetd.pid ]
-then
+else
/usr/sbin/xinetd -pidfile /var/run/xinetd.pid
/usr/bin/sleep 1
fi
exec /usr/bin/watchpid `cat /var/run/xinetd.pid`
-
diff --git a/sys-apps/xinetd/xinetd-2.3.3.ebuild b/sys-apps/xinetd/xinetd-2.3.3.ebuild
index 03faba460213..4bda0f2ff6f5 100644
--- a/sys-apps/xinetd/xinetd-2.3.3.ebuild
+++ b/sys-apps/xinetd/xinetd-2.3.3.ebuild
@@ -1,49 +1,36 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/xinetd/xinetd-2.3.3.ebuild,v 1.1 2001/08/30 15:07:52 lamer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/xinetd/xinetd-2.3.3.ebuild,v 1.2 2001/09/01 06:12:57 woodchip Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="Replacement for inetd."
HOMEPAGE="http://www.xinetd.org"
-SRC_URI="http://www.xinetd.org/${A}"
-DEPEND="virtual/glibc
- tcpd? ( >=sys-apps/tcp-wrappers-7.6-r2 )"
+SRC_URI="http://www.xinetd.org/${P}.tar.gz"
-RDEPEND="virtual/glibc
- sys-devel/perl"
+DEPEND="virtual/glibc tcpd? ( >=sys-apps/tcp-wrappers-7.6-r2 )"
+RDEPEND="virtual/glibc sys-devel/perl"
src_compile() {
+ local myconf
+ use tcpd && myconf="$myconf--with-libwrap"
+ use ipv6 && myconf="$myconf --with-inet6"
- local myconf
- if [ "`use tcpd`" ] ; then
- myconf="--with-libwrap"
- fi
- if [ "`use ipv6`" ] ; then
- myconf="$myconf --with-inet6"
- fi
-
- try ./configure --with-loadavg --prefix=/usr --mandir=/usr/share/man --host=${CHOST} $myconf
- # Parallel make does not work
- make || die
-
+ ./configure --with-loadavg --prefix=/usr --mandir=/usr/share/man --host=${CHOST} $myconf || die
+ # Parallel make does not work
+ make || die
}
src_install() {
- cd ${S}
- try make prefix=${D}/usr MANDIR=${D}/usr/share/man install
- dodoc CHANGELOG README COPYRIGHT
- exeinto /etc/rc.d/init.d
- doexe ${FILESDIR}/xinetd ${FILESDIR}/svc-xinetd
- insinto /etc
- #doins ${FILESDIR}/xinetd.conf
- exeinto /var/lib/supervise/services/xinetd
+ cd ${S}
+ make prefix=${D}/usr MANDIR=${D}/usr/share/man install
+ dodoc CHANGELOG README COPYRIGHT ${FILESDIR}/xinetd.conf
+
+ exeinto /etc/rc.d/init.d
+ newexe ${FILESDIR}/xinetd.rc5 xinetd
+ doexe ${FILESDIR}/svc-xinetd
+
newexe ${FILESDIR}/xinetd-run-${PV} run
- exeinto /usr/sbin
+ exeinto /usr/sbin
doexe ${FILESDIR}/xconv.pl
}
-
-
-
-