summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-25 23:06:50 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-25 23:06:50 +0000
commit6e44bf9c58786bb3f7fc57f6a2d60edea461e4b8 (patch)
treefb2806c132b9329df1a8a4937ce8a2a85b0503e8
parentFix ELF_DATA defines for arm/cris. (diff)
downloadgentoo-2-6e44bf9c58786bb3f7fc57f6a2d60edea461e4b8.tar.gz
gentoo-2-6e44bf9c58786bb3f7fc57f6a2d60edea461e4b8.tar.bz2
gentoo-2-6e44bf9c58786bb3f7fc57f6a2d60edea461e4b8.zip
Update list output to show the active version for all targets.
(Portage version: 2.0.51.22-r2)
-rw-r--r--sys-devel/gcc-config/ChangeLog5
-rwxr-xr-xsys-devel/gcc-config/files/gcc-config-1.3.1234
2 files changed, 28 insertions, 11 deletions
diff --git a/sys-devel/gcc-config/ChangeLog b/sys-devel/gcc-config/ChangeLog
index 7ddf2f88b8a5..97c039e0c0db 100644
--- a/sys-devel/gcc-config/ChangeLog
+++ b/sys-devel/gcc-config/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-devel/gcc-config
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/ChangeLog,v 1.99 2005/08/09 08:34:23 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/ChangeLog,v 1.100 2005/08/25 23:06:50 vapier Exp $
+
+ 25 Aug 2005; Mike Frysinger <vapier@gentoo.org> files/gcc-config-1.3.12:
+ Update list output to show the active version for all targets.
09 Aug 2005; Jeremy Huddleston <eradicator@gentoo.org>
-files/gcc-config-1.4.0, -gcc-config-1.4.0.ebuild:
diff --git a/sys-devel/gcc-config/files/gcc-config-1.3.12 b/sys-devel/gcc-config/files/gcc-config-1.3.12
index 9366d86756e4..25abc348a769 100755
--- a/sys-devel/gcc-config/files/gcc-config-1.3.12
+++ b/sys-devel/gcc-config/files/gcc-config-1.3.12
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.3.12,v 1.4 2005/08/20 07:36:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.3.12,v 1.5 2005/08/25 23:06:50 vapier Exp $
trap ":" INT QUIT TSTP
@@ -323,21 +323,35 @@ get_current_profile() {
list_profiles() {
local i=1
+ if [[ ${ROOT} != "/" ]] ; then
+ echo "Using gcc-config info in ${ROOT}"
+ fi
+
if [[ ! -f ${GCC_ENV_D}/config ]] ; then
eerror "$0: No gcc profile is active; please select one!"
- else
- get_current_profile >/dev/null
fi
- if [[ ${ROOT} != "/" ]] ; then
- echo "Using gcc-config info in ${ROOT}"
- fi
+ eval $(grep ^CURRENT= "${GCC_ENV_D}"/config)
+ CURRENT_NATIVE=${CURRENT}
+ local target=
for x in "${GCC_ENV_D}"/* ; do
if [[ -f ${x} ]] && [[ ${x/\/config} == ${x} ]] ; then
+ source "${x}"
+ if [[ ${target} != ${CTARGET} ]] ; then
+ [[ -n ${target} ]] && echo
+ target=${CTARGET}
+ CTARGET=""
+ fi
+
x=${x##*/}
- [[ ${x} == ${CURRENT} ]] && x="${x} *"
- echo "[${i}] ${x}"
- i=$((i + 1))
+ if [[ ${x} == ${CURRENT_NATIVE} ]] ; then
+ x="${x} ${GOOD}*${NORMAL}"
+ elif [[ -e ${GCC_ENV_D}/config-${target} ]] ; then
+ source "${GCC_ENV_D}/config-${target}"
+ [[ ${x} == ${CURRENT} ]] && x="${x} ${HILITE}*${NORMAL}"
+ fi
+ echo " [${i}] ${x}"
+ ((++i))
fi
done
}
@@ -546,7 +560,7 @@ for x in "$@" ; do
CC_COMP="${y##*/}"
break
fi
- i=$((i + 1))
+ ((++i))
done
else
# User gave us a full HOST-gccver