summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2008-06-24 00:31:47 +0000
committerAlin Năstac <mrness@gentoo.org>2008-06-24 00:31:47 +0000
commit7647d94b4ea361ffd86958680ae9401f11dfa409 (patch)
tree6b1c47766fd5a9df7343fba666aade8cc5fd789e
parentold (diff)
downloadgentoo-2-7647d94b4ea361ffd86958680ae9401f11dfa409.tar.gz
gentoo-2-7647d94b4ea361ffd86958680ae9401f11dfa409.tar.bz2
gentoo-2-7647d94b4ea361ffd86958680ae9401f11dfa409.zip
Remove flex test during configure (#221365).
Ebuild code cleanup. (Portage version: 2.1.4.4)
-rw-r--r--app-mobilephone/kannel/ChangeLog6
-rw-r--r--app-mobilephone/kannel/files/kannel-1.4.1-nolex.patch22
-rw-r--r--app-mobilephone/kannel/kannel-1.4.1.ebuild27
3 files changed, 44 insertions, 11 deletions
diff --git a/app-mobilephone/kannel/ChangeLog b/app-mobilephone/kannel/ChangeLog
index 5da0bab48f8c..9afcc0e1b313 100644
--- a/app-mobilephone/kannel/ChangeLog
+++ b/app-mobilephone/kannel/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-mobilephone/kannel
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/kannel/ChangeLog,v 1.16 2008/05/21 15:52:40 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/kannel/ChangeLog,v 1.17 2008/06/24 00:31:46 mrness Exp $
+
+ 24 Jun 2008; Alin Năstac <mrness@gentoo.org>
+ +files/kannel-1.4.1-nolex.patch, kannel-1.4.1.ebuild:
+ Remove flex test during configure (#221365). Ebuild code cleanup.
21 May 2008; Tiziano Müller <dev-zero@gentoo.org> kannel-1.4.1.ebuild:
Changed dependency for postgresql from dev-db/postgresql to
diff --git a/app-mobilephone/kannel/files/kannel-1.4.1-nolex.patch b/app-mobilephone/kannel/files/kannel-1.4.1-nolex.patch
new file mode 100644
index 000000000000..07dfd147d677
--- /dev/null
+++ b/app-mobilephone/kannel/files/kannel-1.4.1-nolex.patch
@@ -0,0 +1,22 @@
+diff -Nru gateway-1.4.1.orig/configure.in gateway-1.4.1/configure.in
+--- gateway-1.4.1.orig/configure.in 2008-06-24 02:00:07.000000000 +0200
++++ gateway-1.4.1/configure.in 2008-06-24 02:06:05.000000000 +0200
+@@ -108,7 +108,6 @@
+ AC_PROG_INSTALL
+ AC_PROG_RANLIB
+ AC_PROG_YACC
+-AC_PROG_LEX
+ AC_PATH_PROG(CONVERT, convert)
+ AC_PATH_PROG(PERL, perl)
+
+diff -Nru gateway-1.4.1.orig/Makefile.in gateway-1.4.1/Makefile.in
+--- gateway-1.4.1.orig/Makefile.in 2006-05-09 07:46:56.000000000 +0200
++++ gateway-1.4.1/Makefile.in 2008-06-24 02:06:21.000000000 +0200
+@@ -60,7 +60,6 @@
+ SHELL = @SHELL@
+ VERSION = @VERSION@
+ SUFFIX = @SUFFIX@
+-LEX = @LEX@
+ PERL = @PERL@
+ YACC = @YACC@
+
diff --git a/app-mobilephone/kannel/kannel-1.4.1.ebuild b/app-mobilephone/kannel/kannel-1.4.1.ebuild
index 9290568c4fe7..47906f2c2202 100644
--- a/app-mobilephone/kannel/kannel-1.4.1.ebuild
+++ b/app-mobilephone/kannel/kannel-1.4.1.ebuild
@@ -1,7 +1,10 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/kannel/kannel-1.4.1.ebuild,v 1.7 2008/05/21 15:52:40 dev-zero Exp $
-inherit eutils
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/kannel/kannel-1.4.1.ebuild,v 1.8 2008/06/24 00:31:46 mrness Exp $
+
+WANT_AUTOMAKE=none
+
+inherit eutils autotools flag-o-matic
DESCRIPTION="Powerful SMS and WAP gateway"
HOMEPAGE="http://www.kannel.org/"
@@ -38,17 +41,19 @@ pkg_setup() {
src_unpack() {
unpack ${A}
+ cd "${S}"
epatch "${FILESDIR}/${P}-custom-wap-ports.patch"
+ epatch "${FILESDIR}/${P}-nolex.patch" # flex is not used
- cd "${S}"
#by default, use current directory for logging
sed -i -e 's:/tmp/::' doc/examples/kannel.conf
- #correct doc path
- sed -i -e "s:share/doc/kannel:share/doc/${P}:" configure configure.in
+
+ eautoconf
}
src_compile() {
- econf \
+ append-flags -fno-strict-aliasing # some code breaks strict aliasing
+ econf --docdir=/usr/share/doc/${P} \
--enable-localtime \
--disable-start-stop-daemon \
$(use_enable pam) \
@@ -60,19 +65,21 @@ src_compile() {
$(use_with sqlite) \
$(use_with sqlite3) \
$(use_with postgres pgsql) \
- || die "./configure failed"
+ || die "econf failed"
emake || die "emake failed"
}
src_test() {
- make check || die "make check failed"
+ emake check || die "make check failed"
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
- use doc && make DESTDIR="${D}" install-docs
+ if use doc; then
+ emake DESTDIR="${D}" install-docs || die "emake install-docs failed"
+ fi
dodoc README LICENSE
diropts -g kannel -m0750