summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-02-01 20:48:51 +0000
committerMike Frysinger <vapier@gentoo.org>2004-02-01 20:48:51 +0000
commit766195a81fd5cfeeb9e1e340fca62867b09d20a0 (patch)
tree7192c3ddd22d392dd39ac06269afa61d2c868447
parentold (diff)
downloadgentoo-2-766195a81fd5cfeeb9e1e340fca62867b09d20a0.tar.gz
gentoo-2-766195a81fd5cfeeb9e1e340fca62867b09d20a0.tar.bz2
gentoo-2-766195a81fd5cfeeb9e1e340fca62867b09d20a0.zip
ver bump
-rw-r--r--app-misc/evidence/evidence-0.9.7.20040201.ebuild67
-rw-r--r--app-misc/evidence/files/digest-evidence-0.9.7.200402011
-rw-r--r--sys-apps/epbb/epbb-0.0.5.20040201.ebuild14
-rw-r--r--sys-apps/epbb/files/digest-epbb-0.0.5.200402011
-rw-r--r--x11-misc/entrance/entrance-0.9.0.20040201.ebuild65
-rw-r--r--x11-misc/entrance/files/digest-entrance-0.9.0.200402012
6 files changed, 150 insertions, 0 deletions
diff --git a/app-misc/evidence/evidence-0.9.7.20040201.ebuild b/app-misc/evidence/evidence-0.9.7.20040201.ebuild
new file mode 100644
index 000000000000..730834e19751
--- /dev/null
+++ b/app-misc/evidence/evidence-0.9.7.20040201.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/evidence/evidence-0.9.7.20040201.ebuild,v 1.1 2004/02/01 20:44:34 vapier Exp $
+
+inherit enlightenment eutils flag-o-matic
+
+DESCRIPTION="GTK2 file-manager"
+HOMEPAGE="http://evidence.sourceforge.net/"
+
+LICENSE="GPL-2"
+IUSE="${IUSE} perl X mad oggvorbis truetype gnome kde"
+
+DEPEND=">=dev-util/pkgconfig-0.5
+ =x11-libs/gtk+-2*
+ oggvorbis? ( media-libs/libvorbis
+ media-libs/libogg )
+ perl? ( dev-libs/libpcre )
+ X? ( virtual/x11 )
+ mad? ( media-sound/mad )
+ truetype? ( =media-libs/freetype-2* )
+ kde? ( kde-base/kdelibs )
+ media-libs/libao
+ virtual/glibc
+ sys-devel/gcc
+ app-admin/fam
+ >=sys-fs/efsd-0.0.1.20031013
+ >=x11-libs/evas-1.0.0.20031018_pre12
+ >=dev-db/edb-1.0.4
+ >=dev-libs/eet-0.9.0.20031013
+ >=x11-libs/ecore-1.0.0.20031018_pre4
+ >=media-libs/imlib2-1.1.0
+ gnome? ( >=gnome-base/gnome-vfs-2.0
+ >=media-libs/libart_lgpl-2.0
+ >=gnome-base/libgnomecanvas-2.0 )"
+
+src_compile() {
+ # if we turn this on evas gets turned off (bad !)
+ #use gnome && MY_ECONF="${MY_ECONF} --enable-canvas-gnomecanvas"
+
+# `use_enable gnome backend-gnomevfs2`
+# `use_enable kde backend-kio`
+ export MY_ECONF="
+ --enable-ecore-ipc
+ --enable-canvas-evas2
+ --disable-backend-efsd
+ --enable-extra-themes
+ --enable-extra-iconsets
+ `use_enable perl pcre`
+ `use_enable x X`
+ `use_enable mad libmad`
+ `use_enable oggvorbis plugin-vorbis`
+ `use_enable truetype plugin-ttf`
+ `use_enable debug`
+ "
+ enlightenment_src_compile
+}
+
+src_install() {
+ enlightenment_src_install
+
+ # Fixup broken symlinks
+ dosym efm /usr/share/evidence/icons/default
+ dosym efm /usr/share/evidence/themes/default
+ chown -R root:root ${D}/usr/share/evidence
+
+ dodoc docs/*
+}
diff --git a/app-misc/evidence/files/digest-evidence-0.9.7.20040201 b/app-misc/evidence/files/digest-evidence-0.9.7.20040201
new file mode 100644
index 000000000000..68efc6dc0178
--- /dev/null
+++ b/app-misc/evidence/files/digest-evidence-0.9.7.20040201
@@ -0,0 +1 @@
+MD5 b177f991a3c45153f5f595de0abbb89a evidence-0.9.7.20040201.tar.bz2 4760799
diff --git a/sys-apps/epbb/epbb-0.0.5.20040201.ebuild b/sys-apps/epbb/epbb-0.0.5.20040201.ebuild
new file mode 100644
index 000000000000..a4dca8039700
--- /dev/null
+++ b/sys-apps/epbb/epbb-0.0.5.20040201.ebuild
@@ -0,0 +1,14 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/epbb/epbb-0.0.5.20040201.ebuild,v 1.1 2004/02/01 20:45:38 vapier Exp $
+
+inherit enlightenment
+
+DESCRIPTION="a pbbuttonsd client using the EFL"
+
+KEYWORDS="~ppc"
+
+DEPEND=">=x11-libs/evas-1.0.0.20040117_pre12
+ >=media-libs/edje-0.0.1.20040117
+ >=x11-libs/ecore-1.0.0.20040117_pre4
+ >=sys-apps/pbbuttonsd-0.5.2"
diff --git a/sys-apps/epbb/files/digest-epbb-0.0.5.20040201 b/sys-apps/epbb/files/digest-epbb-0.0.5.20040201
new file mode 100644
index 000000000000..6c5721c50d3a
--- /dev/null
+++ b/sys-apps/epbb/files/digest-epbb-0.0.5.20040201
@@ -0,0 +1 @@
+MD5 01a3e1fb70559276f3ad295efbb5139b epbb-0.0.5.20040201.tar.bz2 497413
diff --git a/x11-misc/entrance/entrance-0.9.0.20040201.ebuild b/x11-misc/entrance/entrance-0.9.0.20040201.ebuild
new file mode 100644
index 000000000000..f4cb11e28db2
--- /dev/null
+++ b/x11-misc/entrance/entrance-0.9.0.20040201.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/entrance/entrance-0.9.0.20040201.ebuild,v 1.1 2004/02/01 20:48:51 vapier Exp $
+
+inherit enlightenment eutils
+
+DESCRIPTION="next generation of Elogin, a login/display manager for X"
+HOMEPAGE="http://xcomputerman.com/pages/entrance.html"
+SRC_URI="${SRC_URI}
+ mirror://gentoo/extraicons-1.tar.bz2
+ http://wh0rd.de/gentoo/distfiles/extraicons-1.tar.bz2"
+
+IUSE="${IUSE} pam"
+
+DEPEND="virtual/x11
+ pam? ( sys-libs/pam )
+ >=dev-db/edb-1.0.4.20031013
+ >=x11-libs/evas-1.0.0.20031025_pre11
+ >=x11-libs/ecore-0.0.2.20031018_pre4
+ >=media-libs/edje-0.0.1.20031020
+ >=x11-libs/esmart-0.0.2.20031025"
+
+src_compile() {
+ if [ `use pam` ] ; then
+ export MY_ECONF="--with-auth-mode=pam"
+ else
+ export MY_ECONF="--with-auth-mode=shadow"
+ fi
+ enlightenment_src_compile
+}
+
+src_install() {
+ enlightenment_src_install
+ rm -rf ${D}/etc/init.d
+ insinto /usr/share/entrance/images/sessions
+ doins ${WORKDIR}/extraicons/*
+ exeinto /usr/share/entrance
+ doexe data/config/build_config.sh
+
+ cd /etc/X11/Sessions
+ local edb="${D}/etc/entrance_config.db"
+ local count="`edb_ed ${edb} get /entrance/session/count int`"
+ local datadir="${D}/usr/share/entrance/images/sessions"
+ local icon=""
+ while [ ${count} -ge 0 ] ; do
+ edb_ed ${edb} del /entrance/session/${count}/icon
+ edb_ed ${edb} del /entrance/session/${count}/session
+ edb_ed ${edb} del /entrance/session/${count}/title
+ count=$((${count} - 1))
+ done
+ count=0
+ for s in Default * failsafe ; do
+ [ "${s}" == "Xsession" ] && continue
+ icon="`find ${datadir} -iname ${s}.png -printf %f`"
+ if [ -z "${icon}" ] ; then
+ edb_ed ${edb} add /entrance/session/${count}/icon str default.png
+ else
+ edb_ed ${edb} add /entrance/session/${count}/icon str ${icon}
+ fi
+ edb_ed ${edb} add /entrance/session/${count}/session str ${s}
+ edb_ed ${edb} add /entrance/session/${count}/title str ${s}
+ count=$((${count} + 1))
+ done
+ edb_ed ${edb} add /entrance/session/count int ${count}
+}
diff --git a/x11-misc/entrance/files/digest-entrance-0.9.0.20040201 b/x11-misc/entrance/files/digest-entrance-0.9.0.20040201
new file mode 100644
index 000000000000..506a610e4331
--- /dev/null
+++ b/x11-misc/entrance/files/digest-entrance-0.9.0.20040201
@@ -0,0 +1,2 @@
+MD5 afa785b2f43156945050e720c271b13b entrance-0.9.0.20040201.tar.bz2 6559260
+MD5 b1d2a452028c3a09443d84968e24144c extraicons-1.tar.bz2 16770