summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-10-27 13:01:10 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-10-27 13:01:10 +0000
commit7a029020e984aa64164cce8c828058fa64ba5ac0 (patch)
treea3e4914553f8d8d5e50037f129b4c928ada673ad
parentversion bump (diff)
downloadgentoo-2-7a029020e984aa64164cce8c828058fa64ba5ac0.tar.gz
gentoo-2-7a029020e984aa64164cce8c828058fa64ba5ac0.tar.bz2
gentoo-2-7a029020e984aa64164cce8c828058fa64ba5ac0.zip
version bump
(Portage version: 2.2_rc46/cvs/Linux x86_64)
-rw-r--r--media-video/cclive/ChangeLog7
-rw-r--r--media-video/cclive/cclive-0.5.3.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/media-video/cclive/ChangeLog b/media-video/cclive/ChangeLog
index 9cd2b53ba5c4..af86e529cab3 100644
--- a/media-video/cclive/ChangeLog
+++ b/media-video/cclive/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/cclive
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/cclive/ChangeLog,v 1.6 2009/10/10 00:42:05 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/cclive/ChangeLog,v 1.7 2009/10/27 13:01:10 aballier Exp $
+
+*cclive-0.5.3 (27 Oct 2009)
+
+ 27 Oct 2009; Alexis Ballier <aballier@gentoo.org> +cclive-0.5.3.ebuild:
+ version bump
*cclive-0.5.2 (10 Oct 2009)
diff --git a/media-video/cclive/cclive-0.5.3.ebuild b/media-video/cclive/cclive-0.5.3.ebuild
new file mode 100644
index 000000000000..fa7109a0b5ce
--- /dev/null
+++ b/media-video/cclive/cclive-0.5.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/cclive/cclive-0.5.3.ebuild,v 1.1 2009/10/27 13:01:10 aballier Exp $
+
+EAPI=2
+
+DESCRIPTION="Command line tool for extracting videos from various websites"
+HOMEPAGE="http://code.google.com/p/cclive/"
+SRC_URI="http://cclive.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+RDEPEND=">=net-misc/curl-7.18.0
+ >=dev-libs/libpcre-7.9[cxx]"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf \
+ --with-man \
+ $(use_enable test tests)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO || die "dodoc failed"
+}
+
+src_test() {
+ einfo "Tests require internet connection in order to work."
+ ADULT_OK="true" emake check || die "emake test failed"
+}