summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-03-11 02:43:44 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-03-11 02:43:44 +0000
commit7c189a734632ee4dad3f48e68acea90b3feeab97 (patch)
tree3feb0b70256f3451fe170504144837c686f9286e
parentupdated dev-python/cliff to 1.3.1 (diff)
downloadgentoo-2-7c189a734632ee4dad3f48e68acea90b3feeab97.tar.gz
gentoo-2-7c189a734632ee4dad3f48e68acea90b3feeab97.tar.bz2
gentoo-2-7c189a734632ee4dad3f48e68acea90b3feeab97.zip
update of python-quantumclient to 2.2.0
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
-rw-r--r--dev-python/python-quantumclient/ChangeLog9
-rw-r--r--dev-python/python-quantumclient/python-quantumclient-2.2.0.ebuild28
2 files changed, 35 insertions, 2 deletions
diff --git a/dev-python/python-quantumclient/ChangeLog b/dev-python/python-quantumclient/ChangeLog
index 1ef5ebcc2ee7..d30878887091 100644
--- a/dev-python/python-quantumclient/ChangeLog
+++ b/dev-python/python-quantumclient/ChangeLog
@@ -1,10 +1,15 @@
# ChangeLog for dev-python/python-quantumclient
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-quantumclient/ChangeLog,v 1.1 2013/01/26 08:06:56 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-quantumclient/ChangeLog,v 1.2 2013/03/11 02:43:44 prometheanfire Exp $
+
+*python-quantumclient-2.2.0 (11 Mar 2013)
+
+ 11 Mar 2013; Matthew Thode <prometheanfire@gentoo.org>
+ +python-quantumclient-2.2.0.ebuild:
+ update of python-quantumclient to 2.2.0
*python-quantumclient-2.1 (26 Jan 2013)
26 Jan 2013; Matthew Thode <prometheanfire@gentoo.org>
+python-quantumclient-2.1.ebuild, +metadata.xml:
initial add of python-quantumclient
-
diff --git a/dev-python/python-quantumclient/python-quantumclient-2.2.0.ebuild b/dev-python/python-quantumclient/python-quantumclient-2.2.0.ebuild
new file mode 100644
index 000000000000..2fa4b79f42e9
--- /dev/null
+++ b/dev-python/python-quantumclient/python-quantumclient-2.2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-quantumclient/python-quantumclient-2.2.0.ebuild,v 1.1 2013/03/11 02:43:44 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Quantum API"
+HOMEPAGE="https://launchpad.net/quantum"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="virtual/python-argparse[${PYTHON_USEDEP}]
+ >=dev-python/cliff-1.3.1
+ dev-python/httplib2
+ dev-python/iso8601
+ >=dev-python/prettytable-0.6
+ <dev-python/prettytable-0.7
+ >=dev-python/pyparsing-1.5.6
+ <dev-python/pyparsing-2.0
+ dev-python/simplejson"