summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2007-12-18 07:15:19 +0000
committerHans de Graaff <graaff@gentoo.org>2007-12-18 07:15:19 +0000
commit7e27ab2c66c9287bbd291fa3f015653e91a3fc6a (patch)
tree473fe74aa3996dd8644b90aea68838f58f671692
parentVersion bump for Rails 2.0.2 (diff)
downloadgentoo-2-7e27ab2c66c9287bbd291fa3f015653e91a3fc6a.tar.gz
gentoo-2-7e27ab2c66c9287bbd291fa3f015653e91a3fc6a.tar.bz2
gentoo-2-7e27ab2c66c9287bbd291fa3f015653e91a3fc6a.zip
Version bump for Rails 2.0.2
(Portage version: 2.1.3.19)
-rw-r--r--dev-ruby/rails/ChangeLog7
-rw-r--r--dev-ruby/rails/files/digest-rails-2.0.23
-rw-r--r--dev-ruby/rails/rails-2.0.2.ebuild48
3 files changed, 57 insertions, 1 deletions
diff --git a/dev-ruby/rails/ChangeLog b/dev-ruby/rails/ChangeLog
index 854ba5c77cd4..464ba7cc6e47 100644
--- a/dev-ruby/rails/ChangeLog
+++ b/dev-ruby/rails/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rails
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.94 2007/12/01 22:48:48 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.95 2007/12/18 07:15:18 graaff Exp $
+
+*rails-2.0.2 (18 Dec 2007)
+
+ 18 Dec 2007; Hans de Graaff <graaff@gentoo.org> +rails-2.0.2.ebuild:
+ Version bump for Rails 2.0.2
01 Dec 2007; Christoph Mende <angelos@gentoo.org> rails-1.2.6.ebuild:
Stable on amd64 wrt bug #200159
diff --git a/dev-ruby/rails/files/digest-rails-2.0.2 b/dev-ruby/rails/files/digest-rails-2.0.2
new file mode 100644
index 000000000000..80fb096eb0b3
--- /dev/null
+++ b/dev-ruby/rails/files/digest-rails-2.0.2
@@ -0,0 +1,3 @@
+MD5 3bfadab613a0b4b50a84c45ac21f3a4a rails-2.0.2.gem 183808
+RMD160 f1b7593466db77e1f51b19a262ce0ee9bc287d6c rails-2.0.2.gem 183808
+SHA256 5b5c2e7710a32c47686eb9f564153cda98cca91ce0cf8c26de97bfb7e4f86b94 rails-2.0.2.gem 183808
diff --git a/dev-ruby/rails/rails-2.0.2.ebuild b/dev-ruby/rails/rails-2.0.2.ebuild
new file mode 100644
index 000000000000..f7b4a13bc96a
--- /dev/null
+++ b/dev-ruby/rails/rails-2.0.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/rails-2.0.2.ebuild,v 1.1 2007/12/18 07:15:18 graaff Exp $
+
+inherit ruby gems
+
+DESCRIPTION="ruby on rails is a web-application and persistance framework"
+HOMEPAGE="http://www.rubyonrails.org"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="fastcgi"
+DEPEND=">=dev-lang/ruby-1.8.5
+ >=app-admin/eselect-rails-0.11
+ >=dev-ruby/rake-0.7.2
+ =dev-ruby/activerecord-2.0.2
+ =dev-ruby/activeresource-2.0.2
+ =dev-ruby/activesupport-2.0.2
+ =dev-ruby/actionmailer-2.0.2
+ =dev-ruby/actionpack-2.0.2
+ !<dev-ruby/rails-1.1.6-r1"
+
+RDEPEND="${DEPEND}
+ fastcgi? ( >=dev-ruby/ruby-fcgi-0.8.6 )"
+
+src_install() {
+ gems_src_install
+ # Rename slotted files that may clash so that eselect can handle
+ # them
+ mv ${D}/usr/bin/rails ${D}/usr/bin/rails-${PV}
+ mv ${D}/${GEMSDIR}/bin/rails ${D}/${GEMSDIR}/bin/rails-${PV}
+}
+
+pkg_postinst() {
+ einfo "To select between slots of rails, use:"
+ einfo "\teselect rails"
+ # Bring users to rails 2.0.x by default when updating
+ eselect rails update 2
+
+ einfo "All database USE flags have been moved to dev-ruby/activerecord"
+}
+
+pkg_postrm() {
+ # Drop users back to rails 1.2.x when they remove 2.0.x
+ eselect rails update 1.2
+}