summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-03-21 17:30:22 +0000
committerMarinus Schraal <foser@gentoo.org>2003-03-21 17:30:22 +0000
commit7f5608b7f77242a46d7134969ed0d13f845102db (patch)
tree5fea79984b39215ca628d0a0501310c69cc87cae
parentAdded hppa to KEYWORDS. (diff)
downloadgentoo-2-7f5608b7f77242a46d7134969ed0d13f845102db.tar.gz
gentoo-2-7f5608b7f77242a46d7134969ed0d13f845102db.tar.bz2
gentoo-2-7f5608b7f77242a46d7134969ed0d13f845102db.zip
new version
-rw-r--r--app-office/abiword/ChangeLog9
-rw-r--r--app-office/abiword/abiword-1.0.5.ebuild82
-rw-r--r--app-office/abiword/files/digest-abiword-1.0.51
-rw-r--r--app-office/gnucash/ChangeLog7
-rw-r--r--app-office/gnucash/files/digest-gnucash-1.8.21
-rw-r--r--app-office/gnucash/gnucash-1.8.2.ebuild61
6 files changed, 159 insertions, 2 deletions
diff --git a/app-office/abiword/ChangeLog b/app-office/abiword/ChangeLog
index 4361f543d593..0b2f5000c4a1 100644
--- a/app-office/abiword/ChangeLog
+++ b/app-office/abiword/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-office/abiword
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.26 2003/03/16 00:51:23 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.27 2003/03/21 17:30:22 foser Exp $
+
+*abiword-1.0.5 (16 Mar 2003)
+
+ 16 Mar 2003; foser <foser@gentoo.org> abiword-1.0.5.ebuild :
+ New version
+ disabled gnome USE because it breaks
+ disabled perl USE because it never really worked
*abiword-1.0.4 (26 Jan 2003)
diff --git a/app-office/abiword/abiword-1.0.5.ebuild b/app-office/abiword/abiword-1.0.5.ebuild
new file mode 100644
index 000000000000..608bb7b81e2d
--- /dev/null
+++ b/app-office/abiword/abiword-1.0.5.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-1.0.5.ebuild,v 1.1 2003/03/21 17:30:22 foser Exp $
+
+IUSE="nls build spell jpeg xml2"
+
+S=${WORKDIR}/${P}/abi
+
+DESCRIPTION="Word processor"
+SRC_URI="mirror://sourceforge/abiword/${P}.tar.gz"
+HOMEPAGE="http://www.abisource.com"
+
+KEYWORDS="~x86 ~ppc"
+LICENSE="GPL-2"
+SLOT="1"
+
+DEPEND="virtual/x11
+ media-libs/libpng
+ >=dev-libs/libunicode-0.4-r1
+ =x11-libs/gtk+-1.2*
+ jpeg? ( >=media-libs/jpeg-6b-r2 )
+ xml2? ( >=dev-libs/libxml2-2.4.10 )
+ spell? ( >=app-text/aspell-0.50.2-r1 )
+ !app-shells/bash-completion"
+
+# gnome build seems broken <foser@gentoo.org>
+# gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r1
+# >=gnome-extra/gal-0.13-r1
+# >=gnome-base/bonobo-1.0.9-r1 )
+
+src_compile() {
+ local myconf
+
+# use gnome \
+# && myconf="${myconf} --with-gnome --enable-gnome"; \
+# export ABI_OPT_BONOBO=1
+
+ use spell \
+ && myconf="${myconf} --with-pspell --disable-static"
+
+ use xml2 \
+ && myconf="${myconf} --with-libxml2" \
+ || myconf="${myconf} --without-libxml2"
+ use jpeg \
+ && myconf="${myconf} --with-libjpeg" \
+ || myconf="${myconf} --without-libjpeg"
+
+ use nls \
+ && myconf="${myconf} --enable-bidi"
+
+ ./autogen.sh
+
+ einfo "Ignore above ERROR as it does not cause build to fail."
+
+ CFLAGS="${CFLAGS} `gdk-pixbuf-config --cflags`"
+
+ # we got enough of the perl problems for now
+ econf ${myconf} --disable-scripting
+
+ make || die
+}
+
+src_install() {
+ dodir /usr/{bin,lib}
+
+ einstall
+
+ dosed "s:${D}::g" /usr/bin/AbiWord
+
+ rm -f ${D}/usr/bin/abiword
+ dosym /usr/bin/AbiWord /usr/bin/abiword
+
+ dodoc BUILD COPYING *.txt, *.TXT
+
+ # Install icon and .desktop for menu entry
+ use gnome && ( \
+ insinto /usr/share/pixmaps
+ newins ${WORKDIR}/${P}/abidistfiles/icons/abiword_48.png AbiWord.png
+ insinto /usr/share/gnome/apps/Applications
+ doins ${FILESDIR}/AbiWord.desktop
+ )
+}
diff --git a/app-office/abiword/files/digest-abiword-1.0.5 b/app-office/abiword/files/digest-abiword-1.0.5
new file mode 100644
index 000000000000..07bf249fd7d6
--- /dev/null
+++ b/app-office/abiword/files/digest-abiword-1.0.5
@@ -0,0 +1 @@
+MD5 dfe86fb72afc4008e51504fd693b224e abiword-1.0.5.tar.gz 18966097
diff --git a/app-office/gnucash/ChangeLog b/app-office/gnucash/ChangeLog
index a422efc91797..47160b87cc89 100644
--- a/app-office/gnucash/ChangeLog
+++ b/app-office/gnucash/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for app-office/gnucash
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/ChangeLog,v 1.16 2003/03/20 01:00:33 nall Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/ChangeLog,v 1.17 2003/03/21 17:26:25 foser Exp $
+*gnucash-1.8.2 (21 Mar 2003)
+
+ 21 Mar 2003; foser <foser@gentoo.org> gnucash-1.8.2.ebuild :
+ Fixed SRC_URI and a couple of other minor things
+
*gnucash-1.8.1 (17 Mar 2003)
19 Mar 2003; Jon Nall <nall@gentoo.org> gnucash-1.8.1.ebuild :
diff --git a/app-office/gnucash/files/digest-gnucash-1.8.2 b/app-office/gnucash/files/digest-gnucash-1.8.2
new file mode 100644
index 000000000000..a40fbd473544
--- /dev/null
+++ b/app-office/gnucash/files/digest-gnucash-1.8.2
@@ -0,0 +1 @@
+MD5 3995f9df6766d2573b1cf96b6b12bea0 gnucash-1.8.2.tar.gz 6555050
diff --git a/app-office/gnucash/gnucash-1.8.2.ebuild b/app-office/gnucash/gnucash-1.8.2.ebuild
new file mode 100644
index 000000000000..25ad0b16c82e
--- /dev/null
+++ b/app-office/gnucash/gnucash-1.8.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/gnucash-1.8.2.ebuild,v 1.1 2003/03/21 17:26:25 foser Exp $
+
+# FIXME - ebuild needs a good look at
+
+inherit flag-o-matic libtool
+
+DESCRIPTION="A personal finance manager"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnucash.org/"
+
+KEYWORDS="~x86 ~ppc"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="nls postgres"
+
+RDEPEND=">=gnome-base/gnome-libs-1.4.1.2-r1
+ >=dev-libs/libxml-1.8.3
+ >=gnome-extra/gtkhtml-0.14.0-r1
+ >=gnome-extra/gal-0.13-r1
+ >=gnome-extra/guppi-0.35.5-r2
+ >=gnome-base/gnome-print-0.21
+ postgres? ( dev-db/postgresql )"
+
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5
+ >=dev-libs/slib-2.3.8
+ >=dev-lang/swig-1.3_alpha4
+ >=dev-libs/g-wrap-1.3.4
+ <gnome-base/libglade-2
+ media-libs/gdk-pixbuf
+ <dev-util/guile-1.4.1
+ gnome-base/libghttp
+ nls? ( sys-devel/gettext )"
+
+# these flags to GCC interfere with G_INLINE_FUNC usage in this package
+filter-flags "-fno-inline -finline-functions"
+
+src_compile() {
+ elibtoolize
+ local myconf=""
+
+ use nls \
+ && myconf="--enable-nls" \
+ || myconf="--disable-nls"
+ use postgres \
+ && myconf="${myconf} --enable-sql" \
+ || myconf="${myconf} --disable-sql"
+
+ econf ${myconf}
+
+ MAKEOPTS="${MAKEOPTS} -j1" emake || die # Doesn't work with make -j 4 (hallski)
+}
+
+src_install() {
+ einstall \
+ pkgdatadir=${D}/usr/share/gnucash
+
+ dodoc ABOUT-NLS AUTHORS COPYING ChangeLog HACKING NEWS README* TODO
+}