summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2013-05-22 07:38:57 +0000
committerOle Markus With <olemarkus@gentoo.org>2013-05-22 07:38:57 +0000
commit7fa77a5c5b3e5952f2c00497055e1d778a82dde9 (patch)
tree908276d477902b764e2dbbe445bfe1b13931f5de
parentbump (diff)
downloadgentoo-2-7fa77a5c5b3e5952f2c00497055e1d778a82dde9.tar.gz
gentoo-2-7fa77a5c5b3e5952f2c00497055e1d778a82dde9.tar.bz2
gentoo-2-7fa77a5c5b3e5952f2c00497055e1d778a82dde9.zip
Version bump. Removing miscommitted 5.5 support for older versions
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key C4A92BF5)
-rw-r--r--dev-php/xdebug/ChangeLog8
-rw-r--r--dev-php/xdebug/xdebug-2.2.0.ebuild4
-rw-r--r--dev-php/xdebug/xdebug-2.2.1.ebuild4
-rw-r--r--dev-php/xdebug/xdebug-2.2.2.ebuild4
-rw-r--r--dev-php/xdebug/xdebug-2.2.3.ebuild89
5 files changed, 102 insertions, 7 deletions
diff --git a/dev-php/xdebug/ChangeLog b/dev-php/xdebug/ChangeLog
index 494330addd0a..2e5142af769b 100644
--- a/dev-php/xdebug/ChangeLog
+++ b/dev-php/xdebug/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/xdebug
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug/ChangeLog,v 1.59 2013/04/14 06:27:26 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug/ChangeLog,v 1.60 2013/05/22 07:38:57 olemarkus Exp $
+
+*xdebug-2.2.3 (22 May 2013)
+
+ 22 May 2013; Ole Markus With <olemarkus@gentoo.org> +xdebug-2.2.3.ebuild,
+ xdebug-2.2.0.ebuild, xdebug-2.2.1.ebuild, xdebug-2.2.2.ebuild:
+ Version bump. Removing miscommitted 5.5 support for older versions
*xdebug-2.2.2 (14 Apr 2013)
diff --git a/dev-php/xdebug/xdebug-2.2.0.ebuild b/dev-php/xdebug/xdebug-2.2.0.ebuild
index 4b830902321b..35b17fe3d3a4 100644
--- a/dev-php/xdebug/xdebug-2.2.0.ebuild
+++ b/dev-php/xdebug/xdebug-2.2.0.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug/xdebug-2.2.0.ebuild,v 1.10 2013/04/14 06:27:26 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug/xdebug-2.2.0.ebuild,v 1.11 2013/05/22 07:38:57 olemarkus Exp $
EAPI="4"
PHP_EXT_NAME="xdebug"
PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="yes"
-USE_PHP="php5-5 php5-3 php5-4"
+USE_PHP="php5-3 php5-4"
MY_PV="${PV/_/}"
MY_PV="${MY_PV/rc/RC}"
diff --git a/dev-php/xdebug/xdebug-2.2.1.ebuild b/dev-php/xdebug/xdebug-2.2.1.ebuild
index 21f33ba65ac1..ac5da29f6cc8 100644
--- a/dev-php/xdebug/xdebug-2.2.1.ebuild
+++ b/dev-php/xdebug/xdebug-2.2.1.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug/xdebug-2.2.1.ebuild,v 1.7 2013/04/14 06:27:26 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug/xdebug-2.2.1.ebuild,v 1.8 2013/05/22 07:38:57 olemarkus Exp $
EAPI="4"
PHP_EXT_NAME="xdebug"
PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="yes"
-USE_PHP="php5-5 php5-3 php5-4"
+USE_PHP="php5-3 php5-4"
MY_PV="${PV/_/}"
MY_PV="${MY_PV/rc/RC}"
diff --git a/dev-php/xdebug/xdebug-2.2.2.ebuild b/dev-php/xdebug/xdebug-2.2.2.ebuild
index 013fe811152f..3659dce999d7 100644
--- a/dev-php/xdebug/xdebug-2.2.2.ebuild
+++ b/dev-php/xdebug/xdebug-2.2.2.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug/xdebug-2.2.2.ebuild,v 1.1 2013/04/14 06:27:26 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug/xdebug-2.2.2.ebuild,v 1.2 2013/05/22 07:38:57 olemarkus Exp $
EAPI="5"
PHP_EXT_NAME="xdebug"
PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="yes"
-USE_PHP="php5-5 php5-3 php5-4"
+USE_PHP="php5-3 php5-4"
MY_PV="${PV/_/}"
MY_PV="${MY_PV/rc/RC}"
diff --git a/dev-php/xdebug/xdebug-2.2.3.ebuild b/dev-php/xdebug/xdebug-2.2.3.ebuild
new file mode 100644
index 000000000000..dfddb27be686
--- /dev/null
+++ b/dev-php/xdebug/xdebug-2.2.3.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug/xdebug-2.2.3.ebuild,v 1.1 2013/05/22 07:38:57 olemarkus Exp $
+
+EAPI="5"
+PHP_EXT_NAME="xdebug"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="yes"
+
+USE_PHP="php5-5 php5-3 php5-4"
+
+MY_PV="${PV/_/}"
+MY_PV="${MY_PV/rc/RC}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+inherit php-ext-source-r2
+
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+
+DESCRIPTION="A PHP debugging and profiling extension"
+HOMEPAGE="http://www.xdebug.org/"
+SRC_URI="http://pecl.php.net/get/${PN}-${MY_PV}.tgz"
+LICENSE="Xdebug"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ ~dev-php/xdebug-client-${PV}"
+
+src_install() {
+ dodoc NEWS README CREDITS
+ php-ext-source-r2_src_install
+
+ php-ext-source-r2_addtoinifiles "xdebug.auto_trace" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.trace_output_dir" '"/tmp"'
+ php-ext-source-r2_addtoinifiles "xdebug.trace_output_name" '"trace.%c"'
+ php-ext-source-r2_addtoinifiles "xdebug.trace_format" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.trace_options" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.collect_includes" '"1"'
+ php-ext-source-r2_addtoinifiles "xdebug.collect_params" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.collect_return" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.collect_vars" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.default_enable" '"1"'
+ php-ext-source-r2_addtoinifiles "xdebug.extended_info" '"1"'
+ php-ext-source-r2_addtoinifiles "xdebug.manual_url" '"http://www.php.net"'
+ php-ext-source-r2_addtoinifiles "xdebug.max_nesting_level" '"100"'
+ php-ext-source-r2_addtoinifiles "xdebug.show_exception_trace" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.show_local_vars" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.show_mem_delta" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.COOKIE" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.ENV" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.FILES" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.GET" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.POST" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.REQUEST" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.SERVER" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.SESSION" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump_globals" '"1"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump_once" '"1"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump_undefined" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.profiler_enable" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.profiler_output_dir" '"/tmp"'
+ php-ext-source-r2_addtoinifiles "xdebug.profiler_output_name" '"cachegrind.out.%p"'
+ php-ext-source-r2_addtoinifiles "xdebug.profiler_enable_trigger" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.profiler_append" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.profiler_aggregate" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.remote_enable" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.remote_handler" '"dbgp"'
+ php-ext-source-r2_addtoinifiles "xdebug.remote_host" '"localhost"'
+ php-ext-source-r2_addtoinifiles "xdebug.remote_mode" '"req"'
+ php-ext-source-r2_addtoinifiles "xdebug.remote_port" '"9000"'
+ php-ext-source-r2_addtoinifiles "xdebug.remote_autostart" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.remote_log" '""'
+ php-ext-source-r2_addtoinifiles "xdebug.idekey" '""'
+ php-ext-source-r2_addtoinifiles "xdebug.var_display_max_data" '"512"'
+ php-ext-source-r2_addtoinifiles "xdebug.var_display_max_depth" '"2"'
+ php-ext-source-r2_addtoinifiles "xdebug.var_display_max_children" '"128"'
+
+}
+
+pkg_postinst() {
+ ewarn "We have set xdebug.default_enable to 0 (off), as xdebug can be"
+ ewarn "installed as a dependency, and not all users will want xdebug to be"
+ ewarn "enabled by default. If you want to enable it, you should edit the"
+ ewarn "ini file and set xdebug.default_enable to 1. Alternatively you can"
+ ewarn "call xdebug_enable() in your code."
+}