summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2008-10-07 16:00:07 +0000
committerRob Cakebread <pythonhead@gentoo.org>2008-10-07 16:00:07 +0000
commit7ffdc29d8b64272e5b4101aff828a7f04b693624 (patch)
tree3ef810822b03147f44977a456b62672139c25d32
parentInital commit, bug 240341 (diff)
downloadgentoo-2-7ffdc29d8b64272e5b4101aff828a7f04b693624.tar.gz
gentoo-2-7ffdc29d8b64272e5b4101aff828a7f04b693624.tar.bz2
gentoo-2-7ffdc29d8b64272e5b4101aff828a7f04b693624.zip
Added fields patch file bug #240362
(Portage version: 2.2_rc11/cvs/Linux 2.6.26-gentoo-r1 i686)
-rw-r--r--dev-python/django/ChangeLog6
-rw-r--r--dev-python/django/files/django-1.0-fields.py.patch14
2 files changed, 19 insertions, 1 deletions
diff --git a/dev-python/django/ChangeLog b/dev-python/django/ChangeLog
index 67a492568f3c..4ddcd978c07a 100644
--- a/dev-python/django/ChangeLog
+++ b/dev-python/django/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/django
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/ChangeLog,v 1.26 2008/10/06 18:42:46 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django/ChangeLog,v 1.27 2008/10/07 16:00:06 pythonhead Exp $
+
+ 07 Oct 2008; Rob Cakebread <pythonhead@gentoo.org>
+ +files/django-1.0-fields.py.patch:
+ Added patch file
06 Oct 2008; Rob Cakebread <pythonhead@gentoo.org> django-1.0.ebuild,
django-9999.ebuild:
diff --git a/dev-python/django/files/django-1.0-fields.py.patch b/dev-python/django/files/django-1.0-fields.py.patch
new file mode 100644
index 000000000000..e3bc9d11ed81
--- /dev/null
+++ b/dev-python/django/files/django-1.0-fields.py.patch
@@ -0,0 +1,14 @@
+--- tests/regressiontests/forms/fields.py.old 2008-09-06 11:13:31.000000000 -0700
++++ tests/regressiontests/forms/fields.py 2008-09-06 11:16:06.000000000 -0700
+@@ -1300,9 +1300,10 @@
+ >>> fix_os_paths(path)
+ '.../django/forms/'
+ >>> f = forms.FilePathField(path=path)
++>>> f.choices = [p for p in f.choices if not p[0].endswith('.pyc')]
+ >>> f.choices.sort()
+ >>> fix_os_paths(f.choices)
+-[('.../django/forms/__init__.py', '__init__.py'), ('.../django/forms/__init__.pyc', '__init__.pyc'), ('.../django/forms/fields.py', 'fields.py'), ('.../django/forms/fields.pyc', 'fields.pyc'), ('.../django/forms/forms.py', 'forms.py'), ('.../django/forms/forms.pyc', 'forms.pyc'), ('.../django/forms/models.py', 'models.py'), ('.../django/forms/models.pyc', 'models.pyc'), ('.../django/forms/util.py', 'util.py'), ('.../django/forms/util.pyc', 'util.pyc'), ('.../django/forms/widgets.py', 'widgets.py'), ('.../django/forms/widgets.pyc', 'widgets.pyc')]
++[('.../django/forms/__init__.py', '__init__.py'), ('.../django/forms/fields.py', 'fields.py'), ('.../django/forms/forms.py', 'forms.py'), ('.../django/forms/models.py', 'models.py'), ('.../django/forms/util.py', 'util.py'), ('.../django/forms/widgets.py', 'widgets.py')]
+ >>> f.clean('fields.py')
+ Traceback (most recent call last):
+ ...