summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-06-06 14:23:39 +0000
committerJeroen Roovers <jer@gentoo.org>2013-06-06 14:23:39 +0000
commit825d0cd904f5b6918652930f992b0aa324e8c8d7 (patch)
tree4393cb34faa15418a020f37b31fb04a60d8d096f
parentsci-chemistry/theseus: Version BUmp; fix double prefix (diff)
downloadgentoo-2-825d0cd904f5b6918652930f992b0aa324e8c8d7.tar.gz
gentoo-2-825d0cd904f5b6918652930f992b0aa324e8c8d7.tar.bz2
gentoo-2-825d0cd904f5b6918652930f992b0aa324e8c8d7.zip
Version bump.
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key A792A613)
-rw-r--r--sys-boot/unetbootin/ChangeLog7
-rw-r--r--sys-boot/unetbootin/unetbootin-584.ebuild88
2 files changed, 94 insertions, 1 deletions
diff --git a/sys-boot/unetbootin/ChangeLog b/sys-boot/unetbootin/ChangeLog
index b4319cad6e39..3e53cb8ffb3e 100644
--- a/sys-boot/unetbootin/ChangeLog
+++ b/sys-boot/unetbootin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/unetbootin
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/ChangeLog,v 1.97 2013/03/02 23:34:41 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/ChangeLog,v 1.98 2013/06/06 14:23:39 jer Exp $
+
+*unetbootin-584 (06 Jun 2013)
+
+ 06 Jun 2013; Jeroen Roovers <jer@gentoo.org> +unetbootin-584.ebuild:
+ Version bump.
02 Mar 2013; Markos Chandras <hwoarang@gentoo.org> unetbootin-583.ebuild:
Move Qt dependencies to the new category
diff --git a/sys-boot/unetbootin/unetbootin-584.ebuild b/sys-boot/unetbootin/unetbootin-584.ebuild
new file mode 100644
index 000000000000..a07c13ac929b
--- /dev/null
+++ b/sys-boot/unetbootin/unetbootin-584.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/unetbootin-584.ebuild,v 1.1 2013/06/06 14:23:39 jer Exp $
+
+EAPI=5
+
+inherit eutils qt4-r2
+
+DESCRIPTION="Universal Netboot Installer creates Live USB systems for various OS
+distributions."
+HOMEPAGE="http://unetbootin.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-source-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+UNBI_LINGUAS="
+ am ar ast be bg bn ca cs da de el eo es et eu fa fi fo fr gl he hr hu id it
+ ja lt lv ml ms nan nb nl nn pl pt_BR pt ro ru si sk sl sr sv sw tr uk ur vi
+ zh_CN zh_TW
+"
+
+for lingua in ${UNBI_LINGUAS}; do
+ IUSE="${IUSE} linguas_${lingua}"
+done
+
+S="${WORKDIR}"
+
+DEPEND="dev-qt/qtgui:4"
+RDEPEND="${DEPEND}
+ sys-fs/mtools
+ sys-boot/syslinux
+ app-arch/p7zip"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-581-desktop.patch"
+
+ # QA check in case linguas are added or removed
+ enum() {
+ echo ${#}
+ }
+ [[ $(enum ${UNBI_LINGUAS}) -eq $(( $(enum $(echo ${PN}_*.ts) ) -1 )) ]] \
+ || die "Numbers of recorded and actual linguas do not match"
+ unset enum
+
+ # Make room between the last line of TRANSLATIONS and the next definition
+ sed -i \
+ -e '/^DEFINES/s|.*|\n&|g' \
+ ${PN}.pro || die
+
+ # Remove localisations
+ local lingua
+ for lingua in ${UNBI_LINGUAS}; do
+ if ! use linguas_${lingua}; then
+ sed -i ${PN}.pro -e "/\.*${PN}_${lingua}\.ts.*/d" || die
+ rm ${PN}_${lingua}.ts || die
+ fi
+ done
+}
+
+src_configure() {
+ lupdate ${PN}.pro || die
+ lrelease ${PN}.pro || die
+ eqmake4 ${PN}.pro || die
+}
+
+src_install() {
+ dobin ${PN}
+
+ domenu ${PN}.desktop
+
+ for file in ${PN}*.png; do
+ size="${file/${PN}_}"
+ size="${size/.png}x${size/.png}"
+ insinto /usr/share/icons/hicolor/${size}/apps
+ newins ${file} ${PN}.png
+ done
+
+ local lingua
+ for lingua in ${UNBI_LINGUAS}; do
+ if use linguas_${lingua}; then
+ insinto /usr/share/${PN}
+ doins ${PN}_${lingua}.qm
+ fi
+ done
+}