summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2013-08-20 19:41:46 +0000
committerWilliam Hubbs <williamh@gentoo.org>2013-08-20 19:41:46 +0000
commit83321812bd5a3389a70d85c493e4578bc9a8896e (patch)
treed5e8716caa89c468291bd66a2a08c969d209988b
parentLinux patch 3.0.93. (diff)
downloadgentoo-2-83321812bd5a3389a70d85c493e4578bc9a8896e.tar.gz
gentoo-2-83321812bd5a3389a70d85c493e4578bc9a8896e.tar.bz2
gentoo-2-83321812bd5a3389a70d85c493e4578bc9a8896e.zip
add post install warning for first time installs that the network scripts will use dhcp by default.
(Portage version: 2.2.0/cvs/Linux i686, signed Manifest commit with key 0x30C46538)
-rw-r--r--net-misc/netifrc/netifrc-0.1.ebuild11
-rw-r--r--net-misc/netifrc/netifrc-9999.ebuild13
2 files changed, 21 insertions, 3 deletions
diff --git a/net-misc/netifrc/netifrc-0.1.ebuild b/net-misc/netifrc/netifrc-0.1.ebuild
index 7bbac7be855c..7494b00ca56b 100644
--- a/net-misc/netifrc/netifrc-0.1.ebuild
+++ b/net-misc/netifrc/netifrc-0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/netifrc/netifrc-0.1.ebuild,v 1.1 2013/08/14 06:37:32 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netifrc/netifrc-0.1.ebuild,v 1.2 2013/08/20 19:41:46 williamh Exp $
EAPI=5
@@ -50,3 +50,12 @@ src_compile() {
src_install() {
emake ${MAKE_ARGS} DESTDIR="${D}" install
}
+
+pkg_postinst() {
+ if [[ ! -e "${EROOT}"/etc/conf.d/net && -z $REPLACING_VERSIONS ]]; then
+ elog "The network configuration scripts will use dhcp by"
+ elog "default to set up your interfaces."
+ elog "If you need to set up something more complete, see"
+ elog "${EROOT}/usr/share/doc/${P}/README"
+ fi
+}
diff --git a/net-misc/netifrc/netifrc-9999.ebuild b/net-misc/netifrc/netifrc-9999.ebuild
index ad89e55ed666..5a825fb9e742 100644
--- a/net-misc/netifrc/netifrc-9999.ebuild
+++ b/net-misc/netifrc/netifrc-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/netifrc/netifrc-9999.ebuild,v 1.1 2013/08/14 06:37:32 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netifrc/netifrc-9999.ebuild,v 1.2 2013/08/20 19:41:46 williamh Exp $
EAPI=5
@@ -23,7 +23,7 @@ IUSE=""
DEPEND=""
RDEPEND=">=sys-apps/openrc-0.12
-!<sys-apps/openrc-0.12"
+ !<sys-apps/openrc-0.12"
src_prepare() {
sed -i 's:0444:0644:' mk/sys.mk || die
@@ -50,3 +50,12 @@ src_compile() {
src_install() {
emake ${MAKE_ARGS} DESTDIR="${D}" install
}
+
+pkg_postinst() {
+ if [[ ! -e "${EROOT}"/etc/conf.d/net && -z $REPLACING_VERSIONS ]]; then
+ elog "The network configuration scripts will use dhcp by"
+ elog "default to set up your interfaces."
+ elog "If you need to set up something more complete, see"
+ elog "${EROOT}/usr/share/doc/${P}/README"
+ fi
+}