summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-09-17 04:17:18 +0000
committerJeroen Roovers <jer@gentoo.org>2010-09-17 04:17:18 +0000
commit8737676613a407195d595e424f1b91ee6fc12328 (patch)
treeadb81d53dc86ad830de06739a36a38636455f141
parentRemove unused DEPEND. Respect LDFLAGS (bug #335091), CXX. Fix quoting issue. (diff)
downloadgentoo-2-8737676613a407195d595e424f1b91ee6fc12328.tar.gz
gentoo-2-8737676613a407195d595e424f1b91ee6fc12328.tar.bz2
gentoo-2-8737676613a407195d595e424f1b91ee6fc12328.zip
Respect LDFLAGS (bug #335093), CC, CFLAGS.
(Portage version: 2.2_rc82/cvs/Linux i686)
-rw-r--r--x11-terms/root-tail/ChangeLog7
-rw-r--r--x11-terms/root-tail/root-tail-1.2-r3.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/x11-terms/root-tail/ChangeLog b/x11-terms/root-tail/ChangeLog
index a2b3940c0146..fe6b8f65c135 100644
--- a/x11-terms/root-tail/ChangeLog
+++ b/x11-terms/root-tail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-terms/root-tail
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/root-tail/ChangeLog,v 1.43 2010/01/24 18:58:27 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/root-tail/ChangeLog,v 1.44 2010/09/17 04:17:18 jer Exp $
+
+*root-tail-1.2-r3 (17 Sep 2010)
+
+ 17 Sep 2010; Jeroen Roovers <jer@gentoo.org> +root-tail-1.2-r3.ebuild:
+ Respect LDFLAGS (bug #335093), CC, CFLAGS.
24 Jan 2010; Jeroen Roovers <jer@gentoo.org> metadata.xml:
Remove redundant <name> tag.
diff --git a/x11-terms/root-tail/root-tail-1.2-r3.ebuild b/x11-terms/root-tail/root-tail-1.2-r3.ebuild
new file mode 100644
index 000000000000..e8f88a648353
--- /dev/null
+++ b/x11-terms/root-tail/root-tail-1.2-r3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/root-tail/root-tail-1.2-r3.ebuild,v 1.1 2010/09/17 04:17:18 jer Exp $
+
+EAPI="2"
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Terminal to display (multiple) log files on the root window"
+HOMEPAGE="http://www.goof.com/pcg/marc/root-tail.html"
+SRC_URI="http://www.goof.com/pcg/marc/data/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="kde debug"
+
+RDEPEND="x11-libs/libXext
+ x11-libs/libX11"
+DEPEND="x11-misc/imake
+ app-text/rman
+ x11-misc/gccmakedep
+ x11-libs/libX11
+ x11-proto/xproto"
+
+src_prepare() {
+ use kde && epatch "${FILESDIR}"/${P}-kde.patch
+}
+
+src_configure() {
+ xmkmf -a
+}
+
+src_compile() {
+ sed -i 's:/usr/X11R6/bin:/usr/bin:' Makefile || die "sed Makefile failed"
+ use debug && append-flags -DDEBUG
+ emake \
+ CC=$(tc-getCC) \
+ CCOPTIONS="${CFLAGS}" \
+ EXTRA_LDOPTIONS="${LDFLAGS}" \
+ || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install install.man || die "make install failed"
+ dodoc Changes README
+}