summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-11-28 16:26:33 +0000
committerSamuli Suominen <drac@gentoo.org>2007-11-28 16:26:33 +0000
commit884faf207530d8391d2dba6bcfcc39700d6f07c3 (patch)
tree4362efe1b690c4a1ab89f27ca1af873e69293380
parentFix patches (diff)
downloadgentoo-2-884faf207530d8391d2dba6bcfcc39700d6f07c3.tar.gz
gentoo-2-884faf207530d8391d2dba6bcfcc39700d6f07c3.tar.bz2
gentoo-2-884faf207530d8391d2dba6bcfcc39700d6f07c3.zip
Version bump, applying a -Wl,-z,lazy patch wrt #166221.
(Portage version: 2.1.4_rc3)
-rw-r--r--dev-python/gst-python/ChangeLog8
-rw-r--r--dev-python/gst-python/files/digest-gst-python-0.10.93
-rw-r--r--dev-python/gst-python/files/gst-python-0.10.9-lazy.patch21
-rw-r--r--dev-python/gst-python/gst-python-0.10.9.ebuild51
4 files changed, 82 insertions, 1 deletions
diff --git a/dev-python/gst-python/ChangeLog b/dev-python/gst-python/ChangeLog
index 155731fb683c..eaf4b65f7ff4 100644
--- a/dev-python/gst-python/ChangeLog
+++ b/dev-python/gst-python/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/gst-python
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gst-python/ChangeLog,v 1.30 2007/11/24 13:58:23 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gst-python/ChangeLog,v 1.31 2007/11/28 16:26:32 drac Exp $
+
+*gst-python-0.10.9 (28 Nov 2007)
+
+ 28 Nov 2007; Samuli Suominen <drac@gentoo.org>
+ +files/gst-python-0.10.9-lazy.patch, +gst-python-0.10.9.ebuild:
+ Version bump, applying a -Wl,-z,lazy patch wrt #166221.
24 Nov 2007; Samuli Suominen <drac@gentoo.org>
gst-python-0.10.8-r1.ebuild:
diff --git a/dev-python/gst-python/files/digest-gst-python-0.10.9 b/dev-python/gst-python/files/digest-gst-python-0.10.9
new file mode 100644
index 000000000000..a2b935aa34a0
--- /dev/null
+++ b/dev-python/gst-python/files/digest-gst-python-0.10.9
@@ -0,0 +1,3 @@
+MD5 807e14e8d058445524a34e079bb83048 gst-python-0.10.9.tar.bz2 447963
+RMD160 c58c4cf5ebba7bf52dbc8a6de1d8346050166651 gst-python-0.10.9.tar.bz2 447963
+SHA256 9c04c7c50374bf58c5cc8c30400d2738df3fb43d056bdc441d33d4ce9fb3e4b4 gst-python-0.10.9.tar.bz2 447963
diff --git a/dev-python/gst-python/files/gst-python-0.10.9-lazy.patch b/dev-python/gst-python/files/gst-python-0.10.9-lazy.patch
new file mode 100644
index 000000000000..880d5508b2ee
--- /dev/null
+++ b/dev-python/gst-python/files/gst-python-0.10.9-lazy.patch
@@ -0,0 +1,21 @@
+diff -ur gst-python-0.10.9.orig/configure.ac gst-python-0.10.9/configure.ac
+--- gst-python-0.10.9.orig/configure.ac 2007-11-28 11:33:05.000000000 +0200
++++ gst-python-0.10.9/configure.ac 2007-11-28 18:09:48.000000000 +0200
+@@ -363,6 +363,17 @@
+
+ AG_GST_VALGRIND_CHECK
+
++AC_MSG_CHECKING([whether $LD accepts -z,lazy])
++case `$LD -z,lazy -v 2>&1 </dev/null` in
++*GNU* | *'with BFD'*)
++ LDFLAGS="$LDFLAGS -Wl,-z,lazy"
++ AC_MSG_RESULT([yes])
++ ;;
++*)
++ AC_MSG_RESULT([no])
++ ;;
++esac
++
+ AC_OUTPUT([
+ Makefile
+ codegen/Makefile
diff --git a/dev-python/gst-python/gst-python-0.10.9.ebuild b/dev-python/gst-python/gst-python-0.10.9.ebuild
new file mode 100644
index 000000000000..d1e018141631
--- /dev/null
+++ b/dev-python/gst-python/gst-python-0.10.9.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gst-python/gst-python-0.10.9.ebuild,v 1.1 2007/11/28 16:26:32 drac Exp $
+
+NEED_PYTHON=2.3
+
+inherit autotools eutils multilib python
+
+DESCRIPTION="A Python Interface to GStreamer"
+HOMEPAGE="http://gstreamer.freedesktop.org"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0.10"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/pygtk-2.6.3
+ >=dev-libs/glib-2.8
+ >=x11-libs/gtk+-2.6
+ >=dev-python/pygobject-2.11.2
+ >=media-libs/gstreamer-0.10.2
+ >=media-libs/gst-plugins-base-0.10.0.2
+ dev-libs/libxml2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-text/xmlto )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-lazy.patch
+ AT_M4DIR="common/m4" eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ docinto examples
+ cp -pPR examples/* "${D}"/usr/share/doc/${PF}/examples
+ prepalldocs
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize "${ROOT}"usr/$(get_libdir)/python${PYVER}/site-packages/gst-0.10
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}