summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-12-27 16:58:56 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-12-27 16:58:56 +0000
commit8ae155325c8d0081e5bf9458b5dfffa3d215cb96 (patch)
treec1d2f1862c95f0dc314732c3f4c537aeb8983246
parentFluxbox is a spiffed up version of Blackbox (diff)
downloadgentoo-2-8ae155325c8d0081e5bf9458b5dfffa3d215cb96.tar.gz
gentoo-2-8ae155325c8d0081e5bf9458b5dfffa3d215cb96.tar.bz2
gentoo-2-8ae155325c8d0081e5bf9458b5dfffa3d215cb96.zip
removed objprelink globally
-rw-r--r--eclass/kde.eclass30
-rw-r--r--x11-libs/qt-x11/qt-x11-3.0.1-r1.ebuild4
2 files changed, 4 insertions, 30 deletions
diff --git a/eclass/kde.eclass b/eclass/kde.eclass
index 3baa0fb8ce32..dae57001e9b9 100644
--- a/eclass/kde.eclass
+++ b/eclass/kde.eclass
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde.eclass,v 1.24 2001/12/24 20:54:31 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde.eclass,v 1.25 2001/12/27 16:58:56 drobbins Exp $
# The kde eclass is inherited by all kde-* eclasses. Few ebuilds inherit straight from here.
inherit autoconf base || die
ECLASS=kde
@@ -10,7 +10,7 @@ DESCRIPTION="Based on the $ECLASS eclass"
HOMEPAGE="http://www.kde.org/"
-DEPEND="$DEPEND objprelink? ( >=dev-util/objprelink-0-r1 )"
+DEPEND="$DEPEND"
# resolution function: kde version -> qt version
# wish we had something like python dictionaries here :-)
@@ -32,30 +32,6 @@ qtver-from-kdever() {
}
-kde-objprelink-patch() {
- debug-print-function $FUNCNAME $*
- if [ "`use objprelink`" ]; then
- cd ${S} || die
- patch -p0 < /usr/share/objprelink/kde-admin-acinclude.patch || die
- patched=false
-
- for x in Makefile.cvs admin/Makefile.common
- do
- if ! $patched
- then
- if [ -f $x ]
- then
- echo "patching file $x (kde-objprelink-patch)" && make -f $x && patched=true || die
- fi
- fi
- done
-
- $patched || echo "??? Warning: kde-objprelink-patch: patch not applied, makefile not found"
-
- fi
-
-}
-
kde_src_compile() {
debug-print-function $FUNCNAME $*
@@ -73,7 +49,7 @@ kde_src_compile() {
fi
myconf="$myconf --host=${CHOST} --with-x --enable-mitshm --with-xinerama --prefix=/usr --with-qt-dir=${QTDIR}"
use qtmt && myconf="$myconf --enable-mt"
- use objprelink && myconf="$myconf --enable-objprelink" || myconf="$myconf --disable-objprelink"
+ myconf="$myconf --disable-objprelink"
debug-print "$FUNCNAME: myconf: set to ${myconf}"
;;
configure)
diff --git a/x11-libs/qt-x11/qt-x11-3.0.1-r1.ebuild b/x11-libs/qt-x11/qt-x11-3.0.1-r1.ebuild
index 16e3afdde714..3f0a0b565a80 100644
--- a/x11-libs/qt-x11/qt-x11-3.0.1-r1.ebuild
+++ b/x11-libs/qt-x11/qt-x11-3.0.1-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-x11/qt-x11-3.0.1-r1.ebuild,v 1.1 2001/12/18 21:45:02 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-x11/qt-x11-3.0.1-r1.ebuild,v 1.2 2001/12/27 16:58:56 drobbins Exp $
P=qt-x11-${PV}
S=${WORKDIR}/qt-x11-free-${PV}
@@ -15,7 +15,6 @@ DEPEND=">=media-libs/libpng-1.0.9
>=media-libs/libmng-1.0.0
opengl? ( virtual/opengl virtual/glu )
nas? ( >=media-libs/nas-1.4.1 )
- objprelink? ( dev-util/objprelink )
mysql? ( >=dev-db/mysql-3.2.10 )
odbc? ( >=dev-db/unixODBC-2.0 )
virtual/x11"
@@ -38,7 +37,6 @@ src_unpack() {
# cat tmp tmp2 > qmake.conf
# rm tmp tmp2
- use objprelink && patch -p0 < ${FILESDIR}/qt-x11-3.0.1-objprelink.patch
cd ${S}
mv tools/assistant/helpdialogimpl.cpp tools/assistant/helpdialogimpl.cpp_orig