summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2008-07-07 14:42:38 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2008-07-07 14:42:38 +0000
commit8b6d572a5ce3772faaaf218ce0ad475a238a3b5c (patch)
treede269865363d38a5de26754ae079e2639e840f1b
parent- cross compile love (diff)
downloadgentoo-2-8b6d572a5ce3772faaaf218ce0ad475a238a3b5c.tar.gz
gentoo-2-8b6d572a5ce3772faaaf218ce0ad475a238a3b5c.tar.bz2
gentoo-2-8b6d572a5ce3772faaaf218ce0ad475a238a3b5c.zip
Version bumped. Create file in /etc/modprobe.d instead of /etc/modules.d now, else it will be ignored by modules-update.
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-tuxonice-r6 i686)
-rw-r--r--media-video/dxr3config/ChangeLog11
-rw-r--r--media-video/dxr3config/dxr3config-0.3.4.ebuild36
-rw-r--r--media-video/dxr3config/files/dxr3config-0.3.4-modprobed.diff11
3 files changed, 56 insertions, 2 deletions
diff --git a/media-video/dxr3config/ChangeLog b/media-video/dxr3config/ChangeLog
index a27f30ea3a3f..214ec8cd2e0b 100644
--- a/media-video/dxr3config/ChangeLog
+++ b/media-video/dxr3config/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/dxr3config
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/dxr3config/ChangeLog,v 1.5 2007/11/27 11:46:38 zzam Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/dxr3config/ChangeLog,v 1.6 2008/07/07 14:42:38 zzam Exp $
+
+*dxr3config-0.3.4 (07 Jul 2008)
+
+ 07 Jul 2008; Matthias Schwarzott <zzam@gentoo.org>
+ +files/dxr3config-0.3.4-modprobed.diff, +dxr3config-0.3.4.ebuild:
+ Version bumped. Create file in /etc/modprobe.d instead of /etc/modules.d
+ now, else it will be ignored by modules-update.
27 Nov 2007; Matthias Schwarzott <zzam@gentoo.org>
dxr3config-0.3.2.ebuild:
diff --git a/media-video/dxr3config/dxr3config-0.3.4.ebuild b/media-video/dxr3config/dxr3config-0.3.4.ebuild
new file mode 100644
index 000000000000..b44635884484
--- /dev/null
+++ b/media-video/dxr3config/dxr3config-0.3.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/dxr3config/dxr3config-0.3.4.ebuild,v 1.1 2008/07/07 14:42:38 zzam Exp $
+
+inherit eutils
+
+MY_PV="${PV/./-}"
+MY_P="${PN}${MY_PV/./-}"
+
+DESCRIPTION="a small tool, which helps you to find the appropriate module parameters for a dxr3-mpeg card."
+HOMEPAGE="http://free.pages.at/wicky4vdr"
+SRC_URI="http://free.pages.at/wicky4vdr/download/${MY_P}.tgz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-util/dialog
+ media-video/em8300-modules"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-modprobed.diff"
+ sed -i -e 's:DIST="debian":DIST="gentoo":' usr/sbin/${PN}
+}
+
+src_install() {
+ newsbin usr/sbin/${PN} ${PN}
+ insinto /usr/share/${PN}
+ doins usr/share/${PN}/${PN}.m2v
+}
diff --git a/media-video/dxr3config/files/dxr3config-0.3.4-modprobed.diff b/media-video/dxr3config/files/dxr3config-0.3.4-modprobed.diff
new file mode 100644
index 000000000000..c781b9a95b29
--- /dev/null
+++ b/media-video/dxr3config/files/dxr3config-0.3.4-modprobed.diff
@@ -0,0 +1,11 @@
+--- usr/sbin/dxr3config.orig 2008-07-07 16:31:12.073930409 +0200
++++ usr/sbin/dxr3config 2008-07-07 16:32:24.277256585 +0200
+@@ -148,7 +148,7 @@
+ modprobed="/etc/modprobe.d";;
+ gentoo) genModprobe="true";
+ modify="false";
+- modprobed="/etc/modules.d";;
++ modprobed="/etc/modprobe.d";;
+ esac
+ }
+